OVH Community, votre nouvel espace communautaire.

Besoin d'aide avec HTAccess et redirection vers sous répertoire


nicolas35
19/10/2011, 09h10
[QUOTE=Gaston_Phone;456228]/www/.htaccess ou /www/index.php.

Merci Gaston cela fonctionne avec .htaccess

Gaston_Phone
18/10/2011, 23h10
/www/.htaccess ou /www/index.php.

Edit : Il est inutile de citer intégralement ma réponse. Cela alourdit la lecture.

nicolas35
18/10/2011, 23h07
Merci de ta réponse Gaston mais qu'il s'agisse du htaccess, du htm ou de l'index PHP, de quels fichiers s'agit-il ? De ceux installés dans le dossier WWW ou dans le sous répertoire qui pose problème : WordPress3 ?


Citation Envoyé par Gaston_Phone
Redirection systématique vers le dossier : /www/Dossier1

Il existe trois solutions :

Solution 1 - .htaccess :
Code PHP:
Options -Indexes
Options 
-Multiviews
Options 
+FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On
RewriteCond 
%{REQUEST_URI} !^/Dossier1
RewriteRule 
^(.*)$ Dossier1/$
Solution 2 - index.htm : (Compatible avec google6xxxxxxx.html)
Code PHP:
DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<
html>
<
head>
  <
titlexxxxxx title>
  <
meta http-equiv="Content-Type"  content="text/html; charset=iso-8859-1">
  <
meta name="Description"  content="xxxxxx ">
  <
meta name="keywords"     content="xxxxxx ">
  <
meta http-equiv="refresh" content="0; url=http://www.TonDomaine.com/Dossier1/">
head>
<
body>
body>
html
Solution 3 - index.php : (Compatible avec google6xxxxxxx.html)
Code PHP:
         header('HTTP/1.1 301 Moved Permanently');
         
header('Location: http://www.TonDomaine.com/Dossier1/');
?>
Important : Sous Windows, utiliser de préférence notepad.exe pour éditer les fichiers .htaccess, index.htm et index.php.

Des pistes :
- Guide OVH : http://guides.ovh.com/HtaccessProtection
- Guide OVH : http://guides.ovh.com/HtaccessAutre
- Autre Guide : http://www.webmaster-hub.com/publica...reecriture-des
- Autre Guide : http://www.urlrewriting.fr/
- Autre Guide : Chainage de fichiers .htaccess : http://www.helicontech.com/articles/...ewrite-part-2/

Gaston_Phone
18/10/2011, 22h10
Redirection systématique vers le dossier : /www/Dossier1

Il existe trois solutions :

Solution 1 - .htaccess :
Code PHP:
Options -Indexes
Options 
-Multiviews
Options 
+FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On
RewriteCond 
%{REQUEST_URI} !^/Dossier1
RewriteRule 
^(.*)$ Dossier1/$
Solution 2 - index.htm : (Compatible avec google6xxxxxxx.html)
Code PHP:
DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<
html>
<
head>
  <
titlexxxxxx title>
  <
meta http-equiv="Content-Type"  content="text/html; charset=iso-8859-1">
  <
meta name="Description"  content="xxxxxx ">
  <
meta name="keywords"     content="xxxxxx ">
  <
meta http-equiv="refresh" content="0; url=http://www.TonDomaine.com/Dossier1/">
head>
<
body>
body>
html
Solution 3 - index.php : (Compatible avec google6xxxxxxx.html)
Code PHP:
         header('HTTP/1.1 301 Moved Permanently');
         
header('Location: http://www.TonDomaine.com/Dossier1/');
?>
Important : Sous Windows, utiliser de préférence notepad.exe pour éditer les fichiers .htaccess, index.htm et index.php.

Des pistes :
- Guide OVH : http://guides.ovh.com/HtaccessProtection
- Guide OVH : http://guides.ovh.com/HtaccessAutre
- Autre Guide : http://www.webmaster-hub.com/publica...reecriture-des
- Autre Guide : http://www.urlrewriting.fr/
- Autre Guide : Chainage de fichiers .htaccess : http://www.helicontech.com/articles/...ewrite-part-2/

nicolas35
18/10/2011, 21h57
Je prévois de mettre en ligne un blog prochainement. Ovh m’a indiqué la procédure à suivre pour que l’adresse définitive corresponde bien à l’url : www.monsite.com et non à la page site en construction par le biais de cette procédure : : http://border-labs.fr/?p=41. Jusque là tout va bien…pour la page principale du moins. Pour le reste rien ne fonctionne : ni les autres pages, ni les articles ne sont éditables (par exemple : http://www.monsite.com/contact). Ils renvoient tous sur une page du style : oups ce lien semble brisé. Une fois le site repassé sur une url du type http://monsite.com/wordpress3/contact, cela fonctionne. Le support OVH m’a expliqué qu’il fallait faire une redirection 301 en modifiant le fichier HTaccess situé à la racine du dossier www, le probléme viendrait du sous répertoire : « Il faut placer Redirect permanent /ancien_repertoire http://nouveau-site.tld/nouveau_repertoire dans le fichier .htacces qui se trouve à la racine de votre hébergement c'est-à-dire dans le répertoire www. »
Hélas ça ne fonctionne pas !....Quelqu’un connait-il la solution ?