OVH Community, votre nouvel espace communautaire.

Redirection en .htaccess vers un sous dossier impossible


Gaston_Phone
18/10/2011, 08h42
Depuis chez moi, tout semble OK à l’exception de ce que tu ouvres un 2ème onglet ou un 2ème navigateur.

raphsauv
18/10/2011, 00h31
J'ai des onglets en haut Galerie etc et ça ouvre une autre page quand je suis à la racine mais pas quand je suis en index.php

Gaston_Phone
17/10/2011, 21h21
Citation Envoyé par raphsauv
J'aimerais aussi faire une redirection http://www.crystal-event.fr en http://www.crystal-event.fr/index.php car j'ai certain onglet quand je suis sur http://www.crystal-event.fr m'ouvre une autre page mais pas en index.php.
Quelle autre page ?
Des détails ?

raphsauv
17/10/2011, 19h12
J'ai rajouté ça aussi mais toujours rien
RewriteEngine on

raphsauv
17/10/2011, 18h57
ça n'a pas marché =S

ekozan
17/10/2011, 18h49
Google it ...

RewriteRule ^index\.php$ http://www.crystal-event.fr [L,R=301]

raphsauv
17/10/2011, 18h42
Hello

J'aimerais aussi faire une redirection http://www.crystal-event.fr en http://www.crystal-event.fr/index.php car j'ai certain onglet quand je suis sur http://www.crystal-event.fr m'ouvre une autre page mais pas en index.php.

Comment puis-je procéder avec le fichier htaccess ?

Merci

Oworyn
16/10/2011, 22h38
Merci beaucoup !

Gaston_Phone
16/10/2011, 22h36
C'est pour cela je préfère la Solution 3 - index.php :
Code PHP:
         header('HTTP/1.1 301 Moved Permanently');
         
header('Location: http://www.TonDomaine.com/portail/');
?>

ekozan
16/10/2011, 22h33
Options -Indexes
Options -Multiviews
Options +FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On
RewriteCond %{REQUEST_URI} !^/gestion
RewriteCond %{REQUEST_URI} !^/portail
RewriteRule ^(.*)$ portail/$1

Oworyn
16/10/2011, 22h27
Il subsiste un problème auquel je n'avais pas pensé.
Je m'explique : ce htaccess redirige l'intégralité des requêtes vers le dossier /portail. Cependant, il existe un dossier /gestion qui n'est pas accessible à tous les utilisateurs mais auquel je dois pouvoir accéder qui, du fait du htaccess, ne fonctionne plus. Comment contourner cela ?

Gaston_Phone
15/10/2011, 17h48
Non cela ne règlera pas le problème du www, mais il faut savoir rebondir sur un problème.
Où alors déplacer tout le contenu de /www/Portrait dans /www.

Oworyn
15/10/2011, 14h52
Je suis sous Wordpress, et ça risque de s'avérer compliqué !
Mais cette solution ne réglerai pas le problème du www, je me trompe ?

Gaston_Phone
15/10/2011, 13h08
Remplace le nom du dossier "portail" par un à trois mots clés de ton sites séparés par le signe mois et le tour sera joué.
De plus, cerise sur le gâteau, tu améliorera ton référencement.

Oworyn
15/10/2011, 12h40
Merci pour vos réponses !
Lorsque je mets un htaccess avec le code suivant, ça fonctionne :
Code:
Options -Indexes
Options -Multiviews
Options +FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On
RewriteCond %{REQUEST_URI} !^/portail
RewriteRule ^(.*)$ portail/$1
En revanche, l'ajout des deux lignes suivantes empêche la redirection :
Code:
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
J'ai donc mis mon fichier de vérification ... à la racine et dans le dossier /portail, sachant que celui-ci est, pour google, à la racine du site !
En revanche, cela m'affiche, lorsque la redirection marche, une adresse du type monsite.fr. Or, je souhaiterais une adresse du type ... www.monsite.fr. Avez-vous une solution !
Merci beaucoup !

ekozan
15/10/2011, 10h45
la solution 1 est aussi compatible x') ... plaçant le fichier vérif de google dans le dossier1

ou en ajoutant

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

-> http://3ko.fr/c/s

Gaston_Phone
14/10/2011, 23h58
Redirection systématique vers le dossier : /www/Dossier1

Il existe trois solutions :

Solution 1 - .htaccess :
Code PHP:
Options -Indexes
Options 
-Multiviews
Options 
+FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5
RewriteEngine On
RewriteCond 
%{REQUEST_URI} !^/Dossier1
RewriteRule 
^(.*)$ Dossier1/$
Solution 2 - index.htm : (Compatible avec google6xxxxxxx.html)
Code PHP:
DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN" "http://www.w3.org/TR/html4/frameset.dtd">
<
html>
<
head>
  <
titlexxxxxx title>
  <
meta http-equiv="Content-Type"  content="text/html; charset=iso-8859-1">
  <
meta name="Description"  content="xxxxxx ">
  <
meta name="keywords"     content="xxxxxx ">
  <
meta http-equiv="refresh" content="0; url=http://www.TonDomaine.com/Dossier1/">
head>
<
body>
body>
html
Solution 3 - index.php : (Compatible avec google6xxxxxxx.html)
Code PHP:
         header('HTTP/1.1 301 Moved Permanently');
         
header('Location: http://www.TonDomaine.com/Dossier1/');
?>
Important : Sous Windows, utiliser de préférence notepad.exe pour éditer les fichiers .htaccess, index.htm et index.php.

Des pistes :
- Guide OVH : http://guides.ovh.com/HtaccessProtection
- Guide OVH : http://guides.ovh.com/HtaccessAutre
- Autre Guide : http://www.webmaster-hub.com/publica...reecriture-des
- Autre Guide : http://www.urlrewriting.fr/
- Autre Guide : Chainage de fichiers .htaccess : http://www.helicontech.com/articles/...ewrite-part-2/

Oworyn
14/10/2011, 22h40
Bonjour,
J'ai précédemment déménagé mon installation de wordpress depuis le dossier www vers le dossier portail de mon site web.
Or, je ne sais pas comment m'y prendre, j'obtiens des boucles infinies ou des erreurs 500 : sans doute un problème de syntaxe.
En effet, jusqu'à présent, j'utilisais (temporairement) une redirection en PHP. Mais cela pose des problèmes : mon site n'est plus référencé sur aucun moteur de recherche.
Deux questions : comment faire cette redirection proprement et à quoi est du ce problème de référencement ?
Merci d'avance,
Oworyn