OVH Community, votre nouvel espace communautaire.

serveur maison + domaine ovh + ddclient + multisousdomaine..


cassiopee
20/07/2011, 08h00
Content pour toi

dredtrake
20/07/2011, 00h00
Hello,
bon merci infiniment pour ce coup de main car la ça fonctionne (du moins ça en à tout l'air), c'est vrai que j'ai pas trop tilté en voyant cette histoire de cnam malgrès l'avoir sans doute vu 1000 fois (la page ovh à ce sujet) ....
bref, grand merci a toi cassiopee.

cassiopee
19/07/2011, 07h41
Tu pourrais essayer l'approche "CNAME" évoqué tout en bas de cette page
(paragraphe "Conseils si vous avez plusieurs DynHOST") :

http://guide.ovh.com/DynDns

Dans ce guide il s'agit de mettre en oeuvre plusieurs noms de domaines
mais même si tu n'en utilises qu'un seul, le principe reste identique.

www.ton_domaine.fr est associée à l'IP dynamique de ta NeufBox
forum.ton_domaine.fr est un CNAME de www.ton_domaine.fr
webmail.ton_domaine.fr est un CNAME de www.ton_domaine.fr

par exemple.

dredtrake
18/07/2011, 22h52
bonsoir,
donc après une série de test et je confirme bien que "use=web, web=checkip.dyndns.com/, web-skip='IP Address'" ne fonctionne pas mieux que dans mon cas de figure... il ne récupère jamais l'ip.
mais j'insiste sur le fait que cela fonctionne bien pour un seul sous domaine à la fois et que dès que l'on en met plus de un, c'est cuit..ça ne fonctionne plus....
c'est vraiment embêttant car je ne suis pas derrière ma neuf box pour savoir quand elle change d'ip,
de plus partant prochainement en vacance j'aimerais bien pouvoir profiter de mon serveur sans avoir à faire des pieds et des mains pour récup mon ip...

bref, a vot' bon coeur msieurs dames....

dredtrake
14/07/2011, 15h32
Hello et merci pour ta réponse,
En fait comme je dit dans mon post précédent en simple (sous-)domaine cela fonctionne et dès que j'en met plus de un cela ne fonctionne plus
j'avais testé la ligne en question "use=web, web=checkip.dyndns.com/, web-skip='IP Address' " mais j'avais pas plus de succès.
En mode "use=web" l'ip est bien transmise (bien que je ne sais comment?)

Je vais retester cela dits, et je te tiens informé...

merci

Freemaster
14/07/2011, 08h18
salut,
puisque tu utilises le type use=web
il faudrait lui indiquer comment récupérer ton ip...

donc :
use=web, web=checkip.dyndns.com/, web-skip='IP Address'

me parait bien

dredtrake
13/07/2011, 23h51
bon jour tout d'abord,
donc je pense que tout est dit dans le titre,
à savoir si dans ma conf je ne met que un seul domaine cela fonctionne...
j'ai une neuf box, un domaine chez ovh, un serveur à la maison.
tout mes sous domaines sont config en dynhost, ainsi que un user dynhost dans mon admin ovh.
tout ces sous domaines fonctionnent en solo...
ci joint ma conf :

Code PHP:
# Configuration file for ddclient generated by debconf
#
# /etc/ddclient.conf

pid=/var/run/ddclient.pid
cache
=/tmp/ddclient.cache
protocol
=dyndns2
#use=if, if=eth0
#use=web, web=checkip.dyndns.com/, web-skip='IP Address'
use=web
server
=www.ovh.com
login
=xxxx
password
='xxxxx'
# ne fonctionne pas
#domaine.com,sousdomaine1.domaine.com,sousdomaine2.domaine.com,sousdomaine3.domaine.com
#fonctionne si juste un seul sous domaine est listé...
sousdomaine1.domaine.com 
si quelqu'un à une idée je suis preneur, car là ça fait des mois que je traine ce problème depuis un bon moment et j'ai beau chercher (dans le peu de doc dispo à ce sujet) je sèche un peu...

d'avance merci !