OVH Community, votre nouvel espace communautaire.

Echec de validation DNS sous Google Apps avec la méthode Enregistrement type CNAME


alibam
15/05/2011, 13h00
--edite---

afoehne
12/05/2011, 16h55
Citation Envoyé par fritz2cat
hou là... est-ce encore permis de montrer des signes religieux de notre belle tradition européenne ?

allez hop une petite pour la route.
Je fais juste ici une petite correction : c'est pas 3 fois Allah que l'on psalmodie lors de la prière des défunts, mais 4 !

Quoique on puisse parfaitement comprendre pourquoi ils auraient oublié le quatrième couplet...

Par ailleurs, sans doute ont-ils du s'appesantir un peu sur le premier...

On dit quatre fois de suite: «Allàhou akbar».
  1. Après la première fois on dit: «Je me mets sous la protection de Dieu contre le Diable lapidé»
  2. Après la deuxième fois on dit: «Seigneur Dieu! Bénis Mohammad et ceux qui appartiennent à Mohammad»
  3. Après la troisième fois on invoque Dieu pour le mort et pour les Musulmans
  4. Après la quatrième fois on invoque Dieu et de préférence comme suit: «Seigneur Dieu! Ne nous prive pas de son salaire et ne nous tente pas après lui. Absous-nous ainsi que lui»
Voir la source ici.

Ces gens de la CIA n'étaient donc pas de vrais musulmans. Quand on vous dit que les américains sont les rois du mensonge et de la propagande !

fritz2cat
12/05/2011, 15h59
Citation Envoyé par afoehne
Il faut que je pense à faire brûler un cierge pour Frédéric... Aurait-il déjà un ex-voto quelque part dans une église ?
hou là... est-ce encore permis de montrer des signes religieux de notre belle tradition européenne ?

allez hop une petite pour la route.
La C.I.A a prié 3 fois Allah avant de balancer le corps à la flotte. Ils se sont mis de part et d'autre du cadavre drapé dans un linceul blanc, et puis Allah une, Allah deux et Allah trois.

fritz2cat
12/05/2011, 15h54
Morale de l'histoire:

- envoyer des informations vraies (montrer un vrai nom de domaine et non "mon-domaine.com")
- envoyer des photos d'écran et toutes pièces probantes

Seules ces deux conditions ont permis de débusquer l'erreur.

Frédéric

afoehne
12/05/2011, 15h41
Merci Frédéric, c'était effectivement la solution !

Mes cinq domaines ont été reconnus par Google en 5 x 60 secondes exactement (pas les 24 ou 48 heures escomptées dans les mises en garde qui foisonnent sur la toile à ce sujet). OVH a visiblement bien amélioré la fréquence de rafraîchissement des configurations de ses serveurs.

Par ailleurs, la méthode CNAME semble être une ancienne procédure de validation qui ne figure plus dans les méthodes proposées par Google. Mais on tombe toujours sur des discussions qui en font état quand on fait des recherches sur le web. C'est ainsi que la confusion est née.

Cette discussion peut donc être clôturée.

J'en profite pour préciser aux futurs visiteurs que la méthode DNS TXT est la seule méthode utilisable actuellement pour ceux qui souhaiteraient ouvrir un compte Google Apps, mais qui n'auraient encore aucun site hébergé utilisant le même nom de domaine.

Par ailleurs, il faut rester simple lors du suivi de cette procédure DNS TXT. C'est à dire :

  1. Copier bêtement la totalité de la variable et non pas seulement son préfixe situé à droite du signe = tel que proposé sur la page Google
  2. Dans la page de configuration zone DNS d'OVH, cliquer sur la rubrique TXT
  3. Ne rien mettre dans le champs intitulé "Sous-domaine"
  4. Coller le contenu du presse-papier de sorte que la variable proposée par Google figure intégralement


Merci également à tous les participant pour leur aide généreuse.

Il faut que je pense à faire brûler un cierge pour Frédéric... Aurait-il déjà un ex-voto quelque part dans une église ?

Gaston_Phone
12/05/2011, 15h38
Citation Envoyé par fritz2cat
Ce coup-ci comme Gaston, je ne comprends plus rien et je le rejoins dans un transat voisin. Ce ne sera plus la transat en solitaire
Hum! Hum! Hum! Le spécialiste du transat et de la chaise longue c'est ... moi.

fritz2cat
12/05/2011, 15h14
Citation Envoyé par afoehne
J'en étais resté à la méthode CNAME où il était nécessaire d'enlever le préfixe de cette variable.
Quelle méthode CNAME ? Je n'ai rien vu de tel dans les pages d'aide Google.

Ce coup-ci comme Gaston, je ne comprends plus rien et je le rejoins dans un transat voisin. Ce ne sera plus la transat en solitaire

Frédéric

afoehne
12/05/2011, 14h31
Citation Envoyé par fritz2cat
Dans les instructions sur le printscreen posté chez Free, il me semble lire que l'enregistrement TXT doit contenir "google-site-verification=6G....."

Pourquoi as-tu enlevé "google-site-verification=" ???

Frédéric
Houla, je crois que tu tiens le morceau !!!!

J'en étais resté à la méthode CNAME où il était nécessaire d'enlever le préfixe de cette variable. Sans doute as-tu raison, avec la méthode TXT, les instructions de Google suggère le contraire....
Comme quoi, la rémanence rétiniène peut tromper la mémoire en se substituant à l'évidence....

Je vais corriger tout ça et je reviens tout à l'heure....

afoehne
12/05/2011, 14h25
Citation Envoyé par fritz2cat
C'est pourtant clair chez Google:


Par contre le titre de cette discussion contient "CNAME" et ça ce n'est documenté nulle part chez Google.

Frédéric
-> Add a meta tag to my home page : I can't, I've no web site
-> Upload an HTML file with the name you specify to your server : I doubt, am I able to do that on OVH with no hosting ?
-> Add a DNS TXT record. I feel able to do that
-> Add the Google Analytics code you use to track your site. I can't, I've no web site

J'aurai effectivement du mettre TEXT dans le titre au lieu de CNAME. Peut-on remédier à ça ?

fritz2cat
12/05/2011, 14h20
Dans les instructions sur le printscreen posté chez Free, il me semble lire que l'enregistrement TXT doit contenir "google-site-verification=6G....."

Pourquoi as-tu enlevé "google-site-verification=" ???

Frédéric

fritz2cat
12/05/2011, 14h15
C'est pourtant clair chez Google:

How to verify your site
To verify that you own a site, you have a number of options. You can:

-> Add a meta tag to your home page (proving that you have access to the source files). To use this method, you must be able to edit the HTML code of your site's pages.

-> Upload an HTML file with the name you specify to your server. To use this method, you must be able to upload new files to your server.

-> Add a DNS TXT record. To use this method, you must be able to sign in to your domain registrar or hosting provider and add a new DNS record.

-> Add the Google Analytics code you use to track your site. To use this option, you must be an administrator on the Google Analytics account, and the tracking code must use the new asynchronous snippet.

Webmaster Tools will check to see that the specified tag, file, record, or code is present. If it is, we consider you a site owner and will show you site details.
Par contre le titre de cette discussion contient "CNAME" et ça ce n'est documenté nulle part chez Google.

Frédéric

afoehne
12/05/2011, 14h13
Citation Envoyé par fritz2cat
La copie d'écran (celle de Google, pas le webmail OVH...) montre qu'ils ont bien été chercher ton enregistrement TXT et celui-ci contient bien la même chose que ce que j'ai récupéré.

Ca veut dire que la méthode a l'air juste.

Es-tu certain d'avoir bien retranscrit la totalité de la chaîne de caractères à insérer dans l'enregistrement TXT ? Il ne manque rien au début ou à la fin ?

Pour faire plaisir à Gaston, tu peux mettre 127.0.0.1 comme adresse pour ton site web puisque tu n'as pas d'hébergement

Frédéric
Oui, j'ai fait un copier/coller. D'ailleurs, sur cette nouvelle image, on voit bien que la variable d'origine et la variable cible sont les mêmes.

fritz2cat
12/05/2011, 14h11
http://www.google.com/support/webmas...answer=35638#4 ?

Frédéric

Gaston_Phone
12/05/2011, 14h07
Citation Envoyé par fritz2cat
Pour faire plaisir à Gaston, tu peux mettre 127.0.0.1 comme adresse pour ton site web puisque tu n'as pas d'hébergement
Là je ne comprends plus rien à ce douloureux problème et part donc faire ma sieste dans un transat.

Gaston_Phone
12/05/2011, 14h05
C'est bien ce je dis depuis le début.

Pour le moment, règle d'abord ce problème "Purement OVH" d'accès à ton site avec un navigateur et l'URL http://www.interhomines.com/.

Après seulement, tu pourras te préoccuper de GOOGLE (et seulement après).

fritz2cat
12/05/2011, 14h04
La copie d'écran (celle de Google, pas le webmail OVH...) montre qu'ils ont bien été chercher ton enregistrement TXT et celui-ci contient bien la même chose que ce que j'ai récupéré.

Ca veut dire que la méthode a l'air juste.

Es-tu certain d'avoir bien retranscrit la totalité de la chaîne de caractères à insérer dans l'enregistrement TXT ? Il ne manque rien au début ou à la fin ?

Pour faire plaisir à Gaston, tu peux mettre 127.0.0.1 comme adresse pour ton site web puisque tu n'as pas d'hébergement

Frédéric

afoehne
12/05/2011, 13h59
Citation Envoyé par Gaston_Phone
Pour la nième fois, essaie d'aller avec ton navigateur préféré aux adresses suivantes :
http://interhomines.com/
http://www.interhomines.com/

Peux-tu nous dire ce que tu obtiens ?
Ça...

Gaston_Phone
12/05/2011, 13h54
Citation Envoyé par afoehne
La réponse de Google étant : "La validation a échoué pour le site http://interhomines.com/..." (voir ici la copie d'écran),
Pour la nième fois, essaie d'aller avec ton navigateur préféré aux adresses suivantes :
http://interhomines.com/
http://www.interhomines.com/

Peux-tu nous dire ce que tu obtiens ?

afoehne
12/05/2011, 13h35
La réponse de Google étant : "La validation a échoué pour le site http://interhomines.com/..." (voir ici la copie d'écran), cela voudrait-il dire que pour ouvrir un compte sur Google Apps, il faut obligatoirement avoir déjà un site hébergé quelque part sous le domaine que l'on veut lui affecter, afin que la procédure de validation du nom de domaine qu'impose Google puisse s'appliquer ? Le fait de n'avoir aucun site hébergé, mais être seulement propriétaire d'un nom de domaine, serait donc incompatible avec l'ouverture d'un compte sous ce domaine dans Google Apps. Si tel est le cas, ça semble parfaitement aberrant.

afoehne
12/05/2011, 13h24
Citation Envoyé par fritz2cat
Code:
C:\>nslookup -q=txt interhomines.com

Non-authoritative answer:
interhomines.com        text =

        "6GjG8ryHeTDUkpC0RIZfPYm6...KWBLn1D3Fw8WBofE"
ça m'a tout l'air de fonctionner.

Frédéric
C'est bien la variable que Google m'a proposée et que j'ai reportée dans l'enregistrement TXT de mon DNS OVH.
Je viens de retenter la validation sur la page google, mais la réponse est toujours la même : "Nous n'avons pas été en mesure de valider votre domaine"...

fritz2cat
12/05/2011, 13h00
Code:
C:\>nslookup -q=txt interhomines.com

Non-authoritative answer:
interhomines.com        text =

        "6GjG8ryHeTDUkpC0RIZfPYm6...KWBLn1D3Fw8WBofE"
ça m'a tout l'air de fonctionner.

Frédéric

afoehne
12/05/2011, 12h44
Citation Envoyé par fritz2cat
Alors tu crées un enregistrement de type TXT. (via Manager > DNS > Zone DNS)

Avec CNAME tu es parti dans la mauvaise direction.
Avec le point final tu es aussi parti dans la mauvaise direction.

Bosco a été bref et avait raison.

Gaston n'avait probablement utilisé qu'une seule des méthodes d'authentification du domaine proposées par Google.

Frédéric
J'ai laissé tomber la méthode CNAME et suis revenu sur la méthode TXT.

Le "point" à la suite du nom de domaine de premier niveau est donc devenu sans objet étant donné que l’enregistrement TXT ne demande pas de pointer vers Google, mais seulement de renseigner la valeur TXT à l'aide de la variable donnée par Google.

Je ne conteste pas la justesse de la réponse de Gaston, mais souligne simplement son imprécision. Je rappelle que je n'ai pour l'instant aucun hébergement.

Au final, je ne sais toujours pas si la procédure que j'ai décrite plus haut et rapportée à nouveau ci-dessous est bonne....


A la rubrique Accueil > Mutualisé > Domaines & DNS > Zone DNS> champ TXT, j'ai laissé vide le champ "Sous-domaine :" et j'ai renseigné le champ "Valeur :" avec la variable proposée dans la procédure de validation Google. Puis j'ai cliqué sur le bouton "Valider".

Je suis retourné sur la page Google et j'ai cliqué également sur le bouton "valider" afin de ponctuer la procédure de validation.

La page Google m'a renvoyé instantanément le message suivant : "La validation a échoué pour le site http://interhomines.com/ avec la méthode Enregistrement DNS. Le contenu de votre enregistrement DNS TXT de validation est incorrect."

Cependant, le message est complété par un lien qui me propose d' "Afficher les enregistrements DNS TXT trouvés". Et lorsque je clique sur ce lien, s'affiche alors la variable que j'ai justement utilisée pour créer l'enregistrement TEXT dans la zone DNS d'OVH. Et ça c'est pas normal : soit il le trouve, soit il le trouve pas ce P..... d'enregistrement !

Sans doute faut-il que j'attende 24 heures le temps que l'enregistrement TEXT soit pris en compte sur mon serveur OVH...

Gaston_Phone
12/05/2011, 12h40
Citation Envoyé par fritz2cat
Gaston n'avait probablement utilisé qu'une seule des méthodes d'authentification du domaine proposées par Google.
Voui, car pour moi, c'est la plus simple et la plus rapide à mettre en œuvre.

fritz2cat
12/05/2011, 12h28
Alors tu crées un enregistrement de type TXT. (via Manager > DNS > Zone DNS)

Avec CNAME tu es parti dans la mauvaise direction.
Avec le point final tu es aussi parti dans la mauvaise direction.

Bosco a été bref et avait raison.

Gaston n'avait probablement utilisé qu'une seule des méthodes d'authentification du domaine proposées par Google.

Frédéric

afoehne
12/05/2011, 12h23
Citation Envoyé par fritz2cat
On s'égare ici. Reprenons au début. Qu'est-ce que Google t'a demandé d'installer dans le DNS ?

Frédéric
Google m'a demandé d'installer un enregistrement TXT dans la configuration de mon DNS (OVH) à l'aide d'une variable générée automatiquement par ses soins. Google sera ainsi capable d'identifier cette variable dans mon propre DNS (OVH) et d'en conclure que je suis bien le propriétaire du nom de domaine interhomines.com.

Je précise toutefois que je n'ai pas de site utilisant ce nom de domaine. J'ai simplement crée ce domaine chez OVH sans souscrire aucun hébergement. J'ai ensuite ouvert un compte sur Google Apps, avec l'intention de faire pointer mon DNS (OVH) vers ce compte. Ceci correspond, à mon sens, à un hébergement chez Google d'un domaine externe à son propre environnement. Cependant, je suis bloqué dans la procédure Google de validation de mon nom de domaine. Or il existe sur Google Apps 4 procédures de validation au choix, dont une seule ne nécessite pas d'avoir un site déjà hébergé quelque part (c'est en tout cas ce que je suppose). Il me semble donc que je n'avais que cette option disponible pour avancer dans cette procédure de validation.

fritz2cat
12/05/2011, 11h39
Citation Envoyé par Gaston_Phone
OK,

J'ai déclaré pal mal de sites dans GWT (Google Webmaster Tools).
Cela nécessite :
  • Que l'URL www.VotreDomaine.com pointe réellement sur votre hébergement.
  • Qu'ensuite, Google puisse accéder à un fichier googlexxxxxxxnnnnnn.html qu'il vous aura demandé de déposer dans le dossier /www/
Je pense que ce n'est pas la seule méthode offerte par Google. Le DNS admin (hostmaster@) peut aussi se faire authentifier sans devoir toucher au site web.

Frédéric

Gaston_Phone
12/05/2011, 11h30
OK,

J'ai déclaré pas mal de sites dans GWT (Google Webmaster Tools).
Cela nécessite :
  • Que l'URL www.VotreDomaine.com pointe réellement sur votre hébergement.
  • Qu'ensuite, Google puisse accéder à un fichier googlexxxxxxxnnnnnn.html qu'il vous aura demandé de déposer dans le dossier /www/

fritz2cat
12/05/2011, 11h30
On s'égare ici. Reprenons au début. Qu'est-ce que Google t'a demandé d'installer dans le DNS ?

Frédéric

afoehne
12/05/2011, 11h24
Citation Envoyé par Gaston_Phone
Crois-tu que les autres sont des imbéciles ?

Je me permets de répéter ma réponse précédente :

==> Règle donc tes accès à ton domaine chez OVH.
Je suis certainement un imbécile moi-même, mes parents me le disaient souvent. C'est pourquoi j'ai besoin de ton aide afin que tu me précises ce que tu entends par "Règle ton accès à ton domaine chez OVH". Y aurait-il une procédure à suivre que je n'aurais pas comprise ? Car comment imaginer qu'OVH ne me l'a pas présentée au moment de mon inscription ?

Gaston_Phone
12/05/2011, 10h54
Citation Envoyé par afoehne
Mon objectif est d'activer mes comptes Google Apps pour mes noms de domaine interhomines.com, .fr, .org, .eu, .net. Pour cela, Google me demande de lui prouver que je suis bien le propriétaire de ces noms de domaine. Comme je n'ai pas encore de site crée, je dois donc passer par la seule procédure de validation DNS.
Crois-tu que les autres sont des imbéciles ?

Je me permets de répéter ma réponse précédente :
Citation Envoyé par Gaston_Phone
Pour le moment, cela n'a rien à voir avec GOOGLE : Ton domaine interhomines.com pointe sur http://imp.ovh.net/.
==> Règle donc tes accès à ton domaine chez OVH.

afoehne
12/05/2011, 10h49
Citation Envoyé par bosco
Cname = in cname
txt = in txt
A la rubrique Accueil > Mutualisé > Domaines & DNS > Zone DNS> champ TXT, j'ai laissé vide le champ "Sous-domaine :" et j'ai renseigné le champ "Valeur :" avec la variable proposée dans la procédure de validation Google. Puis j'ai cliqué sur le bouton "Valider".

Je suis retourné sur la page Google et j'ai cliqué également sur le bouton "valider" afin de ponctuer la procédure de validation.

La page Google m'a renvoyé instantanément le message suivant : "La validation a échoué pour le site http://interhomines.com/ avec la méthode Enregistrement DNS. Le contenu de votre enregistrement DNS TXT de validation est incorrect."

Cependant, le message est complété par un lien qui me propose d' "Afficher les enregistrements DNS TXT trouvés". Et lorsque je clique sur ce lien, s'affiche alors la variable que j'ai justement utilisée pour créer l'enregistrement TEXT dans la zone DNS d'OVH. Et ça c'est pas normal : soit il le trouve, soit il le trouve pas ce P..... d'enregistrement !

Sans doute faut-il que j'attende 24 heures le temps que l'enregistrement TEXT soit pris en compte sur mon serveur OVH...

Dis-moi, s'il te plait, si j'ai fait une erreur et où je l'ai faite.

bosco
12/05/2011, 09h55
Cname = in cname
txt = in txt

afoehne
12/05/2011, 09h51
Citation Envoyé par bosco
Un enregistrement TXT n'est pas un enregistrement CNAME.

C'est comme si tu disais essence = gasoil.
C'est un fait, je le reconnais. Mais j'ai bien effectué mes recherches sur le web avant de poster mon message et je n'ai trouvé que ça pour m'aider vraiment. Or cette discussion issue du forum Google semble introduire justement la confusion entre procédure CNAME et procédure TXT.

J'ai surligné en jaune, les indications du gentil simplet (niveau 1) qui a rencontré les mêmes problèmes que moi. En bleu, la réponse du gentil expert (niveau 6) qui l'induit en erreur.... et en rose la conclusion du gentil simplet (niveau 1>) qui réalise son erreur.

Merci de m'avoir indiqué que j'ai sans doute fait la même erreur.

Je reviens dès que j'ai vérifié si ça marche en modifiant le TXT à la place du CNAME...

bosco
12/05/2011, 09h28
Un enregistrement TXT n'est pas un enregistrement CNAME.

C'est comme si tu disais essence = gasoil.

afoehne
12/05/2011, 09h13
Citation Envoyé par Gaston_Phone
Pour le moment, cela n'a rien à voir avec GOOGLE : Ton domaine interhomines.com pointe sur http://imp.ovh.net/.
Mon objectif est d'activer mes comptes Google Apps pour mes noms de domaine interhomines.com, .fr, .org, .eu, .net. Pour cela, Google me demande de lui prouver que je suis bien le propriétaire de ces noms de domaine. Comme je n'ai pas encore de site crée, je dois donc passer par la seule procédure de validation DNS.

Cette procédure consiste à renseigner sur la page de configuration OVH un CNAME afin que celui-ci pointe vers google.com. comme c'est décrit dans la doc de Google Apps

Sur la page configuration OVH de la zone DNS de mon domaine, je clique sur la rubrique CNAME, puis dans le champs intitulé "Sous domaine" j'entre la variable proposée sur la page google sous la forme googlefffggghhh12345 (à droite du signe =). Ensuite, dans le champs intitulé "Destination", j'entre la variable qui s'affiche dans la page de google sous la forme google.com. (je n'oublie pas le . final). Enfin, je clique sur > ajouter

Je devrais dès lors pouvoir valider ma demande sur le site de Google.

Pourtant Google me refuse instantanément la validation au motif que mon nom de domaine est introuvable.

J'ai bien noté que la mise a jour DNS et la propagation de ces nouvelles données, peut prendre du temps et qu'il me faudra peut être attendre 10 minutes à 24 heures pour valider mon nom de domaine, mais cela fait une semaine que je suis bloqué à ce stade de la procédure.

Du coup, Google vient de m'avertir que, sans validation de ma part des mes noms de domaine, il allait clôturer mes comptes Apps.

Peut-être aurais-tu une idée du détail sur lequel je bute ?

Gaston_Phone
12/05/2011, 08h26
Pour le moment, cela n'a rien à voir avec GOOGLE : Ton domaine interhomines.com pointe sur http://imp.ovh.net/.

afoehne
12/05/2011, 08h22
Citation Envoyé par Toorop
Si tu veux de l'aide, il me semble qu'il serait judicieux de préciser ton domaine
C'est effectivement une bonne idée. Voici mon domaine : interhomines.com décliné également en .fr .eu .org .net

Toorop
12/05/2011, 05h59
Si tu veux de l'aide, il me semble qu'il serait judicieux de préciser ton domaine

afoehne
11/05/2011, 21h58
Bonjour,
Je n'arrive pas à valider mes domaines OVH sous Google Apps. Google me renvoie instantanément le message suivant : "la validation a échoué [...] Votre enregistrement DNS TXT de validation est introuvable.". Pourtant, je prends soin de copier l'enregistrement TXT (situé après le signe =) dans le champs CNAME de mon domaine. Je n'oublie pas nom plus de laisser le point après le domaine de premier niveau dans le champs "destination". Quelqu'un pourrait-il m'aider ? Merci.