OVH Community, votre nouvel espace communautaire.

Wordpress 3.2 et PHP 5


Gaston_Phone
04/08/2011, 08h40
Citation Envoyé par La Flaneuse
J'ai suivi correctement ces étapes (enfin je pense) mais le message est toujours le même, je ne peux plus accéder à mon blog.
Quelles étapes ?
Quel message d'erreur ?

Juliette
04/08/2011, 00h39
Si tu copie ça dans ton fichier .htaccess

Options -Indexes
Options -Multiviews
Options +FollowSymLinks
SetEnv REGISTER_GLOBALS 0
SetEnv PHP_VER 5_TEST
RewriteEngine On

# BEGIN WordPress
# END WordPress

1 - Ca dit quoi ?
2 - La valeur d'accès au fichier est bien de 604 ? (clic droit sur le fichier sous FileZilla pour savoir) ?

Si je dis des betises, ou s'il y a mieux à copier dans ce fichier, vu le nombre d'utilisateurs expérimentés de ce forum, n'hésitez pas à me reprendre

Juliette.

Nowwhat
04/08/2011, 00h21
Salut
Citation Envoyé par La Flaneuse
.... le message est toujours le même...
Peut-on savoir ce message ?

La Flaneuse
03/08/2011, 23h28
Bonjour,

J'ai suivi correctement ces étapes (enfin je pense) mais le message est toujours le même, je ne peux plus accéder à mon blog.
Est-ce que vous pourrier me donner des solutions?
Merci

Citation Envoyé par Nowwhat
Bonjour !

WordPress exige 5.2.4 au moins, pas qu'un thème.


Noop, apache, le serveur web, plante, car
SetEnv PHP_VER5
est un erreur de syntax.
C'est
SetEnv PHP_VER 5

Solution: la doc d'OVH: http://guides.ovh.net et plus précisément http://guides.ovh.com/Php5ChezOvh

Nowwhat
03/08/2011, 12h29
Compréhensible, la réponse de cette question est pas loin wordpress.org => About => Requirements donc personne en parle ... on le voit de suite

Juliette
03/08/2011, 12h10
Merci Gaston,

C'est ce que j'ai mis

Le forum Wordpress n'est visiblement pas bien riche sur cette question.

Gaston_Phone
03/08/2011, 11h18
Citation Envoyé par Nowwhat
La maison mère l'indique: http://wordpress.org/about/requirements/
Etraits de http://wordpress.org/about/requirements/ :
To run WordPress your host just needs a couple of things:
  • PHP version 5.2.4 or greater
  • MySQL version 5.0 or greater

The requirements have changed as of WordPress 3.2. The minimum requirements for WordPress 3.1 are PHP 4.3 and MySQL 4.1.2.
---> Dans .htaccess :
SetEnv PHP_VER 5_TEST

Nowwhat
03/08/2011, 07h46
La maison mère l'indique: http://wordpress.org/about/requirements/

Gaston_Phone
02/08/2011, 20h38
Citation Envoyé par Juliette
Que conseillez-vous pour Wordpress 3.2 -> Un PHP 5.2 ou 5.3 ?
Et que conseillent les forums dédiés à Wordpress ?

Juliette
02/08/2011, 19h33
Que conseillez-vous pour Wordpress 3.2 -> Un PHP 5.2 ou 5.3 ?

Nunn
08/07/2011, 20h20
Citation Envoyé par Gaston_Phone
On racle les fonds de tiroirs ? La demande date d'il y a DEUX mois.
Il est vrai. Mais la version officielle de WP 3.2 viens seulement de sortir (hier) auparavant il s'agissait seulement d'une version beta, beaucoup de personnes vont donc rechercher cette info.

Gaston_Phone
08/07/2011, 09h21
On racle les fonds de tiroirs ? La demande date d'il y a DEUX mois.

Nowwhat
08/07/2011, 09h01
Bonjour !
Citation Envoyé par peterk
Je dois utiliser Wordpress 3.2 et PHP 5 pour certaines fonctions d'un theme.
WordPress exige 5.2.4 au moins, pas qu'un thème.

Citation Envoyé par peterk
Malheureusement quand j'indique dans le fichier .htaccess (SetEnv PHP_VER5 )
Wordpress plante.
Noop, apache, le serveur web, plante, car
SetEnv PHP_VER5
est un erreur de syntax.
C'est
SetEnv PHP_VER 5

Solution: la doc d'OVH: http://guides.ovh.net et plus précisément http://guides.ovh.com/Php5ChezOvh

Nunn
08/07/2011, 08h34
Bonjour,

C'est tout a fait normal : votre manipulation vous ouvre au PHP 5.2, mais c'est insuffisant. En effet, il vous faut au moins le PHP 5.2.4 pour obtenir le bon support pour WordPress. Dans votre fichier .htaccess il vous faut donc mettre :

SetEnv PHP_VER 5_TEST

...ce code vous fera passer en PHP 5.3

C'est expliqué ici : http://guide.ovh.com/Php5ChezOvh

Bien à vous

peterk
10/05/2011, 14h36
Bonjour,

Je dois utiliser Wordpress 3.2 et PHP 5 pour certaines fonctions d'un theme.
Malheureusement quand j'indique dans le fichier .htaccess (SetEnv PHP_VER5 )
Wordpress plante.

Si je ne modifie rien au niveau htaccess c'est le theme qui plante, le développeur du thème me dit d'utiliser PHP5 pour que cela fonctionne.

Quelqu'un aurait il une suggestion pour régler ce problème de PHP 5 ?

Merci