OVH Community, votre nouvel espace communautaire.

.htaccess pour php5 et internal server error


fredoxxx
15/03/2013, 14h03
--> je viens de recréer un fichier .htaccess à l'aide d'un autre éditeur et tout semble marcher cette fois.<--

Merci merci merci ... Je m'acharnais avec mon éditeur habituel... Du coup j'ai changé par gedit (mac). Et là miracle, plus d'erreur 500 et un url rewriting qui marche sur un kimsufi - ispconfig - debian6

Vraiment merci...

Daniel60
25/05/2011, 15h34
Il est parfois nécessaire d'actualiser le cache du navigateur.

xefiji
25/05/2011, 14h30
Hello Daniel,

et bien je suis sur un autre poste et ça marche. Pourtant j'avais bien joué avec toutes les fonctions d'encodage et de conversion depuis chez moi...étrange....
Merci en tous cas ;-)

Daniel60
25/05/2011, 11h07
L'idée est que ton .htaccess n'est pas bon.
Le codage doit être en ASCII/ANSI et les fins de ligne en LF (0a en héxadécimal).

xefiji
25/05/2011, 10h13
Bonjour,

j'ai le même pbm que Jeremtools, sauf que j'ai édité mon .htaccess avec différents éditeurs de texte et rien n'y fait. j'ai toujours cette erreur:
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}'
Cette parse error est au tout début de ma première classe.

Quand je rajoute par exemple: SetEnv REGISTER_GLOBALS 0 dans le htaccess, j'ai carrément une Internal Server Error.

Tout marchait bien en local...
Une idée?

Gaston_Phone
03/05/2011, 16h36
Citation Envoyé par Daniel60
Donc : passer à Linux
Hum! Hum! Hum! Hum! Hum! ...

Daniel60
03/05/2011, 13h44
Donc : passer à Linux

Nowwhat
03/05/2011, 09h38
Citation Envoyé par jeremtools
... je viens de recréer un fichier .htaccess à l'aide d'un autre éditeur et tout semble marcher cette fois.
Encodage.

Les éditeurs sur un PC peuvent éditer des fichiers test (ASCI), mais le format interne n'est pas universel pour les différent OS's sur le marché.
Ton serveur tourne sur Linux, ton OS chez toi sur Mac os Windows.

A vu, ça l'air le même fichier. Mais quand tu regarde ton fichier façon "binaire ou hexadécimal" tu verras bien d'autre 'chiffres'. C'est ça, le problème.

Gaston_Phone
03/05/2011, 09h07
Et bien voilà!

jeremtools
03/05/2011, 09h03
Merci de votre aide, je viens de recréer un fichier .htaccess à l'aide d'un autre éditeur et tout semble marcher cette fois.

Merci pour votre aide.

jeremtools
03/05/2011, 08h49
c'est bien un problème avec le fichier .htaccess, mais pourquoi est t'il cassé, il n'y a que cette ligne dedans et je viens de le créer, comment puis-je réparer ça.

merci pour votre aide

Gaston_Phone
03/05/2011, 07h57
Citation Envoyé par jeremtools
... à partir de là j'ai une erreur 500 et je ne sais ce que j'ai mal fait.
Ton fichier .htaccess est sans doute abimé.

Pour le vérifier :


Résultat :
Bonjour --> WP en erreur
Erreur 500 --> fichier .htaccess cassé.

jeremtools
02/05/2011, 23h33
merci mais le résultat est le mm

Daniel60
02/05/2011, 23h26
Je ne sais pas où tu as fait tes recherches mais ça
SetEnv SG_DEFAULT_PHP_VERSION 5
ce n'est pas correct, c'est SetEnv PHP_VER 5 qu'il faut écrire.

jeremtools
02/05/2011, 23h08
Bonjour,

Débutant en programmation j'ai besoin d'un peu d'aide.

Pour mon site wordpress à cette adresse : http://portfolio.jeremiemazenq.com j'ai besoin d'activer php5 pour un nouveau thème.

Je suis sur une offre perso.

après quelque recherche je lis qu'il faut créer un fichier .htaccess et y mettre cette ligne : SetEnv SG_DEFAULT_PHP_VERSION 5

Je crée un fhicher text, y colle cette ligne, l'envoi sur mon ftp dans le dossier de mon site /www/wordpress et le renomme en .htaccess

à partir de là j'ai une erreur 500 et je ne sais ce que j'ai mal fait.

Merci pour votre aide.