OVH Community, votre nouvel espace communautaire.

API OVH (SoapI) - Pb màj annuaire universel


lowic
08/12/2010, 15h46
Bonjour,

La variable inseeCode est une variable utilisée interne qui se met à jour automatiquement après quelques minutes après une mise à jour des données via soapi.

Je vais enlever l'affichage de cette variable lors de la prochaine mise à jour du soapi afin de ne pas perturber les utilisateurs du service soapi.

Loïc

loky79
07/12/2010, 08h25
Citation Envoyé par fchantret
Remonté et fixé en dev. Ca devrait être bon lors de la prochaine MAJ de SoAPI
Merci, effectivement ça marche avec la nouvelle signature (1.13.1) !

Par contre, en réussissant à faire maintenant la mise à jour, je me suis rendu compte d'un autre phénomène.... :
=> suite à la mise à jour effectuée par "telephonyDirectoryModifyAddress", je remarque que la valeur de "inseeCode" passe systématiquement à 0 (même quand aucune des autres valeurs n'est modifiée)

Cet "inseeCode" n'est pas un paramètre de la fonction de mise à jour (ce passage à 0 n'a donc pas pour origine une mauvaise valeur envoyée) mais est une info obtenue par "telephonyDirectoryInfo".

Je ne me rend pas bien compte de la conséquence de ce passage à 0 mais je remarque juste que lorsque la mise à jour est faire depuis le manager, cette valeur n'est pas mise à 0.

Merci encore d'avance pour votre aide,

Bruno

fchantret
06/12/2010, 16h44
Citation Envoyé par loky79
Merci pour cette réponse. Effectivement le problème n'apparait plus avec les corrections apportées depuis la version 1.11.5.

Par contre, j'ai remarqué un autre problème, cette-fois ci avec le service telephonyDirectoryInfo (j'utilise bien la nouvelle signature) :
=> Les paramètres sortants suivants sont systématiquement vides : éléments "codePJ" et "LabelPJ" de la structure PJHeading (j'ai vérifié dans le XML de la réponse, ils sont vides)

En d'autres termes la rubrique Pages jaunes est toujours vide dans la réponse alors qu'il y a bien une rubrique définie quand je regarde l'annuaire via le manager.

Ce problème a une conséquence indirecte sur la capacité à faire des mises à jour car, le code pages Jaune étant un paramètre de la fonction "telephonyDirectoryModifyAddress", il n'est donc pas possible de proposer la valeur actuelle (car on ne peut pas la récuperer)

Merci d'avance

Bruno
Remonté et fixé en dev. Ca devrait être bon lors de la prochaine MAJ de SoAPI

loky79
05/12/2010, 15h24
Merci pour cette réponse. Effectivement le problème n'apparait plus avec les corrections apportées depuis la version 1.11.5.

Par contre, j'ai remarqué un autre problème, cette-fois ci avec le service telephonyDirectoryInfo (j'utilise bien la nouvelle signature) :
=> Les paramètres sortants suivants sont systématiquement vides : éléments "codePJ" et "LabelPJ" de la structure PJHeading (j'ai vérifié dans le XML de la réponse, ils sont vides)

En d'autres termes la rubrique Pages jaunes est toujours vide dans la réponse alors qu'il y a bien une rubrique définie quand je regarde l'annuaire via le manager.

Ce problème a une conséquence indirecte sur la capacité à faire des mises à jour car, le code pages Jaune étant un paramètre de la fonction "telephonyDirectoryModifyAddress", il n'est donc pas possible de proposer la valeur actuelle (car on ne peut pas la récuperer)

Merci d'avance

Bruno

fchantret
30/11/2010, 14h47
Citation Envoyé par loky79
Bonjour,

Je souhaite mettre en place la mise à jour de l'annuaire universel via une application locale qui appelle un service SOAPI OVH.

Mon problème concerne l'appel à la méthode "telephonyDirectoryModifyAddress" (mise à jour des informations d'adresse). Lorsque j'appelle la méthode, le message d'erreur suivant m'est renvoyé systématiquement par le service SOAP (et aucune mise à jour n'est réalisée en ligne) :

Paramètre supplémentaire: district ->
Paramètre supplémentaire: placeName ->
Paramètre supplémentaire: floor ->
Paramètre supplémentaire: lodge ->
Paramètre supplémentaire: stairCase ->
Paramètre supplémentaire: door ->
Paramètre supplémentaire: building ->
Paramètre supplémentaire: block ->
Paramètre supplémentaire: extraAddress ->

Il semble y avoir un problème avec ces 9 paramètres (parmi les 32 envoyés à la méthode). Lorsque j'envoie une valeur non vide à tous ces paramètres, le message est le même et la valeur envoyée est affichée en face de chacune des lignes de ce message (il ne s'agit donc pas d'un problème d'envoi d'une valeur non renseignée)

Pour information, la récupération des infos annuaires (via methode "telephonyDirectoryInfo") ou la mise à jour des infos de parution (via methode "telephonyDirectoryModifyPublication") fonctionne très bien.


Est-ce que quelqu'un a déjà rencontré ce problème ?

Merci d'avance

Bruno
Les méthodes SOAPI étaient obsolètes. Elles ont été mises à jour il y a quelques jours.

loky79
25/11/2010, 00h56
Bonjour,

Je souhaite mettre en place la mise à jour de l'annuaire universel via une application locale qui appelle un service SOAPI OVH.

Mon problème concerne l'appel à la méthode "telephonyDirectoryModifyAddress" (mise à jour des informations d'adresse). Lorsque j'appelle la méthode, le message d'erreur suivant m'est renvoyé systématiquement par le service SOAP (et aucune mise à jour n'est réalisée en ligne) :

Paramètre supplémentaire: district ->
Paramètre supplémentaire: placeName ->
Paramètre supplémentaire: floor ->
Paramètre supplémentaire: lodge ->
Paramètre supplémentaire: stairCase ->
Paramètre supplémentaire: door ->
Paramètre supplémentaire: building ->
Paramètre supplémentaire: block ->
Paramètre supplémentaire: extraAddress ->

Il semble y avoir un problème avec ces 9 paramètres (parmi les 32 envoyés à la méthode). Lorsque j'envoie une valeur non vide à tous ces paramètres, le message est le même et la valeur envoyée est affichée en face de chacune des lignes de ce message (il ne s'agit donc pas d'un problème d'envoi d'une valeur non renseignée)

Pour information, la récupération des infos annuaires (via methode "telephonyDirectoryInfo") ou la mise à jour des infos de parution (via methode "telephonyDirectoryModifyPublication") fonctionne très bien.


Est-ce que quelqu'un a déjà rencontré ce problème ?

Merci d'avance

Bruno