OVH Community, votre nouvel espace communautaire.

SOAPI & Formulaire


Merlin59
28/08/2010, 12h08
bonsoir,

j'ai un problème de programmation j'ai mon formulaire en html et une requête api pour création des données mais il en veux pas du tous il n'envoie pas mon formulaire je débute en api et php pouvez vous me dire quelle est mon erreur svp

ps:mes formulaires fonctionnais avec la version soapi-re-1.4.wsdl puis j'ai abandonné le projet api trop de travail puis la je la reprend mais depuis la soapi-re-1.11.wsdl plus rien ne fonctionne alors je ne sais pas si ca viens de soapi qui a changé ou de la version de php qui a aussi changé (version actuel 5.2.13 )

j'ai testé une variable du style :
Code PHP:
$name $_POST['name']; 
mais ca change rien

merci d'avance pour l'aide

Code:
		
				
Nom :

Prénom :

mot de passe :
e-mail :
phone :
international format, ex: +33.899701761

fax :
international format, ex: +33.899701761

adresse :

ville :

Département

code postal :

pays :

langue :
forme légal :

Si vous etes une entreprise ne cliquez pas sur ce bouton envoyer et continué le formulaire


Nom de l'entreprise :
Nom du dirigant :
n° siret :
n° tva intracommunautaire :



login("XXXXXXX", "XXXXXXXXXX","fr", false); echo "login successfull\n"; //nicCreate $result = $soap->nicCreate($session, "$name", "$firstname", "$password", "$email", "$phone", "$fax", "$address", "$city", "$area", "$zip", "$country", "$language", true, "$legalform", "$organisation", "$legalName", "$legalNumber", "$vat"); echo "Votre Identifiant OVH est : \n"; ?> logout($session); echo "logout successfull\n"; } catch(SoapFault $fault) { # echo $fault; } ?>