OVH Community, votre nouvel espace communautaire.

Wildcard DNS


totomat
01/12/2011, 10h58
bonjour,
j'ai un problème similaire,
j'ai un compte pro mutulaisé,
j'ai installer un multidomaine sur wordpress avec comme site principal
www.site1.com et un second site qui est donc www.site1.com/site2
j'ai donné un nom de domaine propre au site 2: www.site2.com en créant un multidomaine sur ovh avec *.site2.com qui pointe dans le dossier du site principal.

résultat, lorsque je tape www.site2.com, le site2 s'ouvre bien mais la barre d'adresse se transforme en www.site1.com/site2

quelqu’un a t-il la solution?
merci d'avance

namster33
25/10/2010, 07h31
Citation Envoyé par DuckEater
Faux : j'ai des wildcards sur des domaines non-principaux ! (hébergement business)
Il faut juste passer par l'option "multi-domaine" au lieu de "sous-domaine".

Tu déclares un multi-domaine en "*.domaine.tld" et le tour et joué (ça t'ajoute même l'entrée dns si ton NIC a les droits d'admin sur le domaine).
qu'on soit bien d'accord, le wildcard est bien sûr possible sur tous les domaines, le soucis est du côté de la réponse de l'hébergement unique.

pour être sûr :
Tu possèdes deux domaines en plus de celui de base de ton hébergement.
*.domaine2.fr et *.domaine3.fr mènent tous deux vers cet hébergement.

l'impression que j'avais est que l'on peut avoir un wildcard par hébergement.

Abazada
25/10/2010, 07h13
Citation Envoyé par DuckEater
Faux : j'ai des wildcards sur des domaines non-principaux ! (hébergement business) //
Tu déclares un multi-domaine en "*.domaine.tld" et le tour et joué (ça t'ajoute même l'entrée dns si ton NIC a les droits d'admin sur le domaine).
Testé à l'instant sur un hébergement PRO :
Multidomain wildcard is not possible on multisubdomain
or multidomain is not hosted by OVH
or you don't have enough privileges on it
Peut-être qu'en BUSINESS c'est différent ?

IE-Lobbying
21/08/2010, 06h59
Citation Envoyé par DuckEater
Faux : j'ai des wildcards sur des domaines non-principaux ! (hébergement business)
Il faut juste passer par l'option "multi-domaine" au lieu de "sous-domaine".

Tu déclares un multi-domaine en "*.domaine.tld" et le tour et joué (ça t'ajoute même l'entrée dns si ton NIC a les droits d'admin sur le domaine).
Donc au final, ça marche ? Tu peux installer WordPress Mu en mutualisé avec option sous-domaine ? Des conditions /restrictions particulières (e.g. nom de domaine géré par OVH, etc.) ?

DuckEater
20/08/2010, 23h34
Citation Envoyé par namster33
le domaine de base utilisé DOIT être le domaine de l'hébergement (limitation purement commerciale d'OVH)
Faux : j'ai des wildcards sur des domaines non-principaux ! (hébergement business)
Il faut juste passer par l'option "multi-domaine" au lieu de "sous-domaine".

Tu déclares un multi-domaine en "*.domaine.tld" et le tour et joué (ça t'ajoute même l'entrée dns si ton NIC a les droits d'admin sur le domaine).

Seo
13/08/2010, 14h49
Bonjour,
merci de vos réponses
J'ai crée un sous-domaine * dans la rubrique hébergement, je vais voir ce que ça va donner ! (à la base je suis en effet passé par les Zone DNS)

Seo.

namster33
13/08/2010, 09h42
Bonjour,

Le Wildcard est disponible est fonctionnel sur les offres mutualisées.

LA chose à savoir c'est que le domaine de base utilisé DOIT être le domaine de l'hébergement (limitation purement commerciale d'OVH)

SI nimportequoi.example.com redirige sur le webmail OVH, ce n'est pas en utilisant un domaine de gandi (ou autre) que cela changera quelque chose : le soucis vient du côté de l'hébergement, non du domaine...

comme le dit DuckEater, la solution est ici :

Citation Envoyé par DuckEater
Il faut que tu crée, dans la rubrique hébergement (et non domaine et dns) un sous domaine "*.domaine.tld" qui pointe vers le dossier de ton site web.

Oriman
11/08/2010, 21h52
Bonjour,

Je suis dans le meme cas, a savoir

WP3.01 multisite active

j'ai donc activer la wildcard en creant une zone DNS
*.monsite.fr A monsite.fr
(comme me la stipuler Richard H de la maintenance OVH)

grace au super gens du forum wordpress qui m aide pendant leurs nuits,
j'ai active un sous domaine
http://*.monsite.fr cible /www

probleme 1 :
tous mes sous domaines wordpress termine dans le webmail ovh

problem 2 :
impossible de creer un sous domaine www.*.monsite.fr

que faire ?
merci d avance

DuckEater
11/08/2010, 18h29
Seo, tu as crée une wildcard au niveau des dns, ce qui veut dire que *.domaine.tdl point vers le serveur mutualisé OVH,
mais tu ne l'as pas déclaré au niveau du dît serveur !
Ce qui fait que ton hébergement ne connait que :
- domaine.tld
- www.domaine.tld (sauf si tu l'as supprimé)
- a.domaine.tld (que tu as déclaré dans hébergement)

Tout autre requête (b.domaine.tld par exemple) tombera sur la page par défaut du serveur, en l'occurrence le webmail ovh.

Il faut que tu crée, dans la rubrique hébergement (et non domaine et dns) un sous domaine "*.domaine.tld" qui pointe vers le dossier de ton site web.

Note : Ce n'était pas la peine de modifier ta zone dns manuellement : si elle est gérée par OVH et que tu as admin du domaine (ce qui est apparemment le cas), en créant un sous-domaine dans hébergement, l'entrée dns correspondante est ajoutée automatiquement !
Le cas échéant, il apparaitrait "Zone externe" en regard de ton sous-domaine (dans la colonne "Pays"), pour t'indiquer que tu dois les configurer manuellement.

IE-Lobbying
10/08/2010, 15h37
Citation Envoyé par Seo
J'ai pris contact avant avec OVH pour leur demander si c'était dispo dans les mutu, ils m'ont répondu que oui. Donc je pense qu'il y'a un problème de configuration qqpart (sûrement de mon fait), mais je ne trouve pas où
Fais le tour du forum, la question a déjà été abordée. Concernant le support OVH, as-tu été clair au niveau des prérequis qu'une installation WordPress Mu impliquait ?

PS : Regarde dans les commentaires de cet article (http://soluo.fr/2009/03/installer-wo...u-en-5-etapes/). Il parle d'une configuration possible de WordPress Mu en mutualisé sur OVH si ton domaine est géré via Gandi.

Seo
10/08/2010, 14h45
J'ai pris contact avant avec OVH pour leur demander si c'était dispo dans les mutu, ils m'ont répondu que oui. Donc je pense qu'il y'a un problème de configuration qqpart (sûrement de mon fait), mais je ne trouve pas où

IE-Lobbying
10/08/2010, 13h53
Citation Envoyé par Seo
Non non, y'a pas besoin de serveur
Y'a juste besoin de pouvoir configurer un wildcard dans les DNS du domaines, ce qui est possible avec un mutualisé chez OVH (j'ai un business).
J'ai edité les zones DNS pour rajouter un champ A * qui pointe vers l'IP et cela ne marche pas.
Sinon je vais déclarer tous les sous-domaines mais quand y'en a 50 à faire, c un peu long

Tu es sûr ? Tu dis toi-même que la Wildcard DNS n'a pas l'air de fonctionner automatiquement ?

Seo
10/08/2010, 13h43
Non non, y'a pas besoin de serveur
Y'a juste besoin de pouvoir configurer un wildcard dans les DNS du domaines, ce qui est possible avec un mutualisé chez OVH (j'ai un business).
J'ai edité les zones DNS pour rajouter un champ A * qui pointe vers l'IP et cela ne marche pas.
Sinon je vais déclarer tous les sous-domaines mais quand y'en a 50 à faire, c un peu long

IE-Lobbying
10/08/2010, 09h37
Citation Envoyé par Seo
Bonjour,
J'utilise un WP3 multi sous-domaines.
J'ai donc configuré le wildcard DNS dans le manager : Accueil > Mutualisé > Domaines & DNS > Zone DNS et j'ai rajouté un champ A de type :
*.url.com (ou url est mon url ) qui pointe vers l'adresse IP du serveur.
En même temps, j'ai ajouté un sous-domaine a.url.com via le manager.

Le week-end passe et je reviens à ça.

Le sous-domaine a.url.com est bien attrapé par WP3 qui affiche le blog correspondant. Par contre, b.url.com me mène vers la messagerie OVH (avec le choix des interfaces) alors qu'il est configuré tout pareil que a.url.com sous WP3. La seule différence est donc au niveau du wildcard. L'un est vraiment déclaré en tant que sous-domaine dans le manager, l'autre non mais cela devrait faire la même chose au vu du wildcard.

Je ne comprend donc pas pourquoi cela ne fonctionne pas !
Me suis-je planté qqpart, avez-vous une idée ?

Merci !
D'après ce que je sais, WPMU - avec option sous-domaines - nécessite un serveur dédié pour fonctionner. Personnellement, j'utilise un RPS pour mes besoins, ça suffit amplement.

En effet, WPMU nécessite une configuration serveur (http://codex.wordpress.org/Create_A_...ard_Subdomains).

Dis-nous quand même si tu réussi... ;-)

chben
09/08/2010, 16h32
Je ne suis pas encore certain que j'ai le même problème, mais ça y ressemble.
Je viens de me rendre compte que les portfolios de mon sites, que j'hébergeait sous des URL en nom_user.mon_site.com ne fonctionnent plus.
Mon htaccess fait bien la réécriture d'URL, et renvoie vers la bonne page de redirection, en revanche l'URL ne reste pas réécrite dans la barre d'adresse du navigateur qui m'affiche la page de destination indiquée par mon htaccess..

Je suis certain que tout fonctionnait encore vendredi matin... et c'est très très problématique.

[A noter que mon problème intervient sur un serveur dédié, et que j'ai configuré mon nom de domaine pour accepter les noms de domaines en *.mon_site.com...]

Seo
09/08/2010, 14h14
Bonjour,
J'utilise un WP3 multi sous-domaines.
J'ai donc configuré le wildcard DNS dans le manager : Accueil > Mutualisé > Domaines & DNS > Zone DNS et j'ai rajouté un champ A de type :
*.url.com (ou url est mon url ) qui pointe vers l'adresse IP du serveur.
En même temps, j'ai ajouté un sous-domaine a.url.com via le manager.

Le week-end passe et je reviens à ça.

Le sous-domaine a.url.com est bien attrapé par WP3 qui affiche le blog correspondant. Par contre, b.url.com me mène vers la messagerie OVH (avec le choix des interfaces) alors qu'il est configuré tout pareil que a.url.com sous WP3. La seule différence est donc au niveau du wildcard. L'un est vraiment déclaré en tant que sous-domaine dans le manager, l'autre non mais cela devrait faire la même chose au vu du wildcard.

Je ne comprend donc pas pourquoi cela ne fonctionne pas !
Me suis-je planté qqpart, avez-vous une idée ?

Merci !