OVH Community, votre nouvel espace communautaire.

Apache listage des répertoire


TranSGeniK
26/02/2004, 19h22
Après une mofication du fichier httpd.conf faut pas oublier de redemarrer le serveur Apache.

# service httpd restart

ou

# /etc/init.d/httpd restart

Je ne sais pas par quel tour de passe passe mais ca marche maintenant !
Ton serveur redemarre chaque nuit voilà pourquoi ça c'est mis à marcher le lendemain.

freeway
26/02/2004, 16h15
Bah enlève Override none et tu met all.
Met dans certains cas il faut laisser.
T'aurai du le laisser comme il était d'origine ! Avoir une copie !

Marquis
26/02/2004, 15h30
Non ca ne fait rien. Erreur 500 toujours

freeway
26/02/2004, 13h10
DocumentRoot "/usr/local/apache/htdocs"

#
# Each directory to which Apache has access, can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).
#
# First, we configure the "default" to be a very restrictive set of
# permissions.
#

Options Includes ExecCGI MultiViews FollowSymLinks -Indexes
AllowOverride All

Marquis
26/02/2004, 12h14
AllowOverride apparait 2 fois dans mon fichier httpd.conf


Options FollowSymLinks
AllowOverride none



Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all



Mais celui qui est utilisé c'est le premier je pense et il a l'air d'être désactivé.

freeway
26/02/2004, 11h24
TU as touché a d'autres trucs dans la config httpd.conf ?
Notamment Allowoverride qui ne tiendrai pas compte des .htaccess

voir :
http://redhat.matrix.com.br/linux/cu...-ALLOWOVERRIDE

Marquis
26/02/2004, 09h44
Je ne sais pas par quel tour de passe passe mais ca marche maintenant !

Par contre, comme je suis chiant, j'aimerai autoriser le listage des répertoires QUE pour UN répertoire. Donc pour ça, j'ai créé un petit fichier .htaccess que j'ai placé dans le répertoire en question avec marqué dedans "Options Indexes".

Lorsque j'accède au répertoire, j'ai l'erreur suivante maintenant:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@xxxx and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

freeway
26/02/2004, 04h11
A un moment dans httpd.conf tu voit
FollowSymLinks Indexes

et bah tu met :

FollowSymLinks -Indexes

Sinon c que tu a touché a autre chose comme le allow_overide
-------------------
Fait une copie du fichier avant.

Marquis
24/02/2004, 19h54
Ca ne marche pas non plus, toujours une erreur 500

freeway
24/02/2004, 15h35
Fait le dans Apache directement

http://redhat.matrix.com.br/linux/cu...on-config.html

DirectoryIndex

Marquis
24/02/2004, 10h18
Quand je ne met pas d'index, ca fait une erreur 403

TranSGeniK
24/02/2004, 02h23
Pour lister un repertoire, normalement par defaut tu n'as pas besoin d'un .htaccess.
Il suffit de ne pas mettre de fichier index.

mathieu
23/02/2004, 22h12
Marquis écrivait :
ca fait pareil
Arf bah la je séche

Marquis
23/02/2004, 22h10
ca fait pareil

mathieu
23/02/2004, 22h09
essaye avec ton répertoire en 705

Marquis
23/02/2004, 21h59
Salut !

Comment est ce que je peux AUTORISER le listage d'un répertoire ? J'ai créé un fichier .htaccess avec dedans Options +Indexes et lorsque je tente d'accéder au répertoire avec IE, j'ai une erreur 500. Le répertoire est mis en 755.

Quelqu'un a une idée ?

Merci a+