OVH Community, votre nouvel espace communautaire.

en-tête From sur OVH


yakou32
21/06/2010, 10h03
Ben, à moi aussi

Daniel60
21/06/2010, 10h02
Effectivement, cela m'avait échappé

yakou32
21/06/2010, 10h00
Youpi ! Ça fonctionne !

Merci à tous deux pour vos réponses, mais en fait ça n'a rien à voir avec la configuration du compte OVH, c'est juste un \n qui manquait en fin de ligne 4 :
Code PHP:
$headers ='MIME-Version: 1.0'."\n"
$headers .='Content-type: text/html; charset="utf-8"'."\n"
$headers .='Content-Transfer-Encoding: 8bit'."\n";  
$headers .='X-Mailer: PHP/'.phpversion()."\n"
$headers .='From: monNom '."\n"
$headers .='Reply-To: no_reply@monsite.com'."\n"
Le header From se confondait donc avec le X-Mailer, et c'est pour ça que je me retrouvais avec une adresse par défaut.

On peut donc bien paramétrer que From, le Reply-to que l'on souhaite...

Daniel60
21/06/2010, 10h00
Je confirme que dans le cas normal on peut mettre le From: que l'on souhaite et il n'y a d'ailleurs aucun contrôle.

yakou32
21/06/2010, 09h51
J'ai dû commencé avec un Start, qui est passé en Perso, puis Pro... Donc ce ne serait pas la première fois.
Quoi qu'il en soit, je trouve ça curieux qu'on ne puisse pas choisir le From que l'on souhaite. J'ai pourtant créer toutes les adresses mail que j'utilise dans mon script dans les redirections mails de la section nom de domaine du manager...

Gaston_Phone
21/06/2010, 09h50
Bonjour yakou32,

Ce qui est important :
- Ce n'est pas le : Return-Path:
- Mais le : Reply-To: TonAdresseMAIL

Daniel60
21/06/2010, 09h09
Apparemment, ce multi-domaine à conservé son ancien statut.
Comme de toute manière l'option multidom n'offre pas d'adresses différentes de celles du domaine principal, il est probable que tu devras acquérir un MXplan. A faire confirmer par le support.

yakou32
21/06/2010, 08h56
En fait, je ne suis pas sur un start, mais sur un hébergement de type Pro en multi-domaine.
J'ai eu un Start auparavant, et OVH me génère une en-tête From: loginOVH@start.ovh.net

Daniel60
21/06/2010, 07h46
Pour un start, je ne sais pas.

yakou32
20/06/2010, 19h30
J'ai ajouté une adresse de return path dans les headers
J'ai ajouté un .forward dans le répertoire www de mon hébergement, et à la racine.

Je reçois toujours mes mails avec une adresse @start.ovh.net

Je ne vois pas ce que je dois faire concrètement...

Daniel60
20/06/2010, 17h53
C'est plutôt le Return-Path qui est forcé par OVH.

yakou32
20/06/2010, 17h35
Bonjour,

J'ai des soucis avec la fonction mail() sous OVH en mutualisé.

OVH modifie l'en-tête From de mon script et le remplace par mes identifiants de compte...

Voici mon header :
Code PHP:
$headers ='MIME-Version: 1.0'."\n";
$headers .='Content-type: text/html; charset="utf-8"'."\n";
$headers .='Content-Transfer-Encoding: 8bit'."\n"
$headers .='X-Mailer: PHP/'.phpversion();
$headers .='From: monNom '."\n";
$headers .='Reply-To: no_reply@monsite.com'."\n"
Quelqu'un aurait-il déjà rencontré ce problème et trouvé une solution ?
Merci beaucoup !