OVH Community, votre nouvel espace communautaire.

Joomla et SEF/SEO


Nowwhat
12/05/2010, 09h25
Citation Envoyé par TipX
@Nowwhat, il n'y à rien dans mon répertoire logs à la racine de mon site :/


(3615) Oula, encore une qui ne connais pas l'emplacement des manuels, notices et astuces d'OVH - pour autant quasi indispensable !
C'est ici : http://guides.ovh.com
Pour les logs : http://guides.ovh.com/LogsWeb
Regarde tes "OVH Speed Log" – le log « error »,il faut qu’il soit ‘vide’ pour un site ‘parfait’.

Citation Envoyé par TipX
Enfin j'aimerai quand même savoir pourquoi je ne peux accéder à mon site via l'url "classique" depuis mon lieu de stage :s
Ping ton www.ton-domaine.fr - même s'il ne répond pas, l'IP doit s'afficher.
Verifi que c'est le même IP qui figure dans ton manager => Domaine & DNS => Zone DNS
Il doit y avoir une ligne comme
.ton-url.fr A a.b.d.e dont a.b.c.d est l'IP.

A savoir maintenant qui joue un jeu avec toi : ton FAI (son DNS), ton 'lieu de stage' (IP bloqué) - le routeur d'accès, etc etc .

TipX
12/05/2010, 09h13
@Nowwhat, il n'y à rien dans mon répertoire logs à la racine de mon site :/

@tckalexon, SH404SEF est malheureusement payant depuis quelque temps.

MAIS!

J'ai trouvé!
Depuis que j'ai commandé mon hébergement et mon nom de domaine chez ovh je ne peux accèder depuis le reseau ou est situé mon ordi a l'adresse direct de mon site mais uniquement avec une adresse du style http://pro.ovh.net/xxxxx/.

Alors pour tester, je me suis connecter à mon site via un proxy et via ma connection internet personnel, et la, oh miracle, le SEF/SEO fonctionne à merveille.

J'ai donc passé toute la journée d'hier sur un problème qui n'en était pas un.

Enfin j'aimerai quand même savoir pourquoi je ne peux accéder à mon site via l'url "classique" depuis mon lieu de stage :s

Merci quand même beaucoup de vos aides!

tckalexon
11/05/2010, 20h22
je pense que j'ai trouvé une l'astuce regarde dans se site http://www.dart-creations.com/joomla...or-joomla.html mais en anglais

Nowwhat
11/05/2010, 17h47
Regarde dans ton log nommé "error", tu trouvera les urls mal-formé qui n'aboutisse pas.

TipX
11/05/2010, 14h19
Alors, après plusieurs test l'erreur 500 viens de "AddType x-mapp-php5.php" qui doit bien s'écrire "AddType x-mapp-php5 .php"

L'ajout ou la suppression de php1 ne change rien chez moi...

Je n'ai donc plus que des erreurs 404, ca viens d'un problème de réecriture non ?

Nowwhat
11/05/2010, 13h26
Citation Envoyé par TipX
Merci mais non toujours pas, j'obtiens la même erreur 500
Voici à quoi ressemble mon htaccess avec tes modifications:
Code:
SetEnv PHP_VER 5
DirectoryIndex index.php
php 1
##
....

Eeeuh, c'est quoi php 1

Avec ça, j'ai un "500" pour de bon.

TipX
11/05/2010, 11h33
Merci mais non toujours pas, j'obtiens la même erreur 500

Voici à quoi ressemble mon htaccess avec tes modifications:
SetEnv PHP_VER 5
DirectoryIndex index.php

php 1
##
# @version $Id: htaccess.txt 13415 2009-11-03 15:53:25Z ian $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


################################################## ###
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
################################################## ###

## Can be commented out if causes errors, see notes above.
#Options +FollowSymLinks
# MODIFICATION PERSO
AddType x-mapp-php5.php

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#
#Order allow,deny
#Deny from all
#Satisfy all
#

## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a