OVH Community, votre nouvel espace communautaire.

DNS et Bind


Citt_jr
08/03/2010, 18h24
Je te remercie encore, cela fonctionne maintenant.

Encore un grand merci

cassiopee
08/03/2010, 16h55
Citation Envoyé par Citt_jr
Donc je doit juste incrémenter le numéro de série (c'est ce qui correspond a yyyymmdd) de mon enregistrement dans BIND pour que le serveur secondaire se mette à jour automatiquement ?
Oui c'est tout à fait ça

(juste pour être complet : il faut aussi redémarrer bind ou recharger la zone
mais j'ai vu que ça a été fait en l'occurence)

Je viens de faire la modification en ajoutant 2 jours, je vais voir dans 2-4 heures !
Ça a l'air d"être bon. Il faut juste se méfier des caches :

- cache web
- cache DNS

Surtout le deuxième en l'occurence, qui pourrait avoir mémorisé
les mauvaises réponses précédentes et donner ainsi l'impression que
ça ne fonctionne toujours pas alors même que c'est bon.

Au besoin, faire un :

Code:
ipconfig /flushdns
dans une session DOS ('Invites de commandes") afin de bien purger le cache
DNS de Windows. (dans le poste client, je ne parle pas du serveur)

Citt_jr
08/03/2010, 16h37
Bonjour,

Donc je doit juste incrémenter le numéro de série (c'est ce qui correspond a yyyymmdd) de mon enregistrement dans BIND pour que le serveur secondaire se mette à jour automatiquement ?

Je viens de faire la modification en ajoutant 2 jours, je vais voir dans 2-4 heures !

Merci d'avance,

Citt_jr

cassiopee
08/03/2010, 13h21
A priori c'est du au fait que les deux serveurs DNS se sont pas synchronisés.

Ce qui peut arriver si on fait un changement dans le serveur DNS maître
sans incrémenter le numéro de série DNS en même temps.

Du coup les changements ne sont pas repris par le serveur DNS esclave.
(en l'occurence, il n'a sans doute pas l'enregistrement wildcard,
ce qui fait que lorsqu'on l'interroge, il ne donne pas la bonne réponse
pour "nimportequoi.tondomaine.net)

Une solution simple à ce problème peut être de juste changer le numéro
de série DNS du serveur maître, ce qui va forcer le serveur DNS esclave
à se synchroniser et du coup récupérer les dernières modifications.

Cette synchronisation n'est en général pas immédiate, avec sdns1.ovh.net
ça peut prendre jusqu'à 2 à 4 heures.

Citt_jr
08/03/2010, 13h02
Bonjour,

Je viens de mettre en place les DNS de mon RPS I OVH (Gento Release 2) sur mon nom de domaine www.tsubara.net et sous bind j'ai ajouté cette ligne dans le fichier d'enregistrement de mon domaine :
* IN A 188.165.44.224

Cela devrait normalement me rediriger tous mes sous domaine vers mon hébergement.
Mais cela ne fonctionne pas pour tous les sous domaine, une fois sur deux il m'avertis que l'adresse est indisponible.
Ex : jeeo.tsubara.net alors que citt-jr.tsubara.net fonctionne.

Sauriez vous pourquoi ?

Merci d'avance,