OVH Community, votre nouvel espace communautaire.

Problème d'affichage décimales avec un point


evenrude
21/03/2010, 19h10
Bonsoir,
Mea culpa pour le dernier message, chaque fois que je faisais une modification dans le bon de commande, je ne le téléchargeais pas au bon endroit chez OVH ! Celà découvert et corrigé, je travaille maintenant sur la version PHP de l'envoi du formulaire par email, car l'histoire de l'antislash m'a paru aussi délicate et compliquée à faire. Donc pas de souci pour l'instant, j'en suis à la validation du formulaire. A bientôt pour de nouvelles aventures ... qui continuent grâce aux "forumeux" de si bonne volonté !
Bonne semaine à tous

evenrude
21/03/2010, 11h47
Bonjour,

Après avoir travaillé ta solution en ayant trouvé la fonction javascript qui encode, je continue de recevoir un email dont le corps contient "bon de commande".
Dans le doute, j'ai décidé d'essayer la méthode par php pour envoyer le formulaire comme suit :
Code:
en utilisant toujours :
Code:
...
et mon script php bien enregistré sous mail.php

J'ai même essayé avec _GET au lieu de _POST car j'ai bizarrement trouvé les 2 cas sur internet, et j'ai aussi essayé
Code:
$msg="Seau de pâte à cuire : ".$quantite0."\n";
(pour chaque variable msg à la place de ce qui est écrit au-dessus)
Aucune variable n'est renvoyée. Je n'ai que les détails d'articles jusqu'aux deux points. Se peut-il que quelque chose bloque au niveau d'OVH ? J'avoue que je commence à être découragée.
Ai-je, encore, fait une erreur quelque part ?
Merci d'avance pour tous les coups de pouce... et bon dimanche

cassiopee
20/03/2010, 22h52
Non, ce n'est pas "contenu_html.value" mais bien "contenu_html" tout court
car c'est une variable Javascript et pas le contenu d'un élément du formulaire.

En revanche, il doit falloir l'encoder afin que ça passe correctement,
quelque chose comme ça :

Fenetre_bon.document.write('