OVH Community, votre nouvel espace communautaire.

DNS et zonecheck


Mat Pat
07/10/2005, 18h01
Bonjour,

c'est après avoir lu les (très utiles) guides 'Comment configurer les zones DNS pour mon domaine en .fr ?', 'Comment installer un domaine sur mon serveur dédié ?', 'Configuration des DNS d'un Domaine pour un serveur dédié', 'Installation d'un domaine sur le serveur ns.ovh.net', 'Suivi de la création (ou transfert) d'un domaine .fr'
proposés par ovh (bien que je ne sois pas débutant, mais pas prétentieux non plus) que je fais appel à vous :

Voici mes 2 problèmes :

1 -
J'ai créé mon domaine domaine.fr sur le dédié nsxxxxx.ovh.net (avec Plesk), en renseignant les entrées A, CNAME, MX, PTR, NS, nécessaires.
J'ai renseigné comme enregistrements 'NS' nsxxxxx.ovh.net et ns.ovh.net. (en remplaçant les x par le vrai nom de machine évidemment).

J'ai ensuite, comme l'indique le guide, renseigné le domaine en question dans la rubrique 'dns secondaires' du manager correspondant au dédié.

J'ai redémarré les services du dédié, attendu le lendemain pour le redémarrage de ns.ovh.net, mais le zonecheck signale toujours une erreur :
Le contact obtenu (hostmaster.domaine.com.) est différent de celui indiqué sur nsxxxxx.ovh.net./aaa.aaa.aaa.aaa (hostmaster.domaine.fr).
ns.ovh.net./212.27.32.132 .


Vous l'aurez remarqué, les 2 adresses diffèrent effectivement. Celà vient du fait que j'avais fait une erreur lors de la première configuration sur le primaire.
Mais je pensais que une fois celà corrigé sur le primaire, et les service redémarrés sur celui-ci, la configuration serait répliquée sur le secondaire lors du redémarrage de celui-ci et que le problème serait résolu...
Celà ne semble toutefois pas être le cas. aurais-je commis une autre erreur ?

2 -
J'ai créé mon domaine .com sur un autre dédié nsyyyyy.ovh.net (avec Plesk), en renseignant les entrées A, CNAME, MX, PTR, NS, nécessaires.
J'ai renseigné comme enregistrements 'NS' nsyyyyy.ovh.net et ns.ovh.net. (en remplaçant les y par le vrai nom de machine évidemment).

J'ai ensuite, comme l'indique le guide, renseigné le domaine en question dans la rubrique 'dns secondaires' du manager correspondant au dédié.

J'ai redémarré les services du dédié, attendu le lendemain pour le redémarrage de ns.ovh.net, mais le zonecheck signale toujours une erreur :
Aucun enregistrement SOA présent sur le serveur.
ns.ovh.net./212.27.32.132



Voici pourtant ce que me renvoi #dig @nsyyyyy.ovh.net domaine.com ANY

; <<>> DiG 9.2.3 <<>> @nsyyyyy.ovh.net domaine.com ANY
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60466
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 3

;; QUESTION SECTION:
;domaine.com. IN ANY

;; ANSWER SECTION:
domaine.com. 86400 IN MX 10 mail.domaine.com.
domaine.com. 86400 IN A aaa.aaa.aaa.aaa
domaine.com. 86400 IN SOA nsyyyyy.ovh.net. administrateur.domaine.com. 1128680713 10800 3600 604800 86400

domaine.com. 86400 IN NS nsyyyyy.ovh.net.
domaine.com. 86400 IN NS ns.ovh.net.


;; ADDITIONAL SECTION:
mail.domaine.com. 86400 IN A aaa.aaa.aaa.aaa
ns.ovh.net. 58552 IN A 212.27.32.132
nsyyyyy.ovh.net. 144950 IN A aaa.aaa.aaa.aaa

;; Query time: 4 msec
;; SERVER: aaa.aaa.aaa.aaa#53(nsxxxxx.ovh.net)
;; WHEN: Fri Oct 7 17:17:55 2005
;; MSG SIZE rcvd: 209


Ce n'est pourtant pas la première fois que je fais celà, mais c'est pourtant comme celà.
Donc, soit j'ai commis des erreurs, soit le ns.ovh.net n'a pas redémarré (moins probable puisque ovh dit que celà est fait le matin et le soir).

Merci de votre aide.