OVH Community, votre nouvel espace communautaire.

Conversion en page blanche ecofax


fchantret
21/05/2010, 10h38
Citation Envoyé par AB&C
Bonjour à tous,

J'ai le même problème que le premier message de ce post : pdf à blanc en utilisation de l'imp virtuelle ecofax. (le fax est bien transmis mais vide)

Suis aussi en contact avec le support qui m'a fait installer la Rev. 1.0a7 build 2010050300
Installé aujourd'hui avec suppression préalable de l'.ecofax.db mais toujours pareil.

Pour info, ma config : XP pro 2002 SP2

J'utilise régulièrement CutePdf Writer qui fonctionne nickel ...

Une idée ??
Merci
Manu
Es tu loggué avec un compte appartenant à un domaine Windows géré par un contrôleur de domaine ?

J'ai réalisé un fix et c'est dans les cartons. Je vais t'envoyer le fix afin de voir si ça solutionne aussi ton problème.

Gaston_Phone
20/05/2010, 17h53
@ AB&C : Et si provisoirement tu passais par la case "PdfCreator" pour générer le PDF puis il te suffit d'envoyer le fichier PDF avec EchoFax.

AB&C
20/05/2010, 17h06
Bonjour à tous,

J'ai le même problème que le premier message de ce post : pdf à blanc en utilisation de l'imp virtuelle ecofax. (le fax est bien transmis mais vide)

Suis aussi en contact avec le support qui m'a fait installer la Rev. 1.0a7 build 2010050300
Installé aujourd'hui avec suppression préalable de l'.ecofax.db mais toujours pareil.

Pour info, ma config : XP pro 2002 SP2

J'utilise régulièrement CutePdf Writer qui fonctionne nickel ...

Une idée ??
Merci
Manu

Gaston_Phone
02/03/2010, 17h08
Citation Envoyé par fchantret
Les FAX ne sont pas supprimables pour le moment. C'est dans la TODO pour une prochaine version.
Merci Florent.

fchantret
02/03/2010, 16h55
Citation Envoyé par Gaston_Phone
Excuse-moi Florent.

La prochaine fois j'attendrai DEUX minutes pour voir si la réactualisation se fait.

D'autre part comment : comment peut-on supprimer les fax en echec ?
Merci
Les FAX ne sont pas supprimables pour le moment. C'est dans la TODO pour une prochaine version.

Gaston_Phone
01/03/2010, 11h03
Excuse-moi Florent.

La prochaine fois j'attendrai DEUX minutes pour voir si la réactualisation se fait.

D'autre part comment : comment peut-on supprimer les fax en echec ?
Merci

fchantret
01/03/2010, 10h48
Citation Envoyé par Gaston_Phone
Bonjour François,
Non, moi c'est Florent ;o)

Dans la foulée, pourrais-tu regarder la réactualisation des différents onglets.

Pour avoir la réactualisation des différents onglets, je suis obligé de faire "Quitter", d'attendre une minute et de relancer Ecofax.

Ceci dit : je suis enchanté par ce logiciel.
D'attendre une minute ? Justement, en gardant EcoFax lancé, les modifications sont contrôlées toutes les minutes donc rien d'anormal.

C'est plus si il ne se passe rien pendant une paire de minutes alors que ça devrait qu'il y a un problème. Cependant, je n'ai pas réussi à le reproduire pour le moment.

Gaston_Phone
01/03/2010, 10h33
Bonjour François,

Dans la foulée, pourrais-tu regarder la réactualisation des différents onglets.

Pour avoir la réactualisation des différents onglets, je suis obligé de faire "Quitter", d'attendre une minute et de relancer Ecofax.

Ceci dit : je suis enchanté par ce logiciel.

fchantret
01/03/2010, 10h21
Citation Envoyé par TRIMIX45
Bon, j'ai bien avancé.
dans un premier temps un fichier temporaire eco*.ps créé à la racine du local setting du profil local du pc (cyrille.portable)
deuxième temps, ce fichier est récupérer par écofax dans le temp du local setting de l'utilisateur.
PROBLEME. si l'utilisateur se connecte sous une session réseau, Redmon et Ecofax se servent des paramêtres des utilisateurs locaux (encore plus vicieux, si on modifier le répertoire temp des variables d'environnement, Ecofax, recréé le repertoire d'origine).

J'ai un peu farfouillé. Visiblement, un bat en complément du fichier ecofax.rsp peut corriger le problème. Mais là c'est pas accessible au niveau des parametres ecofax.

Bon à OVH de bosser. car même si ce n'est pas trop cher, j'aimerai pouvoir utiliser la fonction imprimante virtuelle (c'est pour cela que j'ai choisi cette solution à la base)
Bonjour,

Merci pour le diagnostic ! On avait déjà amélioré la gestion de EcoFax en accès distant via Terminal Server mais il y a encore de quoi améliorer à priori.

Je pense que le répertoire TEMP qui est pris en considération et renvoyé par une routine Qt, ainsi on a le même code multi-plateforme pour Windows, Linux et OS X. Il faudra que je vérifie dans le code

Il faudrait peut être changer ça et / ou remonter un bug à Nokia car Qt ne prend peut être pas le bon répertoire temporaire sur une session distante.

TRIMIX45
23/02/2010, 11h24
Redmon est la technologie open source d'Ecofax

Gaston_Phone
23/02/2010, 07h41
Extrait de http://pages.cs.wisc.edu/~ghost/redmon/fr/redmon.htm :
Le moniteur de port RedMon redirige un port d'imprimante particulier vers un programme. RedMon est généralement employé avec Ghostscript et une imprimante non-PostScript pour émuler une imprimante PostScript.

RedMon peut être utilisé avec n'importe quel programme acceptant des données sur l'entrée standard.

RedMon vous permet de créer des ports d'imprimante redirigés. Si vous reliez une imprimante de Windows au port redirigé, toutes les données envoyées au port redirigé seront expédiées par RedMon à l'entrée standard d'un programme. Ce programme se charge alors du traitement des données et de la création d'une nouvelle impression.

Une imprimante Windows PostScript redirigée vers un port RedMon peut être partagée en réseau. Si cette imprimante est configurée pour utiliser Ghostscript et une imprimante non-PostScript, elle apparaîtra sous la forme d'une imprimante PostScript pour les autres utilisateurs du réseau.

RedMon fonctionne sous Windows 95, NT 4.0 et 3.51.

La configuration de RedMon s'adresse à des utilisateurs expérimentés.
Cela fait pas mal de temps que je travaille sur micro et c'est la première fois que j'entends parler de Redmon.

Ce logiciel Redmon te sert-il vraiment ?

As-tu essayé de désinstaller Redmon et de tester ton Ecofax ensuite ?

TRIMIX45
23/02/2010, 02h02
Bon, j'ai bien avancé.
dans un premier temps un fichier temporaire eco*.ps créé à la racine du local setting du profil local du pc (cyrille.portable)
deuxième temps, ce fichier est récupérer par écofax dans le temp du local setting de l'utilisateur.
PROBLEME. si l'utilisateur se connecte sous une session réseau, Redmon et Ecofax se servent des paramêtres des utilisateurs locaux (encore plus vicieux, si on modifier le répertoire temp des variables d'environnement, Ecofax, recréé le repertoire d'origine).

J'ai un peu farfouillé. Visiblement, un bat en complément du fichier ecofax.rsp peut corriger le problème. Mais là c'est pas accessible au niveau des parametres ecofax.

Bon à OVH de bosser. car même si ce n'est pas trop cher, j'aimerai pouvoir utiliser la fonction imprimante virtuelle (c'est pour cela que j'ai choisi cette solution à la base)

TRIMIX45
22/02/2010, 20h11
Bon après différents tests
Cela fonctionne en session locale
par contre dés que je log sur mon réseau (2003) problème

Bien sûr, j'ai le max de droit, étant l'admin du parc.
Si vous avez des pistes ...

TRIMIX45
22/02/2010, 14h07
j' ai désinstallé Adobe 8.
réinstallé le reader 9.
Même symptôme.

fchantret
20/02/2010, 16h39
Citation Envoyé par TRIMIX45
Merci pour ta proposition. Sincèrement j'en prend note et me permettrais si besoin. Ne suis pas au bureau aujourd'hui. Peut être plus simple devant ma machine.

Sinon, effectivement, je ne passe pas directement par Adobe mais bien par Word ou excel ou tout autre application puis impression vers imprimante virtuelle Ecofax.
Soyons fou, j'ai fais le test, j'ai imprimé un document en PDF, puis une fois généré, je l'ai imprimé par Ecofax = même symptome, même avant l'envoi l'aperçu à partir de la console est vide.
Par contre, quand je pars de la console pour pointer un fichier pdf. Là c'est bon
Bon, à priori ça n'est pas Avast 5 qui est en cause puisque ça marche pour Gaston_Phone mais pas pour Trimix45.

Par contre, Trimix, tu as dit un truc intéressant, tu as installé Adobe Pro 8 et je crois qu'on a eu une autre remontée de ce genre d'un autre client (à moins que tu aies contacté le support pour ce problème).

Si tu as la possibilité de déinstaller temporairement Adobe Pro 8, ça permettrait de voir si ça marche (même si il est possible que ça laisse le système dans un état qui flingue EcoFax).

Pure supposition, mais ça serait intéressant de voir si ça n'est pas ça.

TRIMIX45
19/02/2010, 17h25
Merci pour ta proposition. Sincèrement j'en prend note et me permettrais si besoin. Ne suis pas au bureau aujourd'hui. Peut être plus simple devant ma machine.

Sinon, effectivement, je ne passe pas directement par Adobe mais bien par Word ou excel ou tout autre application puis impression vers imprimante virtuelle Ecofax.
Soyons fou, j'ai fais le test, j'ai imprimé un document en PDF, puis une fois généré, je l'ai imprimé par Ecofax = même symptome, même avant l'envoi l'aperçu à partir de la console est vide.
Par contre, quand je pars de la console pour pointer un fichier pdf. Là c'est bon

Gaston_Phone
19/02/2010, 17h09
Dans ce cas là je n'utilise pas d'imprimante PDF : Adobe, PDF Creator, etc.
J'imprime directement depuis WORD sur l'imprimante "Ecofax".

Si tu le souhaites m'avoir au téléphone envoie moi un mail.

TRIMIX45
19/02/2010, 16h52


merci d'avoir fais le test. Quel version d'Adobe as tu d'installé.
Moi c'est Acrobat pro 8.

Gaston_Phone
19/02/2010, 16h00
Je suis sous Windows7 avec Avast v5.

Je viens de m'envoyer un fax à moi-même :
- Ouverture document Office WORD 2007,
- Impression : Choix EcoFax,
- Mode Standard

--> Réception OK (Le fax est bien rempli ).

TRIMIX45
19/02/2010, 15h26
Je suis tout nouveau utilisateur. Donc problème dés le début.

WXP
AVAST FAMILIALE V5
PAS DE FIREWALL LOGICIEL
IMPRIMANTE HP/ADOBE PDF(OPERATIONNEL)

Quand je passe directement par la console Ecofax cela fonctionne
Quand je passe par l'imprimante virtuelle non

J'ai essayé sur un autre poste = même symptôme

fchantret
18/02/2010, 15h24
Non, malheureusement pas d'idée mais nous avons quelques cas et j'aimerai bien identifier le problème...

- Sous quelle plateforme êtes vous ?

- Avez vous un antivirus / anti-spyware / firewall particulier ?

- Avez vous d'autres drivers d'imprimantes pour convertir les PDFs sur votre machine ? Fonctionnent ils ?

- Est ce que le dysfonctionnement a toujours été présent, dès la première utilisation de EcoFax ?

TRIMIX45
18/02/2010, 14h41
Bonjour,

lorsque j'utilise l'imprimante virutelle Ecofax de n'importe quel logiciel, cela me génere systématiquement une page blanche !?

Une idée.

Merci