OVH Community, votre nouvel espace communautaire.

Pbm avec ffmpeg


9clics
28/01/2010, 22h19
J'ai réglé le problème de façon brutale, puisque je ne pouvais pas me permettre de laisser le serveur down, je l'ai ré-installé proprement avec une release 2, sans rien toucher et je me suis commandé un dédié tout neuf avec une gentoo de base. Effectivement, du coup, ça fonctionne, il me reste à tout mettre au carré pour qu'apache / mysql et php fonctionnent correctement et pour que je puisse installer les sites qui vont avec la config de ffmpeg ;-)

Merci pour ton aide en tout cas !

Precea
25/01/2010, 09h35
Hum, j'avais pas vu que tu étais sous release2.
Le problème de cette distrib, c'est qu'il ne faut rien toucher, rien installer et pas mettre à jour ...

Pour t'en sortir faudrait sortir complètement de la R2 et passer en gentoo. Par contre c'est lent et fastidieux. (virer les trucs d'ovh, virer l'overlay ovh, mettre un nouveau profil, emerge -e world 3 fois de souvenir, etc.)

J'ai un script qui transforme ta distro en gentoo propre, mais tu y perds tout sauf ton /home. Donc tu perds tes configuration. Si cela te pose pas de problème, je te donnerais un lien. Mais c'est plus réservé à un admin système avec un peux d'expérience.

9clics
25/01/2010, 08h50
!!! All ebuilds that could satisfy ">=sys-libs/glibc-2.7" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/glibc-2.11-r1 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.11 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.10.1-r1 (masked by: package.mask)
- sys-libs/glibc-2.10.1 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.9_p20081201-r3 (masked by: package.mask, ~x86 keyword)
- sys-libs/glibc-2.9_p20081201-r2 (masked by: package.mask)
- sys-libs/glibc-2.8_p20080602-r1 (masked by: package.mask)
- sys-libs/glibc-2.7-r2 (masked by: package.mask, ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "sys-libs/pam-1.1.0" [ebuild])
(dependency required by "app-misc/screen-4.0.3" [installed])
(dependency required by "world" [argument])

Precea
25/01/2010, 05h44
Donne les erreurs.

9clics
24/01/2010, 22h05
Voila, j'en suis au même point, c'est à dire que le :
# emerge -DavutN world
coince avec pas mal de messages d'erreur ... m'en vais faire le tour du forum pour trouver comment me dépatouiller de ça...

9clics
24/01/2010, 21h45
la dernière fois que j'ai fais ça, ça a tout cassé :-( Allez, je la tente et je te dis si le soucis se pose encore ...

Precea
24/01/2010, 21h41
Pense a mettre ton serveur à jour.

# emerge --sync
# emerge portage
# emerge -DavutN world

Ansi tu vas mettre ton serveur à jour.

9clics
24/01/2010, 20h31
Merci pour la bonne ligne de commande, mais par contre, cela ne change rien, j'ai tjs la même erreur :-S
En même temps, je n'ai à priori pas les mêmes versions que toi... arrrfff, ça deviens casse tête :-(

Precea
24/01/2010, 18h31
echo 'media-video/ffmpeg 3dnow 3dnowext encode faac hardcoded-tables ipv6 mmx mmxext mp3 ssse3 theora vorbis x264 xvid zlib' > /etc/portage/package.use
emerge -av ffmpeg

9clics
24/01/2010, 17h53
j'avoue que je ne suis pas trop spécialiste des installations sur gentoo, mais je viens de ré-emerger ffmpeg avec :
USE="3dnow 3dnowext encode faac hardcoded-tables ipv6 mmx mmxext mp3 ssse3 theora vorbis x264 xvid zlib" emerge ffmpeg

Mais même verdict, j'ai exactement la même erreur.

Precea
24/01/2010, 17h42
Ok, c'est pas normal alors. Car ta ligne fonctionne chez moi.

Voilà les USE que j'ai utilisé : 3dnow 3dnowext encode faac hardcoded-tables ipv6 mmx mmxext mp3 ssse3 theora vorbis x264 xvid zlib

As tu bien mit faac dedans ?

9clics
24/01/2010, 17h22
J'ai pas les mêmes versions que toi, mais j'ai bien la dernière version installée... Et tjs le meme message d'erreur :-(

Precea
24/01/2010, 16h55
Il semble que tu as pas la lib faac.

# emerge --search faac
Searching...
[ Results for search key : faac ]
[ Applications found : 2 ]

* media-libs/faac
Latest version available: 1.28-r1
Latest version installed: 1.28-r1 << si tu vois que c'est installé, c'est que c'est autre chose, sinon :
#emerge -av media-libs/faac

9clics
24/01/2010, 16h51
Bonjour à tous,

J'ai installé ffmpeg et ffmpeg-php sur une release 2 toute fraiche, en suivant le tutoriel suivant :
http://forum.ovh.com/showthread.php?t=12085

Jusque là, tout va bien, mais j'avais besoin d'installer ffmpeg pour faire fonctionner un script php d'upload et d'encodage de vidéos, et c'est à ce moment là que les problèmes arrivent.

En effet, quand je lance l'utilitaire fourni avec le script qui permet de savoir si la config de ffmpeg est correcte, voici le message d'erreur :
Code:
Unknown codec 'libfaac'
FFMPEG est appelé via cette ligne de commande :
Code:
ffmpeg -i $file -y -acodec libfaac -ar 48000 -s 400x300 -vcodec libx264 -threads 4 -b 668k -flags +loop -cmp +chroma -partitions +parti4x4+partp8x8+partb8x8 -flags2 +mixed_refs -me_method  epzs -subq 5 -trellis 1 -refs 5 -bf 3 -b_strategy 1 -coder 1 -me_range 16 -g 250 -keyint_min 25 -sc_threshold 40 -i_qfactor 0.71 -rc_eq 'blurCplx^(1-qComp)' -qcomp 0.6 -qmin 5 -qmax 51 -qdiff 4 $tgtfile
Alors, si quelqu'un avais une idée de ce qui cloche ou éventuellement LA solution pour régler le soucis, je suis preneur !

Merci à tous