OVH Community, votre nouvel espace communautaire.

Probleme DB_File


Conrad
21/02/2004, 23h06
Bonjour,

Je suis dans l'embarras

Bon desormais j'essaye de reinstaller le bundle cpan et j'ai ceci


cpan> install Bundle::CPAN
Going to read /root/.cpan/sources/authors/01mailrc.txt.gz
Going to read /root/.cpan/sources/modules/02packages.details.txt.gz
Database was generated on Sat, 21 Feb 2004 06:49:30 GMT
HTTP:ate not available
Going to read /root/.cpan/sources/modules/03modlist.data.gz
CPAN: Digest::MD5 loaded ok
Can't locate object method "new" via package "Digest::MD5" at /usr/local/lib/perl5/5.6.0/CPAN.pm line 4328.


Je peux faire quoi, cela veut il dire que le module existe ?

Conrad
21/02/2004, 17h33
j'ai suivi le guide et installer cpan puis quelques modules mais a priori on probleme est toujours comment savoir quels modules etaient present a l'origine ?
Merci,
Christophe

Conrad
21/02/2004, 14h40
Merci a tous ,
Je vois que j'ai du boulot en perspective tout ca pour uploader des stats HLstats sur mon dedié
La prochaine fois je ferais plus simple.
Je vous tiens au courant,
Merci
Christophe

OVH
21/02/2004, 13h57
Vous devez probablement reinstaller tous les CPAN qui ont été installés dans la version que vous avez eu avec la machine.

Voici le guide qui devrait vous aider.
http://guides.ovh.net/InstallCpan/

i-services
21/02/2004, 13h54
normal tu le met à jour donc il lui faut une ancienne version

essaie plutot rpm -ivh fichier.rpm

Conrad
21/02/2004, 13h29
Bonjour,

Voila je viens d'installer sur mon dedie redhat 7.2
perl 5.6.1
desormais quand j'essaye d'acceder à OVHM et lorsque je clique sur Ovh Virtual Hosting Management.

j'ai ce message

Error - Perl execution failed
Can't locate DB_File.pm in @INC (@INC contains: /usr/libexec/webmin /usr/local/lib/perl5/5.6.1/i686-linux /usr/local/lib/perl5/5.6.1 /usr/local/lib/perl5/site_perl/5.6.1/i686-linux /usr/local/lib/perl5/site_perl/5.6.1 /usr/local/lib/perl5/site_perl/5.6.0/i686-linux /usr/local/lib/perl5/site_perl/5.6.0 /usr/local/lib/perl5/site_perl .) at /usr/libexec/webmin/ovhm/index.cgi line 13.
BEGIN failed--compilation aborted at /usr/libexec/webmin/ovhm/index.cgi line 13

j'ai reinstalle de nouveau perl, mais rien a faire, ensuite je me suis dit que j'allais installer perl-DB_File

et j'obtiens ceci
tmp]# rpm -U perl-DB_File-1.75-36.1.72.i386.rpm
error: failed dependencies:
perl >= 1:5.6.1-36.1.72 is needed by perl-DB_File-1.75-36.1.72


Si quelqu'un pouvait me venir en aide .

Merci ,
Christophe