OVH Community, votre nouvel espace communautaire.

Accès root impossible via SSH, ou scp


absolom
20/02/2004, 19h34
Tu me sauve, merci !!!!!!!!!!!!!!!!!
Ca à marché, c'ets bon, j'ai retrouvé mon axx root, et je vais patché en 25 le kernel...
Oui, j'avais pas fais, je sais, trop de taff...

Merci elgi!

Elgi
20/02/2004, 19h25
Via webmin, aller dans la rubrique "Autres", puis "Perl modules", là indiquais Digest::MD5 dans le champs prévu à cette effet (on peux aussi naviguer et sélectionner le module via le bouton situé aprés le champs input), on clique sur "installation", hop voila, c'est installé.

On retourne maintenant faire l'opération qui bloquais à cause de ce manque.

absolom
20/02/2004, 18h58
nan, pas possible e faire ça après un su...

i-services
20/02/2004, 18h58
tu utilises bien ssh2 pour te connecter ?

i-services
20/02/2004, 18h55
connecte toi en ssh (via un autre utilisateur puis un su) et tape "passwd" pour changer de mot de passe

absolom
20/02/2004, 18h50
oui...

iRaZ
20/02/2004, 18h48
Merde, ca te dit Access Denied?

absolom
20/02/2004, 18h44
J'ai essayé l'astuce, ça m'a bien pris le nouveau pass, mais ça marche toujours pas...

Fais chier, j'y comprend plus rien...

iRaZ
20/02/2004, 18h37
Heuresement que tu es là

i-services
20/02/2004, 18h34
converti ton pass en md5 avec un script php et ensuite colle le résultat dans "mot de passe crypté" et non "mot de passe en clair"

absolom
20/02/2004, 18h32
idem..

Echec du changement de mot de passe : Missing MD5 or Digest::MD5 perl modules

iRaZ
20/02/2004, 18h26
Sinon dans la parti systeme, tu un menu pour changer les password et la tu selection root et tu remet le meme et puis sa marche

absolom
20/02/2004, 18h22
C'est ce que j'ai fais, mais il me dit qu'il manque un module...
Je vais voir pourle télécharger...

iRaZ
20/02/2004, 18h20
Attends fait ceci :

https://nsxxxx.ovh.net:10000
-> Systeme
* Utilisateur et groupes
- Selectionner "root" dans Utilisateurs locaux

Puis cliquez sur "Mot de passe en texte clair"
-> Si ton page comunicé par OVH est zzzz alors tu met zzz dans la case prevu à cet effet.
* Puis le reste tu laisse
- Sauvegarder

Apres en SSH tu test

absolom
20/02/2004, 18h16
Bah je me logue avec mon user normaol, pui su, mais la, il me dit mot de passe non valide.

Via le webmin, il me dit :

Impossible d'enregistrer l'utilisateur : Missing MD5 or Digest::MD5 perl modules

iRaZ
20/02/2004, 18h11
Moi j'avais la meme chose, donc je me suis conect à webmin apres systeme -> user -> root et tu coche la cache pour mettre ton password en toute lettre et la tu met celui que ta eut dans ton mail puis ok et ca va marcher

quentin
20/02/2004, 18h06
Et en te logguant sous un autre user et puis un :
su -

?

absolom
20/02/2004, 18h04
salut @ tous, je comprend pas, j'ai bien accès à webmin en utilisant l'accès root, mais je ne peux plus me loguer en root via telnet, puis su, ou en ssh , et pas en scp non plus.

Ca marchait très bien il y a encore 1 heure...

Quelq'un à une idée ?

Merci d'avance...