OVH Community, votre nouvel espace communautaire.

Ncftpd - démarrage


Tom
20/02/2004, 18h18
Thanks alot Elgi !

j'ai découvert le problème.

En fait c'était apache qui ne démarrait pas (pour des questions de passphrase). Du coup, j'imagine que inittab ne s'exécutait pas jusqu'au bout.

Maintenant tous les services sont lancés correctement au démarage.

Pour revenir à ce que tu dis + haut démarrer Ncftpd avec le modificateur -d (background démon) marchait très bien.

Merci pour tes conseils j'ai bcp appris. a+ / Thomas

Elgi
20/02/2004, 16h24
Tom écrivait :
Hello Elgi,
Oui j'ai bien cette ligne :

nc:2345:respawn:/usr/local/etc/ncftpd/ncftpd -q /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

Quand je lance le démon avec modificateur -d à la main il n'y a pas de problème.

Qu'est-ce qui ne vas pas avec mon inttab ?
quand je fais :

/usr/local/etc/ncftpd/ncftpd --help
Usage: ncftpd [flags]

Optional Flags (usually set in general config file):
-p XX : Use port XX for control connection (and XX - 1 for data).
-n XX[,YY] : Allow maximum of XX concurrent server users (max-users); keep
at least YY processes running to serve users (min-users).
-v : Print verbose log messages to the screen.
-q : Do not echo log messages to the screen.
-e : Print the detected hostname and exit.
-b : Print the version information and exit.
-d : Run as background daemon.
Exiting.

-q sert donc a ne pas avoir les messages de log à l'écran
-d sert a faire tourner ncftpd en background

inittab, à quoi cela sert ?
de ce que je sais, ca sert a gerer divers services qui ont une certaine tendance a se couper, ne pas vouloir rester en deamon, etc...

La je vois pas d'option pour lancer ncftpd en deamon, donc le mettre dans initab semble etre une solution

Aussi et a savoir, inittab se lance apres tout les services qui doivent etre lance selon le niveau init que l'on demande (cf les chiffres 1 a 6 que l'on peux voir dans le inittab ainsi que les repertoire /etc/rc.d/rcX.d/ qui gere le demarrage ou l'arret selon ce niveau du init)

Hier, on m'a rapelle qu'apres une modification dans le fichier inittab, la commande exacte a lance pour que ces modifications soient prises en compte est :
init -q
ou
telinit
(j'espere ne pas me tromper sur ces commandes )

Donc pour le moment je dirais que si ton fichier ncftpd ne demarre pas alors que ton serveur est au niveau init 3, il y a un truc en effet !
TOn copier-coller montre bien qu'on demande a inittab de lancer ncftpd en init 3 (les autres parametres etant aussi correct, le soucis ne semble pas venir de la).

Tente alors un :
init -q

et avant tente de lancer la commande sous la console pour voir si une erreur en resortirais :
/usr/local/etc/ncftpd/ncftpd -q /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

Tom
20/02/2004, 14h59
Hello Elgi,
Oui j'ai bien cette ligne :

nc:2345:respawn:/usr/local/etc/ncftpd/ncftpd -q /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

Quand je lance le démon avec modificateur -d à la main il n'y a pas de problème.

Qu'est-ce qui ne vas pas avec mon inttab ?

Elgi
20/02/2004, 14h39
Tom écrivait :
Pour une raison que je ne m'explique pas Ncftpd n'a pas redémarré après ma mise à jour du Kernel. Je dois donc le redémarrer à la main comme ca :

/usr/local/etc/ncftpd/ncftpd -d /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

C'est pas terrible ! Ca vous est déja arrivé ? Vous avez une idée de ce que ça peut être ?
Verifie ton repertoire inittab:

cat /etc/inittab

dedans tu devrais avoir une ligne ressemblant a cela :

# ncFTPd
nc:2345:respawn:/usr/local/etc/ncftpd/ncftpd -q /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

as tu bien ca ?

Tom
20/02/2004, 14h12
Pour une raison que je ne m'explique pas Ncftpd n'a pas redémarré après ma mise à jour du Kernel. Je dois donc le redémarrer à la main comme ca :

/usr/local/etc/ncftpd/ncftpd -d /usr/local/etc/ncftpd/general.cf /usr/local/etc/ncftpd/domain.cf

C'est pas terrible ! Ca vous est déja arrivé ? Vous avez une idée de ce que ça peut être ?