OVH Community, votre nouvel espace communautaire.

Erreur depuis la Mise à jour API SOAPI


kiorky
21/02/2011, 22h53
Au passage, je suis entrain de travailler sur l'utilisation de suds qui me parait plus viable (maintenue)

Parcontre la WSDL d'ovh n'est pas valide.
CF https://fedorahosted.org/suds/ticket/388

kiorky
21/02/2011, 22h52
Je viens de prendre l'ownership de wstools et soappy, vous pouvez maintenant faire des easy_install (easy_install SOAPpy). La version étant mis a jour avec les derniers correctifs dispo.

ElBibich
11/02/2011, 14h20
Pour ceux qui cherche encore...

J'ai eu le même problème. Il suffit de télécharger la version 0.12.0, de copier le répertoire SOAPpy/wstools dans le dossier SOAPpy de la dernière version du svn.

et ensuite installer.

Si ça peut servir...
Julien C.

clenoma
23/07/2009, 19h21
up

clenoma
21/07/2009, 00h43
Bonsoir,
J'utilise l'api d'ovh en python avec SOAPpy.

Depuis qu'ovh à mis à jour son api, je dois faire une mise à jour de SOAPpy, c'est indiqué dans ce message :

http://guides.ovh.com/SoApi
Erreur python 'KeyError'
Vous avez le message d'erreur suivant :
* KeyError: u'typens'
La solution :
Utiliser la dernière version de développement de SOAPpy :
http://pywebsvcs.svn.sourceforge.net.../trunk/SOAPpy/

J'ai téléchargé SOAPpy depuis le svn, mais j'ai un problème avec une librairie qu'il utilise :
# python setup.py install
Traceback (most recent call last):
File "setup.py", line 8, in ?
from SOAPpy.version import __version__
File "/tmp/ss/SOAPpy/SOAPpy/__init__.py", line 5, in ?
from Client import *
File "/tmp/ss/SOAPpy/SOAPpy/Client.py", line 58, in ?
from Parser import parseSOAPRPC
File "/tmp/ss/SOAPpy/SOAPpy/Parser.py", line 10, in ?
from wstools.XMLname import fromXMLname
ImportError: No module named wstools.XMLname

Bien entendu, j'ai essayé d'installer la librairie wstools, j'ai trouvé les sources mais pas moyen de l'installer.

Quelqu'un aurait une solution ? A mon avis tous les utilisateurs de l'api sous python on du passer par ce problème.

Merci, nico