OVH Community, votre nouvel espace communautaire.

pb openssl-0.9.7c


-NC-
21/02/2004, 09h07
d'accord donc vu mon niveau 'beginner' on va eviter pcq sinon si je foire qqch faudra banquer c'est bien ca ? :/

OVH
20/02/2004, 19h37
Nous vous deconseilons d'utiliser 0.9.7X pour des raisons qu'on peut redevelopper. Vous allez devoir recompiler l'ensemble des services installés sur la machine commencant par ssh (qui ne va plus fonctionner, activez telnet avant donc), passant par apache, qmail, vpopmail, imap jusqu'à perl et ses modules CPAN. En effet, la version 7 n'est pas compatible avec la version 6 (du tout du tout. les liens symboliques bien placés n'y changeront rien. les services ne fonctionneront plus).

La version 0.9.6 que vous avez est une version la plus recente de 0.9.6 qui comporte toutes les options que vous avez besoins pour faire fonctionner les services.

Puis vous ne pourrez pas profiter des releases ovh pour maintenir la machine à jour.

Maintenant, vous êtes root de votre machine et donc vous pouvez en faire ce que vous voulez. La reinstallation coute 120euro si programmée ou dans la journée. 390euro si dans la nuit/wk ou non programmée.

-NC-
20/02/2004, 17h57
je tente demain, merci

ps
20/02/2004, 15h05
Quand tu as recompilé openssl, par défaut il a du le compiler dans un autre répertoire que la version précédente.

Pour des "raisons historiques", la compilation par défaut installe les binaires dans /usr/local/ssl

Pour être sûr:
which openssl
ça te donne le chemin ou se trouve le premier binaire éxécuté

Regarde ensuite ou a été compilé ton openssl (normalement /usr/local/ssl si t'as pas mis de --prefix lors du configure)

Du coup tu as 2 possibilités:
- tu effaces les binaires de l'ancienne version de openssl et tu vérifies que les binaires de la nouvelle version sont dans ton $PATH

- tu recompiles openssl en précisant :
./configure --prefix=/chemin/anciens/binaires/
ex si which openssl te donnes /usr/bin/openssl alors tu mettras --prefix=/usr/

Je te recommande la deuxième solution, c'est beaucoup plus propre.

-NC-
19/02/2004, 15h47
bah openssl version donne:

[root@ns30041 www]# openssl version
OpenSSL 0.9.6l [engine] 04 Nov 2003


bizarre na? je retente une install ou ya autre chose a faire ?

Elgi
19/02/2004, 15h44
-NC- écrivait :
j'ai install openssl-0.9.7c (les releases l'ont pas mis a jour, si je ne m'abuse) donc config, make make test make install...

50k lignes plus loin tout est termine sans souci, je reload tous les services, puis rien, pas le moindre chgt, g pas l'impression que ca soit bien installe, ya un souci puisque l'en-tete du serv est:

Apache/1.3.29 (Unix) mod_gzip/1.3.19.1a PHP/4.3.4 mod_ssl/2.8.16 OpenSSL/0.9.6l

que faire ? merci.
en ligne de commande :
openssl version

tu devrais avoir la bonne version.
maintenant pour ton phpinfo, faut recompiler php si tu veux voir les bonnes infos, mais a part voir les bonnes infos ca n'apporte rien me semble t'il. c'est juste pour faire bo

-NC-
19/02/2004, 15h30
j'ai install openssl-0.9.7c (les releases l'ont pas mis a jour, si je ne m'abuse) donc config, make make test make install...

50k lignes plus loin tout est termine sans souci, je reload tous les services, puis rien, pas le moindre chgt, g pas l'impression que ca soit bien installe, ya un souci puisque l'en-tete du serv est:

Apache/1.3.29 (Unix) mod_gzip/1.3.19.1a PHP/4.3.4 mod_ssl/2.8.16 OpenSSL/0.9.6l

que faire ? merci.