OVH Community, votre nouvel espace communautaire.

Pb suite à une mise à jour version PHP !!!


Daniel60
27/05/2009, 13h19
Si le script a été développé en php5, sachant que par défaut c'est php4 qui est proposé par OVH, il faut intervenir au niveau d'un .htaccess pour indiquer d'utiliser php5.
Voir la procédure dans les guides.
Mais quand même, "trois mois " !

mr4667-ovh
27/05/2009, 12h34
Bonjour,

Le serveur mutualisé 60gp a été mis à jour au mois de janvier/Février pour une mise à jour de la version PHP. Depuis, le développement du site, qui avait été fait en objet, ne fonctionne plus ! J'ai un message d'erreur "Fatal error: Call to a member function display() on a non-object " alors que l'objet existe... De toute façon, avant cette mise à jour, le site a tourné pdt 6 mois sans problème...

J'ai bien compris que c'était une question de compatibilité de la version PHP, avec une rigueur différente du codage entre PHP4 et PHP5 !

Le seul Hic, ce n'est pas moi qui ai développé ce site, et je suis incapable de trouver comment recoder les scripts...

Quelqu'un pourrait-il m'aider ! Quelqu'un a t-il rencontré ce type de pb sur du développement en objet ? Y a-til un moyen de revenir en arrière sur la version installé sur le serveur ? OVH a t-il une responsabilité dans la mise à jour d'un serveur lorque cela provoque le crash d'un site ?

Merci de m'aider ! Cela fait 3 mois que je galère sur ce pb, et je ne trouve pas de solution...

Merci d'avance.