OVH Community, votre nouvel espace communautaire.

2 virtual host dans httpd.conf


Elgi
18/02/2004, 01h56
Impek écrivait :
C bon j'ai trouvé tout ce qu'il faut ici
http://guides.ovh.com/ListeTodoOVHm/

L'erreur est bien référencée
voila la correction :

fichier effacer_domaine.cgi
remplacer
#on efface aussi le sql.domaine au cas ou
ovhmlib::apache_delete_domain("sql.$domaine");
par
#on efface aussi le sql.domaine au cas ou
ovhmlib::apache_delete_subdomain("$domaine","sql") ;

je poste ca sur la ml de dev d'ovhm

freeway
18/02/2004, 01h41
C bon j'ai trouvé tout ce qu'il faut ici
http://guides.ovh.com/ListeTodoOVHm/

L'erreur est bien référencée

Elgi
18/02/2004, 01h41
Impek écrivait :
Il y a donc bien un script fautif d'origine.
Par ailleurs quand on efface un domaine par ovhm, il n'est pas retiré de httpd.conf
Finalement j'ai tout corrigé a la main, c'est bien plus propre.
pourquoi tu pensais que tout cela se faisait par magie
tu as quel version d'ovhm ?

freeway
18/02/2004, 01h39
Il y a donc bien un script fautif d'origine.
Par ailleurs quand on efface un domaine par ovhm, il n'est pas retiré de httpd.conf
Finalement j'ai tout corrigé a la main, c'est bien plus propre.

Elgi
18/02/2004, 01h09
Impek écrivait :
Ce que je voulais dire c'est que là j'ai une config standart ovh, donc tout le monde doit avoir le meme probleme Vous avez phpmyadmin sur sql.domain.com vous ???
arf tu comprends pas
moi aussi j'ai une config "standart", pourtant je n'ai pas ce probleme !

ce que tu veux dire, mais ne dis pas depuis le debut :

j'utilise ovhm version x.y.z et lorsque j'ajoute un domaine via ovhm donc, j'ai 2 vhost de creer !
l'un a pour servername www.domain.tld, l'autre sql.domain.tld
et je m'apercois que http://sql.domaine.tld est vide !
Comment cela ce fais !?

Et la je te dis encore :
Bah ovhm est un script, et comme webmin il est opensource (on a le droit de regarder les sources ! et meme de les modifier )

et comme tu ne sembles pas vouloir cherche un tout ptit peu !
il s'agit du script creer.cgi d'ovhm !
celui-ci se trouvant la :
/usr/libexec/webmin/ovhm/creer.cgi

il suffit de l'ouvrir, et regarder dedans ce qu'il y a
pour la suite je te laisse faire, parce que j'avance pas dans mon boulot avec votre manque de reflexion continuelle

Mais je reste dispo et te conseille de ne pas faire de modif sasn les comprendre et avoir fait une sauvegarde avant dans le cas ou !

freeway
18/02/2004, 00h57
Ce que je voulais dire c'est que là j'ai une config standart ovh, donc tout le monde doit avoir le meme probleme Vous avez phpmyadmin sur sql.domain.com vous ???

Elgi
17/02/2004, 23h48
Impek écrivait :
bah non c'est webmin qui m'as mit ca par defaut.
Vous devez tous avoir çà aussi dans vos httpd.conf !?
Je ne veut aucun sous domaine.
Mais webmin, c'est juste une application web, nan ?
en regardant l'url qui t'installe un domaine, tu devrais pouvoir retrouver le script fautif, nan ?

quand tu l'auras retrouver, alors ca sera deja plus simple pour trouver ce qui cloche dans ce script
Apres une petite analyse, tu devrais reussir a corriger ton soucis

deja sans un bout de code, et ayant oublie ma boule de cristal, je ne pourrais te dire ce qui cloche

ps : avant de modifier ce script quand tu l'auras trouver, fais signe histoire d'eviter te tout casser avec une modification barbare !

freeway
17/02/2004, 23h43
bah non c'est webmin qui m'as mit ca par defaut.
Vous devez tous avoir çà aussi dans vos httpd.conf !?
Je ne veut aucun sous domaine.

Elgi
17/02/2004, 23h24
Impek écrivait :
Justement le http://sql.domain.com n'afiche rien !
tu cree ce sousdomaine, tu dois bien savoir ce que tu lui dit d'y mettre ?

freeway
17/02/2004, 23h18
Justement le http://sql.domain.com n'afiche rien !

Elgi
17/02/2004, 23h07
Impek écrivait :
Pourkoi dans httpd.conf pour chaque domaine il y a 2 virtualhost créé, dont un avec :

DocumentRoot /home/ovh/www/phpMyAdmin
ServerName sql.domain.com

Il est pas en trop celui là ?
que t'affiche :
http://www.domain.com
et que t'affiche :
http://sql.domain.com

ca devrais repondre a ta question

freeway
17/02/2004, 22h38
Pourkoi dans httpd.conf pour chaque domaine il y a 2 virtualhost créé, dont un avec :

DocumentRoot /home/ovh/www/phpMyAdmin
ServerName sql.domain.com

Il est pas en trop celui là ?