OVH Community, votre nouvel espace communautaire.

PHP include qui ne fonctionne pas.


vincentjuan
11/01/2009, 17h06
Je connais le site du zéro, mais merci quand même !

A pluche.

enycu
11/01/2009, 14h10
Je t'invite à te former au PHP en lisant cet excellent site web:
http://www.siteduzero.com/tutoriel-3...-avec-php.html

vincentjuan
11/01/2009, 13h49
Euh, c'était dans index.html ... Parce que ça ne fonctionnerait que dans index.php? ... Bon OK je crois que va falloir que je me mette au PHP moi. En plus j'aurais du le savoir avec les dizaines d'heures que j'ai passé à bidouiller dans le code de wordpress et consors.

Si c'était ça le problème, j'avoue, je suis un boulet, et j'assume.

Merci.

enycu
10/01/2009, 23h17
Je suppose que le fichier qui contient cet include est bien un fichier .php ?
Moi, j'écris comme cela:

vincentjuan
10/01/2009, 17h44
Bonjour,

Je suis actuellement en train de construire mon site sur mon 60gp et j'expérimente PHP en en faisant un usage très simple.

Je souhaite inclure des meta communes à de nombreuses pages via PHP include.

J'ai procédé comme ceci :
Code:


Et inclus meta.php à la racine de mon site

==> Aucun résultat lors de test en ligne. L'affichage du code source de la page montre qu'à l'endroit du head ou j'attendais mes meta incluses dans meta.php, je retrouve ma fonction include ...

J'ai retenté en modifiant la syntaxte de ma fonction genre
Code:
ou
Code:
car il me semble que ce sont des syntaxes que j'ai croisées sur internet en fouinant avec Google.

==> Toujours aucun résultat.

J'ai essayé d'inclure la fonction dans le body pour voir si ce n'était pas tout simplement pas possible d'utiliser un include dans le head. Pas de résultat non plus. J'ai essayé avec ou sans fichier .htaccess à la racine de mon site, contenant
Code:
SetEnv PHP_VER 5
Bon je suis débutant et je suis un peu allé au bout de mes dons de McGyver là, et je commence à criser.

Un peu d'aide ? Un grand merci, d'avance.