OVH Community, votre nouvel espace communautaire.

How To [Munin]


Romad
14/05/2011, 23h30
Bonsoir à tous,

Bien longtemps plus tard je relance ce forum pour mon cas perso.
Je suis sur une Gentoo 64 OVH
J'ai suivi le tuto et fais les modification qui s'imposait :

echo "=net-analyzer/munin-1.3.4-r1 ~x86 ~amd64" >> /etc/portage/package.keywords

emerge munin

modification du htmldir

copie du répertoire dans /home/ovh/www/munin

mais je reste toujours avec les 2 fichiers htaccess et favicon

Les log donnent ca :

Process Backgrounded
2011/05/14-19:55:47 MyPackage (type Net::Server::Fork) starting! pid(23985)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
2011/05/14-23:16:11 Server closing!
Process Backgrounded
2011/05/14-23:16:12 MyPackage (type Net::Server::Fork) starting! pid(5203)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
Use of uninitialized value in eval {block} exit at /usr/sbin/munin-node line 413, line 59.
Si quelqu'un a une idée je vous en serait très reconnaissant.

Par avance merci

Nicolas

PS : J'édite mon post pour dire que j'ai rajouté a la main la tache CRON et que j'ai mes graphiques. Par contre je n'ai que disk et system

tchouvince
01/03/2010, 16h50
je remonte un peu le bouzin:

Moi j'ai donc installer munin sur un serveur et munin-node sur d'autres serveurs que je veux monitorer.

Le truc c'est qu'il ne me graph rien du tout et je n'ai pas de message d'erreur.

logs du grapher:
Code:
Mar 01 16:45:06 - Starting munin-graph
Mar 01 16:45:06 - Processing domain: domaine.fr
Mar 01 16:45:06 - Processed node: serv1.domaine.fr (0.00 sec)
Mar 01 16:45:06 - Processed node: storage.domaine.fr (0.00 sec)
Mar 01 16:45:06 - Processed node: mysql.domaine.fr (0.00 sec)
Mar 01 16:45:06 - Processed node: web.domaine.fr (0.00 sec)
Mar 01 16:45:06 - Processed domain: domaine.fr (0.00 sec)
Mar 01 16:45:06 - Processing domain: domaine.fr
Mar 01 16:45:06 - Graphed service : open_inodes (0.05 sec * 4)
Mar 01 16:45:06 - Graphed service : apache_processes (0.08 sec * 4)
Mar 01 16:45:06 - Graphed service : entropy (0.04 sec * 4)
Mar 01 16:45:06 - Graphed service : mysql_slowqueries (0.04 sec * 4)
Mar 01 16:45:06 - Graphed service : irqstats (0.11 sec * 4)
Mar 01 16:45:06 - Graphed service : postfix_mailqueue (0.06 sec * 4)
Mar 01 16:45:06 - Graphed service : processes (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : if_eth0 (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : apache_accesses (0.08 sec * 4)
Mar 01 16:45:07 - Graphed service : bind9 (0.06 sec * 4)
Mar 01 16:45:07 - Graphed service : mysql_threads (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : df (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : interrupts (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : swap (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : mysql_bytes (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : smart_sda (0.09 sec * 4)
Mar 01 16:45:07 - Graphed service : load (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : ntp_offset (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : cpu (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : df_inode (0.05 sec * 4)
Mar 01 16:45:07 - Graphed service : postfix_mailvolume (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : mysql_queries (0.06 sec * 4)
Mar 01 16:45:07 - Graphed service : iostat (0.06 sec * 4)
Mar 01 16:45:07 - Graphed service : forks (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : open_files (0.04 sec * 4)
Mar 01 16:45:07 - Graphed service : memory (0.08 sec * 4)
Mar 01 16:45:08 - Graphed service : smart_sdb (0.09 sec * 4)
Mar 01 16:45:08 - Graphed service : vmstat (0.04 sec * 4)
Mar 01 16:45:08 - Processed node: client.domaine.fr (1.56 sec)
Mar 01 16:45:08 - Processed domain: domaine.fr(17.70) (1.56 sec)
Mar 01 16:45:08 - Munin-graph finished (1.57 sec)
Il me graph bien la machine ou est installé à la fois munin et munin-node

logs d'une des nodes:
Code:
2010/03/01-16:45:02 CONNECT TCP Peer: "ip_du_grapher:53682" Local: "machine_supervise:4949"
Sinon je l'utilise avec succes sur une autre infrastructure(hors OVH)

une idée ?

D'avance merci

zuckbin
24/11/2009, 09h27
Bonjour,

J'ai installé Munin sur une Gentoo.

J'ai suivi le tuto à la lettre, mais il ne graffe pas, il ne log pas grand chose.

Je comprend pas, le répertoire /var/www/localhost/htdocs/munin est vide, il n'y a que le favicon.

Merci de votre aide.

J'ai trouvé, il fallait changer la bonne version dans le fichier package.keywords de portage

Ouroboros
29/10/2009, 19h50
Citation Envoyé par thibotus01
Merci pour ces infos . C'est où que je défini l'user et password dans la conf de squid ?
N'importe où dans le squid.conf.
L'ordre a de l'importance uniquement pour les ACLs.

Ouroboros
29/10/2009, 19h35
Pour squid il me semble qu'il faut installer le client de Squid.

Code:
aptitude install squidclient
sur Debian Etch.

Il faut aussi paramétrer le mot de passe pour accéder aux stats :
- dans munin :
Code:
[squid*]
env.squidhost 127.0.0.1
env.squidport 3128
env.squiduser manager
env.squidpasswd ******
- dans squid (normalement pas besoin de mettre "all", tu devrais limiter le nombre de sections accessibles, cf. http://www.visolve.com/squid/squid24...achemgr_passwd) :
Code:
cachemgr_passwd ****** all

acl manager proto cache_object
http_access allow manager localhost
http_access deny manager
L'ACL doit être correctement configurer pour donner accès à Munin uniquement.

Regarde aussi ton demon.log, tu devrais avoir des choses de ce goût là, indiquant que ça marche :
Code:
CACHEMGR: manager@127.0.0.1 requesting 'counters'

Theotime
24/05/2009, 15h30
La MAJ se fait tout les combien de temps ?

Nico94
13/05/2009, 10h39
Bijour,

Je viens de tenter l'install sur un RPS en release 2 et je confirme que ça ne marche pas fort. J'ai suivi le tuto (pour Gentoo donc) à 2 exception près :

1) Etant en release, je n'ai pas fait "emerge apache2"
2) La version de munin à changé, j'ai donc remplacé

echo "=net-analyzer/munin-1.3.3-r2 ~x86 ~amd64" >> /etc/portage/package.keywords
par :

echo "=net-analyzer/munin-1.3.4-r1 ~x86 ~amd64" >> /etc/portage/package.keywords
Je me retrouve en fait dans la situation déjà décrite plus haut par mick29 : j'ai un répertoire /var/www/localhost/htdocs/munin qui contient 2 fichiers (.htaccess et favicon.ico) et qui ne se remplit pas...

J'ai tenté de déplacer ce répertoire vers /home/ovh/www/munin (en changeant le paramètre htmldir et avec les permissions qui vont bien). Ca ne change rien.

Dans mes processus, je vois bien un /usr/sbin/munin-node (donc il tourne mais que fait-il au juste...).

Voici le log :

2009/05/12-22:29:58 MyPackage (type Net::Server::Fork) starting! pid(25116)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
2009/05/12-22:38:40 Server closing!
Process Backgrounded
2009/05/12-22:38:42 MyPackage (type Net::Server::Fork) starting! pid(6538)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
2009/05/13-00:56:42 Server closing!
Process Backgrounded
2009/05/13-01:08:22 MyPackage (type Net::Server::Fork) starting! pid(24654)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
(les "Server closing" correspondent à mes /etc/init.d/munin-node restart)

Des idées ?

Equilibrius
03/04/2009, 13h21
Bonjour, et merci pour ce tuto

J'ai fait des recherche, et impossible de trouver comment ajouter un graph (si je veu surveiller l'utilisation de l'espace disque de tel ou tel dossier par ex., comment je peu faire ? modifier le plugin "df" ? ou en créer un autre ? (sous debian 5)

mick29
24/08/2008, 16h00
Idem j'ai les mêmes fichiers dans ce dossier également

The Destroyeur
24/08/2008, 15h33
Hello,

Regarde la : /var/www/localhost/htdocs/munin/

mick29
24/08/2008, 13h32
Oui j'ai modifié HTMLDIR, la valeur est : /home/ovh/www/munin et ce dossier ne contient que 2 fichier le .htaccess et le favicon

The Destroyeur
24/08/2008, 13h09
Hello,

As-tu changer l'htmldir ?

mick29
24/08/2008, 13h02
Dans le fichier munin-node.log du répertoire /var/log/munin j'ai uniquement les lignes suivantes :

Code:
2008/08/24-12:38:11 Server closing !
Process Backgrounded
2008/08/24-12:38:13 MyPackage (type Net::Server::Fork) starting! pid(11825)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
Et mon dossier munin, contient toujours que le favicon : http://ks33284.kimsufi.com/~ovh/munin/

The Destroyeur
24/08/2008, 12h50
Hello,

Regarde les logs de munin, tu trouveras peut-être ta réponse.

mick29
24/08/2008, 11h43
oui mais actuellement j'ai rien et ça va faire plus d'une heure que j'ai fini la configuration et que j'ai redémarré Munin.
Donc je m'inquiète un peu lol

sum_fvm
24/08/2008, 11h41
Citation Envoyé par mick29
Merci de la réponse
Comment savoir si Munin collecte bien mes données ?
Bah faut regarder s'il graffe

mick29
24/08/2008, 11h34
Merci de la réponse
Comment savoir si Munin collecte bien mes données ?

super_g2
24/08/2008, 11h30
il faut laisser tourner munin un peu

moi ils sont "arrivés" par la suite

mick29
24/08/2008, 10h55
Bonjour,
Mon installation a fonctionné, j'arrive à accéder au dossier où est situé Munin.
En revanche le dossier ne contient que le .htaccess et le favicon
Comment trouver les autres fichiers ?

Cordialement,

super_g2
18/08/2008, 16h25
bon la solution : bourrin j'ai déplacé le .htaccess dans un dossier bien à part (/home/stockage_tmp)
ça marche ^^

voila, si qq1 a le même souci, la solution était toute bête !!

super_g2
18/08/2008, 15h14
re

oui j'ai l'accès root, c'est moi qui est loué le serv et fais les install.. bref j'ai tous les accès.
sinon, j'ai fait ta manip, mais toujours cette loginbox... le dossier de munin est vide... seulement un .htaccess et un favicon.ico... je trouve cela bizarre. une config dans munin à faire??

enjoy

edit : j'ai essayé en ssl (https) : toujours pareil :s

edit2 : j'ai remis le htmldir par défaut, et refait mon lien symbolique, dans tous les cas ca fait pareil ^^
de plus, j'ai fait la commande 'su -c.....' rien d eneuf au bataillon voila

The Destroyeur
18/08/2008, 14h07
Inbox > il est sous release 2 OVH, le path par défaut pour le web, c'est /home/ovh/www, donc s'il veut http://sonip/munin, il faut mettre /home/ovh/www/munin ^^

Il te faut l'accès root pour faire tout sa hein !

super_g2
18/08/2008, 12h54
ce que j'ai fait de manière instinctive.
il me demande login mot de passe.

le root ne fonctionne pas.

merci de m'aider

InboX
18/08/2008, 12h50
Citation Envoyé par The Destroyeur
Tu dois mettre /home/ovh/www/munin
salut,

pas obligatoire "/home/ovh/www/munin"
ca peut etre ailleurs genre /home/admin/www

Il peut le mettre ou il veut.

cordialement,

The Destroyeur
18/08/2008, 12h40
Tu dois mettre /home/ovh/www/munin

super_g2
18/08/2008, 12h17
alors la je t'avoues que c'est du chinois... désolé mais je n'ai rien touché. ^^

edit : trouvé dans munin.conf, dans /etc/munin
je dois mettre quoi?

The Destroyeur
18/08/2008, 10h57
Hello,

As tu changer le htmldir dans la configuration de munin ?

super_g2
18/08/2008, 10h48
bonjour a tous.

Dédié : kimsufi xxl 2008
OS : OVH Release 2 Gentoo

j'ai suivi ce tuto du début à la fin, mais impossible de voir quelquechose à l'adresse http://monip/munin

j'ai fais un symlink dans le dossier /home/ovh/www/ pointant vers /var/www/localhost/htdocs/munin , mais là il me demande login/mot_de_passe.

de plus, dans le dossier "/var/www/localhost/htdocs/munin", il n'y a que .htaccess et favicon.ico. aucun autre fichier.

après 2 réinstall de munin, je ne sais pas quoi faire.

InboX
23/07/2008, 10h00
Le script permet de voir le ping des sites

Cordialement,

lorking
23/07/2008, 09h58
oui il en a qui marche pas
mais tu a éditer car des fois il a des paramaitre a config
ton plugins pour le ping si je me tronpe pas il en a un chez http://muninexchange.projects.linpro...%5D=on&pid=220

moi je cherche pour la bande passent jais test eth0 traffic mais rien

InboX
23/07/2008, 08h43
Salut,

J'ai ajouter un plugins que j'ai trouver sur le net
mais il ne fonctionne pas aucun stats se fait chez moi

le voici
#!/bin/sh

HOSTS="gateway free.fr ovh.com google.fr"

if [ "$1" = "config" ]; then
echo "graph_title Ping response time"
echo 'graph_args --base 1000 -l 0'
echo 'graph_vlabel time(ms)'
echo 'graph_scale no'
for label in $HOSTS;
do
echo "$(echo $label | sed 's/\./_/g').label $label"
done
exit 0
fi
for label in $HOSTS;
do
echo -n "$(echo $label | sed 's/\./_/g').value "
ping -nc1 $label &> /dev/null
if [ "$?" == 0 ]; then
ping -fnc3 $label | tail -n1 | cut -d/ -f4
else
echo
fi
done
je ne vois pas le lien dans la page index des stats.

Voir en image:
http://www.monsterup.com/image.php?u...1216796152.jpg

Comment faire ?
Merci
Cordialement,

lorking
22/07/2008, 21h38
je suis sous gentoo release 2

jais suivi le tuto pour la gentoo release 2

tous c'est bien passer

dans le dossier /var/www/localhost/htdocs/munin

jais tous

le index
un dossier kimsufi.com
.htaccess
definitions.html
favicon.ico
logo.png
style.css



jais config apache pour avoir la page de puis le web /var/www/localhost/htdocs/munin

voici le lien pour voir http://www.munin.evgaming.1s.fr/

merci a vous tous sur tous a The Destroyeur ki ma deja aidé pour mumur super tuto

fblutch
21/07/2008, 16h56
j'ai trouvé !

mise a jour du serveur : rtm et cie
puis reinstalle de munin et ça a marché !

fblutch
21/07/2008, 12h01
Citation Envoyé par The Destroyeur
chown ovhvh -R /home/ovh/www/munin
c'est ce que j'avais fait mais toujours rien sur :

http://monip/~ovh/munin/

The Destroyeur
21/07/2008, 11h34
chown ovhvh -R /home/ovh/www/munin

fblutch
21/07/2008, 11h34
c'est fait mais j'ai toujours un 403 forbidden :s

The Destroyeur
21/07/2008, 11h15
Tu dois le mettre dans le dossier OVH /home/ovh/www/munin.

fblutch
21/07/2008, 11h08
Bonjour,

je suis sous gentoo release 2, j'ai suivi a la lettre le tuto,

mais je n'ai rien quand j'accede a monip/menin sur mon serveur.

J'ai penser a crée un domaine munin pour apache, copier les fichier qui sont dans /var/www/localhost dans /home/munin
mais ça change rien

j'ai fait un chown -R munin sur le /home/munin
mais ça change rien

j'ai changer le path de htmldir dans le munin.conf
mais ça change rien

J'ai plus d'idée ...

merci d'avance !

InboX
15/07/2008, 07h27
Salut,

Et pour Centos 5 Final avez vous une lien pour l'install s'il vous plait ?
car j'ai fait avec yum mais il trouve aucun packet.

[root]-[ns****]-[07:31:38]
[httpdocs]# yum install munin munin-node
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
* base: ftp.halifax.rwth-aachen.de
* updates: mirrors.nl.kernel.org
* addons: ftp.halifax.rwth-aachen.de
* extras: mirror.atrpms.net
Setting up Install Process
Parsing package install arguments
No package munin available.
No package munin-node available.
Nothing to do
Merci
Cordialement,

krok
05/07/2008, 12h24
merci le lien fonctionne (pas avec wget mais le lien est pas mort).

The Destroyeur
05/07/2008, 11h55
Le lien marche

tape:

wget "http://muninexchange.projects.linpro.no/download.php?phid=115"

krok
05/07/2008, 10h45
GG pour ce ptit tuto je suis sous debian sa marche nickel.

par contre j'ai pas pu mettre le plugin teamspeak le lien est mort le domaine existe plus.

kk aurai t 'il un lien pour le DL ?

PS : le chemin des plugins sous debian -> /usr/share/munin/plugin

papykun
05/07/2008, 01h01
Question conne...

J'ai installé Domain Technologie Control (dtc), par contre impossible d'accéder a munin (l'installation se fait mais le répertoire par défaut n ai pas accessible)

Une idée pour régler le souci ?

papykun
21/06/2008, 03h35
te fais un screen patiente un peu

http://papykun.free.fr/munin1.jpg

http://papykun.free.fr/munin2.jpg

http://gorgonite.developpez.com/tuto...ystemes/munin/

Sa devrais aider a optimisé la bête ^^

dark vador 008
21/06/2008, 03h25
Bonjour

On pourrait avoir en image ce que cela donne pour le monitoring?

Combien de ressource prend ce monitoring environs ?

papykun
21/06/2008, 01h00
Code:
aptitude install munin
Message d'erreur :

Code:
Paramétrage de munin-node (1.2.5-1) ...
Initializing plugins..ln: création d'un lien symbolique `/etc/munin/plugins/ip_0.0.0.0/0' vers `/usr/share/munin/plugins/ip_': Aucun fichier ou répertoire de ce type
done.
Starting Munin-Node: done.
Pour régler le souci.

Code:
su -c '/usr/bin/munin-cron' munin
Installation et génération d'image OK.

mais pour le plug in ts la par contre...

Code:
chmod 755 tsuser
en étant dans le répertoire /etc/munin/plugins :

Code:
ln -s /usr/libexec/munin/plugins/tsuser
ln: création d'un lien symbolique `./tsuser' vers `/usr/libexec/munin/plugins/tsuser': Le fichier existe.
La section c est bien rajouter, ds le tsuer j ai modifier le port pour le ts voulu.

Code:
 /etc/init.d/munin-node restart
Bon sa fonctionne

Par contre si je veux désactiver le plug in exim je fais comment ?

Morphau
20/06/2008, 22h47
Oui

EDIT: Et comment le désinstaller à 100 % aussi svp ???

The Destroyeur
20/06/2008, 12h34
Tu es sur quel OS ?

Debian ?

Morphau
20/06/2008, 10h28
Et l'utilisateur non créer pourquoi donc sa ne marche pas svp ???
Merci d'avance

The Destroyeur
20/06/2008, 09h56
Salut,

Tu dois mettre entre " " le lien.

Morphau
20/06/2008, 08h34
Citation Envoyé par Peloo
Code:
cd /usr/libexec/munin/plugins/
Chez moi "libexec" n'existe pas dans usr ...

Ensuite le "wget http://muninexchange.projects.linpro.no/download.php?phid=115" me dl juste la page "download.php?phid=115" donc j'ai dl "tsuser" manuellement via windows ...
Et donc je suis coincé ^^
Comment faire svp ?

papykun
19/06/2008, 17h26
vais tester !! merci ^^

Peloo
19/06/2008, 13h06
Code:
cd /usr/libexec/munin/plugins/

ensuite
Code:
 chmod 755 tsuser
ensuite
Code:
 cd /etc/munin/plugins
ensuite
Code:
 ln -s /usr/libexec/munin/plugins/tsuser
et pour finir
Code:
/etc/init.d/munin-node restart

Morphau
19/06/2008, 12h40
Juste pour savoir, comment le télécharger ?
Car je fait "aptitude install tsuser" ou "apt-get install tsuser" mais sa ne veut pas
Merci d'avance

Peloo
19/06/2008, 12h23
Citation Envoyé par Morphau
En copier collant le dossier "munin" dans l'autre dossier avec mes sites, tout fonctionnent bien
N'oublie pas de l'indiquer dans munin.conf à la ligne "htmldir"


Citation Envoyé par Morphau
Le module teamspeak "tsuser" tu pourrait nous dire comment le mettre stp ?
Merci d'avance
tu dois le placer dans le dossier
Code:
/usr/libexec/munin/plugins/
ensuite un
Code:
 cd /etc/munin/plugins
ensuite un
Code:
 ln -s /usr/libexec/munin/plugins/tsuser
et pour finir un
Code:
/etc/init.d/munin-node restart

Morphau
19/06/2008, 01h33
Moi sa veut toujours pas fonctionné
"Not Found
The requested URL /munin was not found on this server."
Quelqu'un sous debian etc 4.0 avec munin qui fonctionne svp ?
Merci d'avance

EDIT:
C'est bon j'ai trouvé alors le dossier "munin" as été dans /var/www or mes sites sont dans un autre dossier ...
En copier collant le dossier "munin" dans l'autre dossier avec mes sites, tout fonctionnent bien
Le module teamspeak "tsuser" tu pourrait nous dire comment le mettre stp ?
Merci d'avance

Peloo
18/06/2008, 20h58
Sais un mode pour Quake 3
Site officiel : http://www.urbanterror.net

un fps gratuit pas avec des graphisme a la bf2 par exemple mais j'aime bien

The Destroyeur
18/06/2008, 20h36
Urban terror ? =D

Connait pas =D

Peloo
18/06/2008, 19h47
Impect Destroyeur tous fonctionne
j'ai juste dans le le fichier munin-update.log ceci comme erreur
jun 18 19:31:01 [8471] - TLS Notice: No certificate file "/etc/munin/munin.pem". Continuing without private key.
Use of uninitialized value in concatenation (.) or string at /usr/lib/perl5/vendor_perl/5.8.8/i686-linux/Net/SSLeay.pm line 490, line 2.
jun 18 19:31:01 [8471] - TLS Error: Could not enable TLS: 8471: 1 - error:1408A0C1:SSL routines:SSL3_GET_CLIENT_HELLO:no shared cipher
je ne sais pas si ca peut agir sur les graph !?
sinon j'attend la suite sur les plugins intéressants (FPS server CSS, TeamSpeak, etc ...)
car perso je voudrais des graph sur mon serveur de jeu urban terror

The Destroyeur
18/06/2008, 18h24
Regarde le fichier munin-update.log, munin-node est une application pour communiquer entre les serveurs.

Pour ton problème, tape usermod -s /bin/bash munin et sa marchera ^^


(J'ai fait une erreur pour if_eth0 je l'ai corrigée)

Peloo
18/06/2008, 17h41
Salut Destroyeur encore un très bon how to de ta part

l installation sais bien passé sans message d erreur mais par contre quant je fait
su -c '/usr/bin/munin-con' munin
je reçois le message "This account is currently not available."

je suis sous root et gennto rev2 , mes graph reste vide
je dois faire quoi pour que ca fonctionne ?

edit:
je viens d'aller voir les fichiers log et voici ce que j'ai pour le fichier "munin-node.log"

Code:
Process Backgrounded
2008/06/18-18:07:20 MyPackage (type Net::Server::Fork) starting! pid(977)
Binding to TCP port 4949 on host *
Setting gid to "0 0"
Use of uninitialized value in eval {block} exit at /usr/sbin/munin-node line 410,  line 53.

The Destroyeur
18/06/2008, 15h52
Il faut attendre normalement 5min.

Tape su -c '/usr/bin/munin-cron' munin

Il va lancé l'update des données.

Et pour ton problème avec l'ip, supprime le lien avec rm-i.

Morphau
18/06/2008, 13h31
Citation Envoyé par The Destroyeur
Ensuite, on installe munin
Citation:
apt-get munin munin-node
Il me semble que c'est plutôt:
apt-get install munin-code
Citation Envoyé par The Destroyeur
Et normalement, les stats vont se mettre à jour toutes seuls. Vous pouvez les consultez à l'adresse suivante: http://votreip/munin
Et bin rien ne se crée justement
Et dans la fenêtre putty des erreur apparaissent:

Répertoire personnel «*/var/lib/munin*» non créé.
Initializing plugins..ln: création d'un lien symbolique `/etc/munin/plugins/ip_0 .0.0.0/0' vers `/usr/share/munin/plugins/ip_': Aucun fichier ou répertoire de ce type
done.
Starting Munin-Node: done.
Et enfin sous debian il faut mieux utiliser "aptitude" que "apt-get"

The Destroyeur
18/06/2008, 12h19
Bonjour à tous,

Je vais vous expliquer ici comment installer munin sous Debian et sous Gentoo (2 façons différentes)

Munin est un système de monitoring pour serveur dédié (consommation CPU, etc ...)

Debian

On met à jours les paquets
apt-get update
apt-get upgrade
On installe apache si c'est pas fait
apt-get install apache2
Ensuite, on installe munin
apt-get install munin munin-node
Et normalement, les stats vont se mettre à jour toutes seuls. Vous pouvez les consultez à l'adresse suivante: http://votreip/munin

Gentoo

Pour gentoo, c'est un peu plus compliqué malheureusement ^^

Donc il faut d'abord mettre à jours les packets
emerge --sync
On installe apache2
emerge apache2
On ajoute la clé de munin dans le package.keywords
echo "=net-analyzer/munin-1.3.3-r2 ~x86 ~amd64" >> /etc/portage/package.keywords
On installe munin
emerge munin
Maintenant, contrairement à debian, il faut configurer les plugins.

Donc aller dans le dossier /etc/munin/plugins.
cd /etc/munin/plugins
Maintenant, vous devez créer des liens entre le "plugins" et le dossier ou vous êtes pour que munin exécute les plugins.

Voici une listes des plugins que vous pouvez mettre:
ln -s /usr/libexec/munin/plugins/cpu
ln -s /usr/libexec/munin/plugins/df
ln -s /usr/libexec/munin/plugins/if_ if_eth0
ln -s /usr/libexec/munin/plugins/load
ln -s /usr/libexec/munin/plugins/processes
Voici la liste de tous les plugins disponibles:
acpi
amavis
apache_accesses
apache_processes
apache_volume
apc_envunit_
apc_nis
apt
apt_all
bind9
bind9_rndc
cmc_tc_sensor_
colour_tester
courier_
courier_mta_mailqueue
courier_mta_mailstats
courier_mta_mailvolume
cps_
cpu
cpuspeed
cupsys_pages
df
df_abs
df_inode
dhcpd3
digitemp_
entropy
exim_mailqueue
exim_mailqueue_alt
exim_mailstats
files_
foldingathome
foldingathome_rank
foldingathome_wu
forks
fw_conntrack
fw_forwarded_local
fw_packets
hddtemp
hddtemp2
hddtempd
hddtemp_smartctl
http_loadtime
if_
if_err_
ifx_concurrent_sessions_
interrupts
iostat
iostat_ios
ip_
ipac-ng
ipmi_
ircu
irqstats
load
loggrep
lpstat
mailman
mailscanner
mbmon_
memory
mhttping
multiping
multips
munin_stats
munin_update
mysql_bytes
mysql_isam_space_
mysql_queries
mysql_slowqueries
mysql_threads
named
netopia
netstat
nfs4_client
nfs_client
nfsd
nfsd4
ntp_
ntp_kernel_err
ntp_kernel_pll_freq
ntp_kernel_pll_off
ntp_offset
ntp_states
nut_misc
nutups_
nut_volts
nvidia_
open_files
open_inodes
perdition
ping_
plugin.sh
plugins.history
pm3users_
pop_stats
port_
postfix_mailqueue
postfix_mailstats
postfix_mailvolume
postgres_block_read_
postgres_commits
postgres_commits_
postgres_connections
postgres_locks
postgres_queries
postgres_queries_
postgres_space_
processes
proc_pri
ps_
psu_
qmailscan
qmailscan-simple
quota_usage_
samba
sendmail_mailqueue
sendmail_mailstats
sendmail_mailtraffic
sensors_
smart_
snmp__cpuload
snmp__df
snmp__fc_if_
snmp__fc_if_err_
snmp__if_
snmp__if_err_
snmp__load
snmp__memory
snmp__netstat
snmp__processes
snmp__rdp_users
snmp__sensors_fsc_bx_fan
snmp__sensors_fsc_bx_temp
snmp__sensors_fsc_fan
snmp__sensors_fsc_temp
snmp__sensors_mbm_fan
snmp__sensors_mbm_temp
snmp__sensors_mbm_volt
snmp__swap
snmp__uptime
snmp__users
snmp__winload
snmp__winmem
spamstats
squid_cache
squid_icp
squid_objectsize
squid_requests
squid_traffic
surfboard
swap
sybase_space
threads
tomcat_access
tomcat_jvm
tomcat_threads
tomcat_volume
uptime
users
vlan_
vlan_inetuse_
vlan_linkuse_
vmstat
yum
Quand vous avez effectuez un changement, vous devez rebooter munin-node
/etc/init.d/munin-node restart
Ensuite, configurez le plugin (url d'affichage, etc ...). Il se trouve dans /etc/munin.

Je mettrai plus tard des plugins intéressants (FPS server CSS, TeamSpeak, etc ...)