OVH Community, votre nouvel espace communautaire.

[How To] Murmur (Mumble server)


papykun
28/03/2012, 06h25
Bonjour à tous,

Je regarde de nouveau l'installation et la configuration de mumble et je constate que c'est tj aussi prise de tête

Après la lecture des 10 pages, il serait bien de mettre à jour le premier topic peux être et de donner le fameux lien pour configurer ice ou un panel web, car c'est surtout ça qui semble nous poser des soucis ^^

Diax
13/05/2011, 14h44
Bonjour ,

a l heure actuelle j ai une erreur avec mumble .

Warning: IcePHP_stringifyException() expects parameter 2 to be object, null given in /home/gamerpan/www/class/Murmur.php on line 790

Warning: Murmur_InvalidSecretException::__toString() must return a string in Unknown on line 0

Fatal error: Uncaught thrown in /home/gamerpan/www/class/mumble.class.php on line 62

Pourriez vous m eclairer a ce sujet ?

Cool
18/12/2009, 11h14
Citation Envoyé par xana02
SAlut The Destroyeur tu peux envoyer le lien du tuto pour installé par ICE

Merci
Ca serait bien de le mettre à dispo pour tout le monde s'il fonctionne sans encombre

Peloo
16/10/2009, 12h29
Citation Envoyé par cerise95
Salut ,

Pour ceux qui veulent tester un panel mumble complet .

http://mumble-panel.pro.tm

Franchement il est bien
Serveur introuvable

jmp59
23/09/2009, 19h21
moi j'ai un probleme just apré le emerge --sync quand je veux faire le emerge -u portage ou emerge portage il me dit

"!!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
!!! Is the symlink correct? Is your portage tree complete?"

comment faire??

Schen
17/07/2009, 19h38
Petit problème...

Quand je lance cette commande : gcc-config x86_64-pc-linux-gnu-4.1.2

Voici l'erreur qu'on me met : gcc-config: Could not locate 'x86_64-pc-linux-gnu-4.1.2' in '/etc/env.d/gcc/' !

Quelqu'un pour une solution ?

arowan
12/06/2009, 17h20
Citation Envoyé par Olivetiti
Sauf erreur de ma part, cela a déjà été évoqué dans cette discussion.
si tu fais un
Code:
emerge --verbose murmur
Tu pourras te rendre compte de l'erreur évoquée par Geoffroy et qui est dû à la version de Portage qui a besoin d'un update:
Code:
emerge --verbose --update portage
ATTENTION cependant car la mise à jour de portage te fera sortir de la release OVH. Sois conscient que si tu te retrouves avec un système instable par la suite tu as de grandes chances que OVH refuse d'intervenir.
Merci mais ça ne m'aide pas beaucoup

emerge --verbose murmur

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=x11-libs/cairo-1.7.6[svg]".
!!! One of the following packages is required to complete your request:
- x11-libs/cairo-1.8.6-r1 (Change USE: +svg)
(dependency required by "x11-libs/pango-1.24.2" [ebuild])
(dependency required by "x11-libs/gtk+-2.14.7-r2" [ebuild])
(dependency required by "x11-libs/qt-gui-4.5.1" [ebuild])
(dependency required by "x11-libs/qt-qt3support-4.5.1" [ebuild])
Il y a longtemps que je suis sorti de la release. Elle est très complète je n'en disconviens mais elle n'est plus à jour

xana02
12/06/2009, 15h19
SAlut The Destroyeur tu peux envoyer le lien du tuto pour installé par ICE

Merci

Olivetiti
12/06/2009, 15h13
Sauf erreur de ma part, cela a déjà été évoqué dans cette discussion.
si tu fais un
Code:
emerge --verbose murmur
Tu pourras te rendre compte de l'erreur évoquée par Geoffroy et qui est dû à la version de Portage qui a besoin d'un update:
Code:
emerge --verbose --update portage
ATTENTION cependant car la mise à jour de portage te fera sortir de la release OVH. Sois conscient que si tu te retrouves avec un système instable par la suite tu as de grandes chances que OVH refuse d'intervenir.

arowan
06/06/2009, 18h56
Salut,
Que faire avec ça?
emerge murmur
Calculating dependencies... done!

!!! All ebuilds that could satisfy "media-sound/murmur" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/murmur-1.1.8 (masked by: ~x86 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
R2 64 bits

Merci d'avance

CenT
06/06/2009, 12h27
Citation Envoyé par AR51.Kevinos
Pour ajouter un admin sur un server privé mumble (plus communément appelé murmur) tu fait ceci :

1- tu télécharge le programme "sqlite browser" (trouvable sur notre site http://www.team-area51.net/index.php...ption&dl_id=24) et tu l'instal

2- tu ouvre sqlite browser et tu lui fait ouvrire le fichier "murmur.sqlite" qui se trouve dans le dossier d'instal de mumble

3- tu clique ensuite sur le bouton "modify table" (un tableau avec un crayon dessus)

4- tu sélectionne la table "player" et tu fait edit

5- tu clique ensuite sur name et tu fait "edit field"

6- tu va dans la case a coté de "field type" (surtout pas touche au field name sinon gros bobos)

7- tu fait descendre le menu déroulant, et au lieu de TEXT tu met une case blanche (il y a une selection blanche juste en dessous de TEXT)

8- tu fait apply change

9- tu va sur l'onglet "execute sql"

10- tu inscrit ceci :

INSERT INTO players (server_id, name, pw) VALUES (SERVER_ID, "USERNAME","PASSWORD");

sachant que ce qui est en majuscule apres VALUES tu dois le remplacer par les chose correspondante, exemple:

INSERT INTO players (server_id, name, pw) VALUES (1, "tarteamoustache","motdepasse");

11- ton admin est créer
Bonjour, j'aimerai utilisé cette méthode mais je sais pas comment utilisé sqlitebrowser, sa s'ouvre dans une page web ? comment ouvrir précisément le fichier mumble-server.sqlite ... merci de précisé

jyraphe
19/05/2009, 12h46
salut, je suis sous lenny, j'ai installer un serveur de mail, j'ai fais des test d'envois de mail et tout fonctionne parfaitement.

Je viens d'installer mumble-server, j'accède bien à register.cgi, je rempli bien les champs pour enregistrer un utilisateur mais je ne reçois aucun mail.

j'ai essayé avec root, murmur ça ne fonctionne pas.

Si quelqu"un pouvait me donner un coup de main svp, je ne vois pas où ça coince.

edit : je viens de regarder les logs (/var/log/mail.info) : http://pastebin.com/m5d23a3ff

j'avoue ne pas tout comprendre :s

The Destroyeur
12/04/2009, 11h39
Hello,

J'ai fait un tutoriel pour installé ICE, avec sa, vous pourrez gérer votre mumble

valentin
12/04/2009, 08h30
merci Blondin :-)
Là je suis en train d'essayer avec SQLite brower

Blondin
11/04/2009, 11h56
Perso, j'ajoute des membres, via MySQL, mais les channels, ça se fait directement sur le serveur avec le SuperUser ou un compte admin qui a les droits pour éditer les LCA. Pour le root, modifie le registerName, dans le murmur.ini

valentin
10/04/2009, 18h14
J'ai installé mon mumble avec MYSQL.
Par contre, je ne comprends pas j'ai rajouté des channels dans MYSQL
ils ne sont pas apparu dans le mumble
J'ai éditer le channel principal : root et j'ai changé le nom, et c'est tjrs root qui reste affiché
Normal ?

AR51.Kevinos
28/02/2009, 13h24
Pour ajouter un admin sur un server privé mumble (plus communément appelé murmur) tu fait ceci :

1- tu télécharge le programme "sqlite browser" (trouvable sur notre site http://www.team-area51.net/index.php...ption&dl_id=24) et tu l'instal

2- tu ouvre sqlite browser et tu lui fait ouvrire le fichier "murmur.sqlite" qui se trouve dans le dossier d'instal de mumble

3- tu clique ensuite sur le bouton "modify table" (un tableau avec un crayon dessus)

4- tu sélectionne la table "player" et tu fait edit

5- tu clique ensuite sur name et tu fait "edit field"

6- tu va dans la case a coté de "field type" (surtout pas touche au field name sinon gros bobos)

7- tu fait descendre le menu déroulant, et au lieu de TEXT tu met une case blanche (il y a une selection blanche juste en dessous de TEXT)

8- tu fait apply change

9- tu va sur l'onglet "execute sql"

10- tu inscrit ceci :

INSERT INTO players (server_id, name, pw) VALUES (SERVER_ID, "USERNAME","PASSWORD");

sachant que ce qui est en majuscule apres VALUES tu dois le remplacer par les chose correspondante, exemple:

INSERT INTO players (server_id, name, pw) VALUES (1, "tarteamoustache","motdepasse");

11- ton admin est créer

|T-OC|Morpheus
14/02/2009, 19h18
Eh bien, sur ce post-là, t'as les infos avec un panel web qui permet de "manipuler" murmur quand il est en mode mysql : http://forum.ovh.com/showthread.php?t=34485

jyraphe
03/02/2009, 14h49
salut, est ce que quelqu'un a un tuto clair (en anglais ou français) qui explique très bien comment installer murmur ainsi que le panel web pour pouvoir créer des utilisateurs ?

Comme les hébergeurs quoi, parceque murmur a installé tout seul n'est pas un problème mais la création des utilisateurs et autre est un vrai casse tête.

merci

super_g2
02/02/2009, 10h30
Citation Envoyé par Geoffroy
Il faut rajouter ce qui suit dans les fichiers mentionnés :

/etc/portage/package.use
Code:
x11-libs/qt-sql -qt3support
x11-libs/qt-core -qt3support

je mettrai plutot :
dans /etc/portage/package.use
Code:
x11-libs/qt sql core mysql -qt3support
en une ligne, et afin de pouvoir utiliser une bdd mysql si les gens le préfère (notamment cela rend utilisable le murmurwebadmin précédemment proposé ici).
Ceci n'engage que moi mais ça marche bien

Sinon :
gros souci pour utiliser ICEPHP, impossible à installer (cf. post : http://forum.ovh.com/showthread.php?t=38857 et http://forum.ovh.com/showthread.php?t=42789

Geoffroy
04/01/2009, 17h05
Bon bon bon. Il y a eu quelques changements dans l'ebuild, alors il faut reprendre ça proprement :
Il faut rajouter ce qui suit dans les fichiers mentionnés :

/etc/portage/package.use
Code:
x11-libs/qt-sql -qt3support
x11-libs/qt-core -qt3support
/etc/portage/package.keywords
Code:
media-sound/murmur
=x11-libs/qt-core-4.4.2*
=x11-libs/qt-dbus-4.4.2*
=x11-libs/qt-sql-4.4.2*
edit : Pour les problèmes d'EAPI : mettez à jour portage vers la dernière version stable 2.1.6.4 de mémoire.
Si vous êtes en Release 2, vous en "sortez" allègrement.

Danux
04/01/2009, 16h34
Bonjour!

J'ai un gros soucis, je n'arrive pas a compiler QT a cause du paquet cups :/

Code:
 * ERROR: net-print/cups-1.3.9-r1 failed.
 * Call stack:
 *              ebuild.sh, line 1701:  Called dyn_compile
 *              ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *              ebuild.sh, line   44:  Called src_compile
 *   cups-1.3.9-r1.ebuild, line  180:  Called die
 * The specific snippet of code:
 *      emake || die "emake failed"
 *  The die message:
 *   emake failed

Si vous savez m'aider ce serait super car là je suis complètement perdu! :/

Ardar
12/12/2008, 12h56
Citation Envoyé par Geoffroy
Bonsoir,

Pour tous les utilisateurs de Gentoo ou Release 2 OVH souhaitant installer facilement Murmur 1.1.6 "has just hit the tree" :
Détails : http://bugs.gentoo.org/show_bug.cgi?id=207627
Package : http://gentoo-portage.com/media-sound/murmur

Donc plus besoin de passer par un overlay, ou une installation à la main, ou les incantations du début de ce topic.

Code:
echo "media-sound/murmur" >> /etc/portage/package.keywords
echo USE=\"-qt3support\" >> /etc/make.conf
emerge --sync --verbose
emerge --ask --verbose murmur
edit : amélioration pour éviter d'entrainer l'installation d'un paquet de dépendances qt3, inutiles ici. Malheureusement, on sera obligé de passer par l'installation de qt-core. Suivant les machines, ça peut être un peu long.
Bonjour,
Je viens vers vous parce que j'ai un petit soucis pour l'installation de murmur.

Lorsque je fais le emerge --ask --verbose murmur
J'ai ça qui arrive :
Code:
These are the packages that would be merged, in order:

Calculating dependencies \
!!! All ebuilds that could satisfy "media-sound/murmur" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/murmur-1.1.6 (masked by: EAPI 2)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
Et j'avoue être totalement bloqué. (Je cherche un peu mais ce n'est pas très concluant pour le moment )

Geoffroy
29/10/2008, 22h12
Bonsoir,

Pour tous les utilisateurs de Gentoo ou Release 2 OVH souhaitant installer facilement Murmur 1.1.6 "has just hit the tree" :
Détails : http://bugs.gentoo.org/show_bug.cgi?id=207627
Package : http://gentoo-portage.com/media-sound/murmur

Donc plus besoin de passer par un overlay, ou une installation à la main, ou les incantations du début de ce topic.

Code:
echo "media-sound/murmur" >> /etc/portage/package.keywords
echo USE=\"-qt3support\" >> /etc/make.conf
emerge --sync --verbose
emerge --ask --verbose murmur
edit : amélioration pour éviter d'entrainer l'installation d'un paquet de dépendances qt3, inutiles ici. Malheureusement, on sera obligé de passer par l'installation de qt-core. Suivant les machines, ça peut être un peu long.

elpopo
01/10/2008, 16h57
merci galérien, j'ai fouillé un peu mais il me semble qu'il est obligatoire d'avoir un dédié

galerien
01/10/2008, 16h53
Salut,

Sur start5g, franchement je ne pense pas que ce soit possible. Je pense qu'il te faudra un dedier donc au moins un rps. D'autres confirmeront.

Tu peux l'installer sur un pc, en mode local ou lan. Sinon, je crois que c'est uniquement dispo sur linux en dédier. En même temps bcp de serveurs de jeux tournent sous linux.

Non, l'interface ovh (sauf erreur de ma part) ne propose pas cette option.

Si tu as un dédier, tu l'installes toi même en suivant les indications de ce post.

elpopo
01/10/2008, 16h43
Bonjour à tous, je viens de lire ce thread et j'ai compris environ 1 mot sur 10

J'aurai voulu savoir si il était possible d'installer un server mumble ou ventrilo sur une offre mutualisée start5g. Si oui, est ce que cela fonctionne aussi bien qu'un server vocal que l'on loue? (latence?)

Enfin comment l'installer si on a pas linux? (interface ovh?)

désolé si mes questions semblent bêtes, mais j'ai vraiment aucune connaissance dans ce domaine (mais j'ai envie d'apprendre)...

Matthieu

edit: non on peut pas sur une offre mutualisée ^^

didou038
24/09/2008, 16h15
bonjour a tous !

voila je suis sous ubunutu hardy heron, je sais c'est pas gentoo, désolé.

j'ai suivi ce tuto :

http://forum.ovh.com/showthread.php?t=34485 et j'y repondu ce qui suit :

merci pour ce tuto !

je l'ai suivi a la lettre et j'arrive parfaitement a me connecter en mettant comme adresse localhost

J'ai un dyndns d'activer qui fonctionne parfaitement aussi. j'ai donc essayer de me connecter au server en mettant l'adresse dns de mon pc (et j'ai essayer aussi directement avec l'ip fourni par mon FAI) bah a marche pas ! j'ai pourtant bien fait la redirection sur mon routeur vers l'ip de mon pc qui heberge le serveur. Je n'ai aucun soucis avec mon serveur teamspeak pour info qui lui aussi est heberger sur ce pc.

Savez-vous ce que je doit faire pour que ce serveur soit accessible depuis l'exterieur de mon reseau local ?

merci d'avance !
auriez-vous une idée sur ce problème ?

merci d'avance

Geoffroy
14/09/2008, 17h59
Si quelqu'un veut comprendre pourquoi la machine de gunichou peine tellement, je lui suggère de tenter un petit, tout petit "emerge -C coreutils". Bon courage pour ravoir la machine après.
Code:
root@nsXXXX / # /bin/ls
-bash: /bin/ls: Aucun fichier ou r�pertoire de ce type


edit : heureusement, dans sa grande bonté, OVH met à disposition un BINHOST avec des archives des paquets qu'ils mettent à jour dans le patch de release. Il n'y a plus qu'a récupérer l'archive de coreutils, (wget et tar étant toujours là, heuresement), de prier pour que les binaires soient linkés sur une glibc-2.3 (et pas sur une 2.4, grrrrr http://tinderbox.dev.gentoo.org/default-linux/x86/All/), l'extraire à la main, puis "env-update && source /etc/profile" (here comes the beautifull sheel). On a donc récupéré ce qu'il faut pour utiliser emerge : il faut alors ré-emerger proprement coreutils.

reedit
: ftp://ftp.ovh.net/made-in-ovh/release/binhost/ ; ça pourra peut être servir à quelqu'un.

Geoffroy
14/09/2008, 16h45
Je ne sais pas ce que vous lui avez fait à cette pauvre machine ... Si vous voulez, contactez moi par mail, je me chargerai de ce passage problématique (avec plus de réussite qu'il y a 15 jours, évidemment ).

gunichou
14/09/2008, 16h38
Encore plein d'erreurs ...
Je commence à croire qu'on aurait du prendre une autre release plus "conventionnelle" ^^

root@ns38450 ~ # emerge -vu util-linux && emerge -vu coreutils && emerge -vu por tage && emerge -vu bash

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/ncurses-5.6-r2 [5.6-r1] USE="gpm unicode -debug -doc -m inimal -nocxx -profile% -trace (-bootstrap%) (-build%)" 2,353 kB
[ebuild N ] dev-util/unifdef-1.20 65 kB
[ebuild U ] sys-devel/gettext-0.17 [0.16.1-r1] USE="acl%* nls openmp%* -doc -emacs -nocxx" 11,369 kB
[ebuild U ] sys-kernel/linux-headers-2.6.23-r3 [2.6.11-r2] 4,671 kB
[ebuild U ] sys-libs/com_err-1.40.9 [1.40.4] USE="nls" 3,997 kB
[ebuild U ] sys-libs/ss-1.40.9 [1.40.4] USE="nls" 0 kB
[ebuild U ] sys-fs/e2fsprogs-1.40.9 [1.40.4] USE="nls -static" 0 kB
[ebuild U ] sys-apps/util-linux-2.13.1.1 [2.12r-r8] USE="crypt nls unicode%* -loop-aes% -old-linux% (-selinux) -slang% (-old-crypt%) (-perl%*) (-static%)" 2 ,764 kB

Total: 8 packages (7 upgrades, 1 new), Size of downloads: 25,216 kB

>>> Verifying ebuild Manifests...

>>> Emerging (1 of 8) sys-libs/ncurses-5.6-r2 to /
/usr/lib/portage/bin/ebuild.sh: line 836: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 839: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 845: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 846: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 847: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 848: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 849: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 850: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 851: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 852: rm: command not found
/usr/lib/portage/bin/ebuild.sh: line 861: rm: command not found
>>> Downloading 'http://mirror.ovh.net/gentoo-distfiles/distfiles/ncurses-5.6.ta r.gz'
--17:37:16-- http://mirror.ovh.net/gentoo-distfil...rses-5.6.tar.g z
=> `/usr/portage/distfiles/ncurses-5.6.tar.gz'
Résolution de mirror.ovh.net... 213.186.33.37, 213.186.33.38
Connexion vers mirror.ovh.net|213.186.33.37|:80...connecté.
requête HTTP transmise, en attente de la réponse...200 OK
Longueur: 2,402,592 (2.3M) [application/x-gzip]

100%[====================================>] 2,402,592 7.17M/s

17:37:16 (7.17 MB/s) - « /usr/portage/distfiles/ncurses-5.6.tar.gz » sauvegardé [2402592/2402592]

>>> Downloading 'http://mirror.ovh.net/gentoo-distfiles/distfiles/ncurses-5.6-co verity.patch.gz'
--17:37:16-- http://mirror.ovh.net/gentoo-distfil...rses-5.6-cover ity.patch.gz
=> `/usr/portage/distfiles/ncurses-5.6-coverity.patch.gz'
Résolution de mirror.ovh.net... 213.186.33.38, 213.186.33.37
Connexion vers mirror.ovh.net|213.186.33.38|:80...connecté.
requête HTTP transmise, en attente de la réponse...200 OK
Longueur: 6,196 (6.1K) [application/x-gzip]

100%[====================================>] 6,196 --.--K/s

17:37:16 (1.32 MB/s) - « /usr/portage/distfiles/ncurses-5.6-coverity.patch.gz » sauvegardé [6196/6196]

* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking ncurses-5.6.tar.gz ;-) ... [ ok ]
* checking ncurses-5.6-coverity.patch.gz ;-) ... [ ok ]
Traceback (most recent call last):
File "/usr/bin/emerge", line 6518, in ?
retval = emerge_main()
File "/usr/bin/emerge", line 6512, in emerge_main
myopts, myaction, myfiles, spinner)
File "/usr/bin/emerge", line 5971, in action_build
retval = mergetask.merge(pkglist, favorites, mtimedb)
File "/usr/bin/emerge", line 3849, in merge
prev_mtimes=ldpath_mtimes)
File "/usr/lib/portage/pym/portage.py", line 4341, in doebuild
alwaysdep=1, logfile=logfile)
File "/usr/lib/portage/pym/portage.py", line 3465, in spawnebuild
retval=spawnebuild(actionmap[mydo]["dep"],actionmap,mysettings,debug,alwaysd ep=alwaysdep,logfile=logfile)
File "/usr/lib/portage/pym/portage.py", line 3465, in spawnebuild
retval=spawnebuild(actionmap[mydo]["dep"],actionmap,mysettings,debug,alwaysd ep=alwaysdep,logfile=logfile)
File "/usr/lib/portage/pym/portage.py", line 3465, in spawnebuild
retval=spawnebuild(actionmap[mydo]["dep"],actionmap,mysettings,debug,alwaysd ep=alwaysdep,logfile=logfile)
File "/usr/lib/portage/pym/portage.py", line 3465, in spawnebuild
retval=spawnebuild(actionmap[mydo]["dep"],actionmap,mysettings,debug,alwaysd ep=alwaysdep,logfile=logfile)
File "/usr/lib/portage/pym/portage.py", line 3470, in spawnebuild
phase_retval = spawn(actionmap[mydo]["cmd"] % mydo, mysettings, debug=debug, logfile=logfile, **kwargs)
File "/usr/lib/portage/pym/portage.py", line 2583, in spawn
set_term_size(rows, columns, slave_fd)
File "/usr/lib/portage/pym/output.py", line 347, in set_term_size
spawn(cmd, env=os.environ, fd_pipes={0:fd})
File "/usr/lib/portage/pym/portage_exec.py", line 179, in spawn
raise CommandNotFound(mycommand[0])
portage_exception.CommandNotFound: stty

Geoffroy
13/09/2008, 20h55
Dans cet ordre, ça devrait éviter les blocker :
Code:
emerge -vu util-linux && emerge -vu coreutils && emerge -vu portage && emerge -vu bash

gunichou
13/09/2008, 20h22
/$ emerge --info
Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-3.4.6, glibc-2.3.6-r3, 2.6.24.5-grsec-xxxx-grs-ipv4-32 i686)
================================================== ===============
System uname: sh: uname: command not found
Timestamp of tree: Fri, 12 Sep 2008 21:00:01 +0000
app-shells/bash: 3.2_p17
dev-lang/python: 2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.11.14-r8
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.61-r2
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1, 1.10.1
sys-devel/binutils: 2.18-r3
sys-devel/gcc-config: 1.3.13-r2
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/local/apache/conf /usr/local/lib/php4 /usr/local/lib/php5 /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR@euro"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage-ovh"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl acpi alsa arts berkdb cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer hal iconv ipv6 isdnlog jpeg kde kerberos ldap mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptlonly ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline reflection session spell spl sse sse2 ssl svg tcpd tiff truetype unicode vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
/$ emerge -pv mktemp
These are the packages that would be merged, in order:
Calculating dependencies ..... done!
[ebuild U ] sys-apps/coreutils-6.10-r2 [6.9-r1] USE="acl nls (-selinux) -static -vanilla% -xattr" 3,692 kB
[ebuild U ] sys-apps/debianutils-2.28.5 [2.15] USE="-static (-build%)" 136 kB
[ebuild N ] sys-apps/mktemp-1.5 69 kB
[blocks B ] sys-apps/mktemp (is blocking sys-apps/coreutils-6.10-r2)
[blocks B ] [blocks B ] >=sys-apps/coreutils-6.10 (is blocking sys-apps/mktemp-1.5)
Total: 3 packages (2 upgrades, 1 new, 3 blocks), Size of downloads: 3,897 kB
/$ emerge -pv util-linux
These are the packages that would be merged, in order:
Calculating dependencies .... done!
[ebuild U ] sys-apps/util-linux-2.13.1.1 [2.12r-r8] USE="crypt nls unicode%* -loop-aes% -old-linux% (-selinux) -slang% (-old-crypt%) (-perl%*) (-static%)" 2,764 kB
Total: 1 package (1 upgrade), Size of downloads: 2,764 kB
/$ emerge -pv coreutils
These are the packages that would be merged, in order:
Calculating dependencies .... done!
[ebuild U ] sys-apps/coreutils-6.10-r2 [6.9-r1] USE="acl nls (-selinux) -static -vanilla% -xattr" 3,692 kB
[blocks B ] Total: 1 package (1 upgrade, 1 block), Size of downloads: 3,692 kB
/$ emerge -pv bash
These are the packages that would be merged, in order:
Calculating dependencies .... done!
[ebuild U ] app-shells/bash-3.2_p33 [3.2_p17] USE="nls -afs -bashlogger -plugins% -vanilla" 2,564 kB
[blocks B ] Total: 1 package (1 upgrade, 1 block), Size of downloads: 2,564 kB
/$ emerge -pv portage
These are the packages that would be merged, in order:
Calculating dependencies ... done!
[ebuild U ] sys-apps/sandbox-1.2.18.1-r2 [1.2.17] 232 kB
[ebuild U ] sys-apps/portage-2.1.4.4 [2.1.3.19] USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl" 368 kB
Total: 2 packages (2 upgrades), Size of downloads: 599 kB
Oui on a réinstallé le serveur sur une base Release2.

Geoffroy
12/09/2008, 22h42
Il me faudrait quelques infos :
emerge --info
emerge -pv mktemp
emerge -pv util-linux
emerge -pv coreutils
emerge -pv bash
emerge -pv portage

La machine a été réinstallée depuis la dernière fois ?

gunichou
12/09/2008, 22h28
Dorénavent j'ai ça en installant (sauf GCC ) :

ns38450 ~ # emerge -u portage
Calculating dependencies... done!

!!! Error: the !!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handboo...full=1#blocked
locate util-linux-2.13
/usr/portage/metadata/cache/sys-apps/util-linux-2.13.1.1
/usr/portage/sys-apps/util-linux/files/util-linux-2.13-ioprio-syscalls.patch
/usr/portage/sys-apps/util-linux/files/util-linux-2.13-setuid-checks.patch
/usr/portage/sys-apps/util-linux/files/util-linux-2.13-uclibc.patch
/usr/portage/sys-apps/util-linux/files/util-linux-2.13.1-no-a.out.patch
/usr/portage/sys-apps/util-linux/util-linux-2.13.1.1.ebuild
/var/cache/edb/dep/usr/portage/sys-apps/util-linux-2.13-r1
/var/cache/edb/dep/usr/portage/sys-apps/util-linux-2.13-r2

The Destroyeur
11/09/2008, 19h55
Comme je l'ai dit, il en existe un qui marche parfaitement !

jyraphe
11/09/2008, 18h56
ok si je peux aider.

The Destroyeur
11/09/2008, 18h25
Hello,

Avec le nouveau serveur (static 1.1.5), il y a une gestion du port "ICE".

Un panel est installé (register.php) mais il vous faut installer le plugin "ICE", qui est une grosse 'çè"é'é&é" a installé.

Je ferai un tutoriel du comment et du pourquoi par la suite.

jyraphe
11/09/2008, 18h17
salut, est ce que quelqu'un serait prêt à m'aider pour rédiger un tuto de A à Z pour installer un mumble + gestion des utilisateurs (CGI toussa...) avec un panel web comment on en voit chez les hébergeurs...

Un tuto pour les newbies quoi...parce que là même en faisant le tour de la toile, y a des trucs pas très clairs (en tout cas pour moi).Je galère même avec les wiki,readme...

Alpha_67
05/09/2008, 01h43
Salut,


j'ai installé mumble sur une lenny avec le panel web mais rien ne fonctionne via le pannel :s

Il m'indiquer que le serveur est démarrer mais il n'est pas dans les processus... je le lance, je sélectionne stop > rien ne ce passe...

Je clique sur n'importe quoi dans la fenêtre de gauche, rien ne ce passe... même pas se déconnecter fonctionne xD

Bref TS à encore de très beau jour.

Geoffroy
31/08/2008, 18h51
C'est quand même pas sorcier de lire l'ebuild pour la version 1.1.1
Citation Envoyé par mumble.1.1.1.ebuild
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-sound/mumble/mumble-1.1.1.ebuild,v 1.5 2008/07/28 21:21:14 carlo Exp $

EAPI=1

inherit eutils toolchain-funcs qt4

DESCRIPTION="Voice chat software for gaming written in Qt4"
HOMEPAGE="http://mumble.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="pulseaudio vanilla"

DEPEND="=x11-libs/qt-4.3*:4
>=media-libs/speex-1.2_beta3
media-libs/alsa-lib
dev-libs/boost
x11-libs/libXevie
pulseaudio? ( media-sound/pulseaudio )"


RDEPEND="${DEPEND}"

pkg_setup() {
if ! built_with_use -a =x11-libs/qt-4* sqlite3 dbus ; then
echo
if ! built_with_use =x11-libs/qt-4* sqlite3; then
eerror "You need to build Qt4 with the sqlite3 use-flag"
fi
if ! built_with_use =x11-libs/qt-4* dbus; then
eerror "You need to build Qt4 with the dbus use-flag"
fi
echo
die "Your Qt4 installation lacks propper useflag configuration, see above"
fi

if [[ $(gcc-major-version) -eq 3 && $(gcc-minor-version) -lt 4 ]]; then
eerror "You need >=sys-devel/gcc-3.4 to compile ${PN}."
die "System gcc is too old to compile ${PN}."
fi
}

[...]
Rajoutez à celà la doc officielle http://mumble.sourceforge.net/BuildingLinux si nécessaire, et ça évite les ennuis.

The Destroyeur
31/08/2008, 18h27
Mumble est simplement une vrai ***** à compiler je l'avoue ...

Sur debian c'est vachement plus simple.

Geoffroy
31/08/2008, 17h25
Ce tutoriel est une blague. Je viens de passer 3heures à bosser sur une machine en vrac où le "emerge gcc" avait été fait, suivi d'un gcc-config.
Je recommande de ne PAS suivre ce tutoriel tel quel.

Quand on ne sait pas, on ne fait pas. Surtout changer de compilateur sous Gentoo.

edit : ça n'a rien de personnel The Destroyeur. Mais franchement, quand je lis des choses comme ça, ça me fout des boutons.

gunichou
27/08/2008, 20h26
Ok donc ... ?
Je suis largué complet lol

The Destroyeur
27/08/2008, 20h20
Il faut recompiler mumble ^^

gunichou
27/08/2008, 18h57
Bon ben pas mieux ...
J'ai fini l'install de qtdbus mais le même message quand je lance Mumble.

gunichou
27/08/2008, 18h50
J'ai adapté le tuto pour Gentoo
J'en suis à la phase "make install"

The Destroyeur
27/08/2008, 18h22
Hello,

Tu es sous quel OS ?

gunichou
27/08/2008, 17h43
Je viens de trouver cette procédure.Est-ce la bonne manip à faire ?
http://doc.trolltech.com/4.2/install-x11.html

gunichou
27/08/2008, 17h10
Heuuuuuu ... Non lol.
J'ai fait avec dbus moi ...
Je vais chercher comment on l'installe et je reviens ici

The Destroyeur
27/08/2008, 17h07
Hello,

Est-ce que tu as installer qtdbus au moins ?

gunichou
27/08/2008, 13h05
Salut à tous.
Super tuto mais j'ai le même soucis que HanOuk:

cd src/murmur/ && make -f Makefile
make[1]: Entering directory `/home/murmur/install/mumble-1.1.4/src/murmur'
make -f Makefile.Release
make[2]: Entering directory `/home/murmur/install/mumble-1.1.4/src/murmur'
g++ -pipe -Wshadow -Woverloaded-virtual -Wold-style-cast -Wconversion -Wsign-compare -fvisibility=hidden -O2 -march=i686 -pipe -I/usr/kerberos/include -Wall -W -D_REENTRANT -DRESTRICT=__restrict__ -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include/qt4/QtDBus -I../../src -Irelease -I. -x c++-header -c murmur_pch.h -o release/murmurd.gch/c++
murmur_pch.h:12:25: QtDBus/QtDBus : Aucun fichier ou répertoire de ce type
make[2]: *** [release/murmurd.gch/c++] Erreur 1
make[2]: Leaving directory `/home/murmur/install/mumble-1.1.4/src/murmur'
make[1]: *** [release] Erreur 2
make[1]: Leaving directory `/home/murmur/install/mumble-1.1.4/src/murmur'
make: *** [sub-src-murmur-make_default-ordered] Erreur 2
ns38450 mumble-1.1.4 #
Aprés si je fais un ./murmur -supw j'obtiens un:
-bash: syntax error near unexpected token `newline

papykun
27/08/2008, 09h54
Merci c'est gentil

The Destroyeur
27/08/2008, 09h35
Hello,

Je suis en train de scripter en perl pour créer plusieurs serveurs mumble sur un seul serveur.

Je vous donnerai sa quand j'aurai fini.

Cordialement,
deStrO

Slitax
26/08/2008, 18h54
Citation Envoyé par sum_fvm
Faut créer deux dossiers distincts normalement...

Sinon, je suis d'accord avec toi, le dbus c'est pas évident à comprendre, d'où la popularité limitée de mumble...
Ok, je vais tester ça alors pour voir si ça marche
Sinon j'essaye toujours en parallèle avec dbus, mais je ne comprend vraiment rien avec leurs articles sur le site officiels :s

Voila, j'ai réussi avec les paquets, en lanceant plusieurs fois la commande murmurd -ini, je comprend pas pourquoi maintenant ça marche, mais en tout cas les serveurs tournes, maintenant je vais essayer de comprendre comment donner des droits à certains utilisateurs

D'ailleur, est-ce qu'il y a une commande pour lister tout les serveurs qui tournes ? Car il y en a bien une, lorsque l'on utilise dbus pour virtualiser les serveurs, mais sinon, la seul solution c'est un ps -aux |grep murmurd ?

sum_fvm
26/08/2008, 18h43
Faut créer deux dossiers distincts normalement...

Sinon, je suis d'accord avec toi, le dbus c'est pas évident à comprendre, d'où la popularité limitée de mumble...

Slitax
26/08/2008, 18h12
J'ai une question, j'aimerai lancé plusieurs serveur Mumble sur mon dédié, mais je n'arrive pas à le faire.

Y-a-t il une commande spécifique ? Car là je lançais deux fois la commande :
murmurd -ini maconf.ini -supw monpass
Mais le problème, c'est que ça ne marche pas, quand je fais ça, le deuxième serveur ne se lance pas.
J'ai essayer de regarder la doc officiel du site, mais je ne comprend vraiment rien avec leur commande dbus :'(

Je suis sous Debian etch.

Sebbabas
10/08/2008, 21h30
c est bon ca roule

Sebbabas
09/08/2008, 23h44
Bonsoir
Super tuto mais malheureusement quand je tape la premiere commande et les autre le serveur répond :
superuser access is required.
Que faire?
Merci

The Destroyeur
19/07/2008, 09h32
Oui mais cette avec cette version, tu ne peux pratiquement rien faire, c'est sa le soucis.

Han0uk
19/07/2008, 05h20
Il y a celui-ci comme how-to aussi et franchement cela a marché direct sans soucis.

http://forum.ovh.com/showthread.php?t=34485

The Destroyeur
18/07/2008, 17h45
echo "=media-sound/murmur-0.9.4-r1 ~x86" >> /etc/portage/package.keywords
Tape sa

virtuaboy
18/07/2008, 09h21
Bonjour,

Voici l'erreur que j'obtiens lorsque je faire un "emerge murmur"

r13470 ~ # emerge murmur
Calculating dependencies -
!!! All ebuilds that could satisfy "murmur" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/murmur-0.9.4 (masked by: ~x86 keyword)
- media-sound/murmur-0.9.4-r1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
Quelqu'un peut-il m'aider à ce sujet ?

Merci d'avance.

Han0uk
16/07/2008, 01h38
Toujours pas réussi à installer murmur/mumble.

Quelqu'un a-t-il un tuto ou un conseil pour que cela puisse marcher ? Merchi =).

The Destroyeur
12/07/2008, 09h21
Hello,

J'ai eu le même problème mais je sais plus comment je l'ai fixé, je vais regardé et je te dis quoi.

Sinon tu prend la version static de mumble, mais bon, tu ne sauras presque rien faire.

Han0uk
12/07/2008, 09h15
Destro, c'est la même chose en ayant réinstallé ce que tu m'as demandé en faisant emerge. C'est toujours des erreurs et je ne sais pas d'où cela peut venir, y a-t-il une autre méthode pour installer le mumble ? merci !

Out
10/07/2008, 17h31
ok je te remercie

The Destroyeur
10/07/2008, 16h11
Non c'est juste l'architecture qui est différente.

Out
10/07/2008, 16h05
Ok, merci destroyeur, je vais regarder où j'ai pu faire une erreur.

A ce propos lors de l'installation j'avais un souci, je trouvais pas "gcc-config x86_64-pc-linux-gnu-4.1.2"

par contre j'avais :

"gcc-config i686-pc-linux-gnu-4.1.2"

donc j'ai tapé "gcc-config i686-pc-linux-gnu-4.1.2"

Le problème pourrait venir de là?

The Destroyeur
10/07/2008, 15h53
Hello,

HanOuk, réinstalle dbus, puis qt4 et ressaye.

Out, ton murmur doit être mal compilé !

Out
10/07/2008, 14h38
Bonjour, j'ai réussi l'installation sur mon serveur, mais j'ai un message d'erreur lorsque je veux créer le mot de passe du superuser

> ./murmur -supw
/bin/bash: -c: line 0: syntax error near unexpected token `newline'
/bin/bash: -c: line 0: `./murmur -supw '
Quelqu'un aurait-il rencontré ce problème ou aurait juste une idée ?

Par avance merci

Han0uk
10/07/2008, 14h05
Bonjour à tous,

J'ai suivi le tuto pour une version Gentoo 64 bit. J'installe Mumur et tout ce passe bien jusqu'au qmake main.pro CONFIG+=no-client. C'est au make que tout foire puisqu'il me met :

Code:
cd src/murmur/ && make -f Makefile
make[1]: entrant dans le répertoire « /home/install/mumble-1.1.4/src/murmur »
make -f Makefile.Release
make[2]: entrant dans le répertoire « /home/install/mumble-1.1.4/src/murmur »
g++ -pipe -Wshadow -Woverloaded-virtual -Wold-style-cast -Wconversion -Wsign-compare -fvisibility=hidden -O2 -pipe -march=k8 -Wall -W -D_REENTRANT -DRESTRICT=__restrict__ -DQT_NO_DEBUG -DQT_SQL_LIB -DQT_XML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtSql -I/usr/include/qt4/QtSql -I/usr/include/qt4 -I/usr/include/qt4/QtDBus -I../../src -Irelease -I. -x c++-header -c murmur_pch.h -o release/murmurd.gch/c++
murmur_pch.h:12:25: erreur: QtDBus/QtDBus : Aucun fichier ou répertoire de ce type
make[2]: *** [release/murmurd.gch/c++] Erreur 1
make[2]: quittant le répertoire « /home/install/mumble-1.1.4/src/murmur »
make[1]: *** [release] Erreur 2
make[1]: quittant le répertoire « /home/install/mumble-1.1.4/src/murmur »
make: *** [sub-src-murmur-make_default-ordered] Erreur 2
Quelqu'un aurait-il une idée ? Je suis assez nul sous Linux c'est pour ça que je vous demande votre petite aide xD.

Merci à vous !

lorking
10/07/2008, 08h55
ok mais il a pas une web panel comme ts car c'est un peux galaire

jais vue une panel mais pour deb mais moi je suis chez gentoo

The Destroyeur
08/07/2008, 16h10
Hello,

Va voir la => http://mumble.sourceforge.net/Running_Murmur

lorking
08/07/2008, 09h26
moi je test et c'est tré long mdr

je vous dit ce que sa donne a pré avoir fini !

jais suivi le tuto tous et ok mais coment on le demare lol

je fait cd
/home/install/mumble-1.1.4/release

et ./murmurd

sa marche mais je arive pas a etre admin lol

cd /home/install/mumble-1.1.4/scripts
je edite le fichier
murmur.ini

je modif les linge

#
registerName=xxxxx
registerPassword=xxxx
registerUrl=www.xxxxxxx
registerHostname=xxxxx

mais sa marche pas

tigris
04/07/2008, 10h48
Bonjour,
j'aimerais avoir votre avis....

Est ce qu'on peut installer Murmur sur une distrib Ubuntu Linux ?

Et pour compliquer la tache j'aimerais faire ca sur une machine virtuelle...

suis-je trop ambitieux ?

merci de votre aide

The Destroyeur
29/06/2008, 21h52
Citation Envoyé par The Destroyeur
Tape

echo "=media-sound/murmur-0.9.4-r1 ~x86" >> /etc/portage/packages.keywords
Et sa marchera ^^
echo "=media-sound/murmur-0.9.4-r1 ~x86" >> /etc/portage/package.keywords
J'ai ajouté un "s" désolé :s

Phénol
29/06/2008, 17h13
Même problème après le echo...

# emerge murmur
Calculating dependencies \
!!! All ebuilds that could satisfy "murmur" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/murmur-0.9.4 (masked by: ~x86 keyword)
- media-sound/murmur-0.9.4-r1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
Merci quand même, snif.

The Destroyeur
29/06/2008, 13h09
Tape

echo "=media-sound/murmur-0.9.4-r1 ~x86" >> /etc/portage/packages.keywords
Et sa marchera ^^

Phénol
28/06/2008, 15h31
Une idée pour mon problème ?...

Phénol
28/06/2008, 08h45
Déjà merci pour cet excellent Tuto !
La première partie se passe bien jusqu'au moment d'installer Murmur :

~ # emerge murmur
Calculating dependencies \
!!! All ebuilds that could satisfy "murmur" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-sound/murmur-0.9.4 (masked by: ~x86 keyword)
- media-sound/murmur-0.9.4-r1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
Que faire ?

Merci par avance !

P.S. : j'arrive à me débrouiller sous Débian, j'ai quelques notions du monde Linuxien, mais Gentoo est tout nouveau pour moi, snif...

The Destroyeur
23/06/2008, 18h01
Tape emerge portage à la place

L4PiNoU
23/06/2008, 17h54
Petit problème pour moi quand je lance > emerge -u portage

Calculating dependencies .... done!

!!! Error: the !!! the two packages cannot be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handboo...full=1#blocked

Et don apres ben il me manque une ligne

gcc-config -l
[1] i686-pc-linux-gnu-3.4.6 *
[2] i686-pc-linux-gnu-3.4.6-hardened
[3] i686-pc-linux-gnu-3.4.6-hardenednopie
[4] i686-pc-linux-gnu-3.4.6-hardenednopiessp
[5] i686-pc-linux-gnu-3.4.6-hardenednossp

ET j'"ai pas la solution et ca commence a me chauffer

Merci de votre aide

chokapik
01/06/2008, 11h58
Toujours personne?

[HS] Destro, je suis content de voir Lordzz de retour ^^[HS]

chokapik
26/05/2008, 16h42
Salut je l'ai un peu lu mais je ne comprends pas trop bien l'anglais, est ce que l'un d'autre vous a déjà installé ce fameux panel?

Merci

Peloo
26/05/2008, 12h25
tu trouvera plus info sur leur wiki concernant muble ainsi que pour le web panel

http://mumble.sourceforge.net/

chokapik
25/05/2008, 22h53
Et en ce qui concerne l'administration web, y en a t il une?

J'arrive pas a ajouter des utilisateurs, quand je fais ajouter, il n'y a rien qui s'ajoute...

Merci

chokapik
24/05/2008, 17h22
ah ok je vais essayer, merci

papykun
22/05/2008, 23h56
bah c'est sur une debian 32bits que je l'ai fais.

chokapik
22/05/2008, 23h28
Salut, comment faisons nous quand c'est une architecture 32 bit?

Merci bcp

papykun
19/05/2008, 19h20
cd /home

wget http://downloads.sourceforge.net/mumble … g_mirror=0

tar xjf murmur-static_x86-1.1.3.tar.bz2

mv murmur-static_x86-1.1.3 murmur

cd /home/murmur

chmod -cvR a+x murmur.x86

./murmur.x86

test ça ^^

The Destroyeur
19/05/2008, 16h58
Sous debian, moi il me met un tas d'erreur.

debianrlp:/home/install# dpkg -i mumble-server_1.1.4-0ubuntu1_i386.deb
Sélection du paquet mumble-server précédemment désélectionné.
(Lecture de la base de données... 41532 fichiers et répertoires déjà installés.)
Dépaquetage de mumble-server (à partir de mumble-server_1.1.4-0ubuntu1_i386.deb) ...
dpkg : des problèmes de dépendances empêchent la configuration de mumble-server :
mumble-server dépend de libc6 (>= 2.4) ; cependant :
La version de libc6 sur le système est 2.3.6.ds1-13etch5.
mumble-server dépend de libqt4-core (>= 4.3.4) ; cependant :
La version de libqt4-core sur le système est 4.2.1-2+etch1.
mumble-server dépend de libqt4-sql (>= 4.3.4) ; cependant :
La version de libqt4-sql sur le système est 4.2.1-2+etch1.
mumble-server dépend de libssl0.9.8 (>= 0.9.8f-1) ; cependant :
La version de libssl0.9.8 sur le système est 0.9.8c-4etch3.
dpkg : erreur de traitement de mumble-server (--install) :
problèmes de dépendances - laissé non configuré
Des erreurs ont été rencontrées pendant l'exécution :
mumble-server
Alors que quand je fait
debianrlp:/home/install# apt-get -f install libc6
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
libc6 est déjà la plus récente version disponible.
Et c'est la meme chose pour le reste ...

Je m'y perd franchement :s

papykun
19/05/2008, 00h01
Apparement tu peux ajouter des user en plus, autre que le "root". parceque j avoue j ai pas compris comment gérer les droits... L install sous une debian se fait facilement...

Djerfy
18/05/2008, 21h47
Bonjour.

Pour le tuto que tu viens de créer. Le serveur murmur tourne sur une architecture de Linux Gentoo en x64 ? Car sur l'arch 32 bits, il ne tourne pas !

Il y a une solution sur ce probleme ?

Peloo
18/05/2008, 12h07
Tu dois mettre un SuperUser password avant de le demarré de cette façon

./murmur -supw

ensuite pour lancer le serveur

./murmur

jmp59
15/05/2008, 20h46
Trés bien expliquer mais comment on fais pour le lencer maintenent?

The Destroyeur
11/05/2008, 12h59
Hellow,

Voici un petit tutoriel pour installer Murmur (Mumble server).

Je tourne sous Gentoo, donc ce tuto s'addresse au personne utilisant Gentoo (R2).

Tout d'abord, lancer "emerge --sync" puis "emerge -u portage".

Ensuite, il faut installé "SQlite", donc "emerge sqlite". Après, vous devez mettre le dernier compiler (gcc), donc "emerge gcc".

Après, vous tappez ceci "gcc-config -l"

Vous devriez avoir ceci:
[1] x86_64-pc-linux-gnu-3.4.5 *
[2] x86_64-pc-linux-gnu-3.4.5-hardened
[3] x86_64-pc-linux-gnu-3.4.5-hardenednopie
[4] x86_64-pc-linux-gnu-3.4.5-hardenednopiessp
[5] x86_64-pc-linux-gnu-3.4.5-hardenednossp
[6] x86_64-pc-linux-gnu-4.1.2
Vous devez mettre le dernier compileur, donc vous tapez ceci: "gcc-config x86_64-pc-linux-gnu-4.1.2"

Maintenant, vous devez installer "QT". Mais en avant, vous devez spécifiez que QT devra utilisé SQlite, pour cela vous devez entrer cette commande:

echo "x11-libs/qt sqlite3 -sqlite" >> /etc/portage/package.use
Ensuite, "emerge qt".

Enfin, tapez "emerge murmur", il va installer une vielle version, OK, mais il va installé tous les plugins nécéssaire à la compilation du dernier serveur Murmur.

Quand, murmur est installé, taper "emerge -C murmur".

Maintenant, on va installé la dernière version de murmur.

mkdir /home/install
cd /home/install
wget http://surfnet.dl.sourceforge.net/so...e-1.1.4.tar.gz
gunzip mumble-1.1.4.tar.gz
tar -xf mumble-1.1.4.tar
rm -f mumble-1.1.4.tar
cd mumble-1.1.4
qmake main.pro CONFIG+=no-client
make
Le fichier serveur sera mis automatiquement dans le dossier "releases", mais les scripts se trouvent dans le dossier "script".

Voila

Résumé:

emerge --sync
emerge portage
emerge sqlite
emerge gcc
gcc-config x86_64-pc-linux-gnu-4.1.2
echo "x11-libs/qt sqlite3 -sqlite" >> /etc/portage/package.use
emerge qt
emerge murmur
emerge -C murmur
mkdir /home/install
cd /home/install
wget http://surfnet.dl.sourceforge.net/so...e-1.1.4.tar.gz
gunzip mumble-1.1.4.tar.gz
tar -xf mumble-1.1.4.tar
rm -f mumble-1.1.4.tar
cd mumble-1.1.4
qmake main.pro CONFIG+=no-client
make