OVH Community, votre nouvel espace communautaire.

Désactiver session.bug_compat_42 avec un .htaccess ?


pierrotdu78
21/04/2008, 10h17
Bonjour à tous,

j'ai un petit souci avec un mutualisé :

lors de la connexion d'un membre, j'instancie des variables sessions, mais certaines restent vides.
Et lorsqu'il passe sur une page qui demande un de ces variables vides, il a ce message d'erreur :

message = Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively.

A la racine du serveur, j'ai mis un .htaccess contenant :
SetEnv REGISTER_GLOBALS 0
SetEnv SESSION_USE_TRANS_SID 0
SetEnv SESSION_BUG_COMPAT_42 0


mais ca ne marche toujours pas....y'a toujours le warnig qui fait bugger ma page...

Quelqu'un aurait-il une petite idée ?

Merci