OVH Community, votre nouvel espace communautaire.

Mettre un sondage sur Demo 1G


tartifume
11/12/2007, 18h15
Merci quand même pour tout et de ton aide, je viens à l'instant de réussir à tout configurer, il ne me reste plus qu'à créer le questionnaire (le plus facile quoi!! sourire)

En fait ce qu'il fallait faire c'est donc enregistrer limesurvey sur le serveur ftp fourni par ovh, ensuite entrer les bases sql dans phpmyadmin et ensuite juste changer 2-3 trucs dans config.php.

C'est vraiment une explication rapide et grossie mais c'est ok, ça devrait marcher. En fait c'est vrai que c'était relativement assez simple, mais je me suis quand même arrachée quelques cheveux avec le php, heureusement j'ai une bonne épaisseur de capillaires!!

Merci encore!!

rianame
11/12/2007, 17h01
Tu peux aussi te servir de ton propre ordi comme serveur...Mais ça implique de le laisser tourner 24h/24, et puis t'auras peut-être pas l'URL que tu veux du coup.

Moi ce que je te conseille, c'est de exporter ton questionnaire vers un emplacement de ton disque (y'a une fonctionnalité pour ça dans LimeSurvey), d'installer correctement LimeSurvey sur le serveur ftp d'OVH, et ensuite d'importer dans cet administration là ton questionnaire sauvegardé.

Je peux pas t'aider plus, moi même je me fais un peu des noeuds au cerveau avec ces histoires de serveur, de config, etc... donc depuis que ça marche, je ne me pose plus trop de questions...

tartifume
11/12/2007, 15h56
Oui en fait je l'ai trouvé, tout est un peu complexe alors du coup j'avais loupé le choix déroulant qui m'indiquait quelles sortes de question je souhaitais mettre en application et qu'il fallait également créer des étiquettes pour le choix des réponses.

En fait mainenant je recommence de 0, je patauge quand même pas mal parce que dans ma tête je pensais qu'il fallait que j'installe un serveur sur mon ordi comme wamp par exemple, mais apparemment il ne faut pas, je ne sais plus trop où j'en suis, j'ai tout installé, configuré, ça marche sur un serveur local, mais maintenant pour rendre tout accessible, ça ne marche pas. Je pense que je n'en suis pas loin, mais je ne comprends pas la suite. J'essaie de suivre le tuto de limesurvey mais il y a des choses confuses pour moi, bon bref c'est un peu la misère et toute aide charitable sera la bienvenue, sinon et bien je reviendrais vous donner des nouvelles quand tout sera fini!!

rianame
11/12/2007, 13h39
Quand tu crées ta question, tu as un champ pour choisir le type de question. Il suffit de sélectionner "case à cocher". Tu as tout indiqué dans la doc version française en principe...

tartifume
11/12/2007, 11h11
edit: en fait je viens de voir pourquoi je n'ai pas reçu de mail, mon adresse mail que j'ai rentré est erronnée, donc je vais pouvoir modifier cela! Par contre pour la réponse au questionnaire à choix multiple...???

tartifume
11/12/2007, 11h08
Merci Rianame de ta réponse, j'avais bien compris ça comme ça alors.

Oui en fait c'est ça le probléme, c'est que je n'ai pas reçu de mail de la part d' OVH alors que je reçois bien les notifications du forum donc il doit y avoir erreur de leur part, je vais les contacter.

Sinon quand je voulais dire que j'ai réussi à "configurer" limesurvey je voulais dire que j'ai bien changer les données dans config.php et que je peux accéder à l'interface de limesurvey en passant par l'adresse de mon serveur, soit en local, et donc je peux commencer à créer mon questionnaire, mais je n'ai pas fini de "tout" configurer puisqu'il n'est pas encore accessible par mon nom de domaine.

edit: juste une petite question en rapport avec limesurvey, sais-tu où je dois changer les paramètres pour avoir un questionnaire à réponse multiple, parce que pour l'instant je n'ai qu'un questionnaire "ouvert" avec simplement possibilité de répondre par écrit et moi je voudrais des réponses à cocher. J'ai peut-être loupé quelque chose par là! Merci!

rianame
08/12/2007, 11h24
Moi j'avais reçu un mail après la confirmation par téléphone, me donnant l'adresse du serveur Ftp et le login nécessaires pour y accéder.
Et c'est dans le dossier www du serveur ftp que j'ai installé LimeSurvey.
Je trouve super bizarre que tu es configuré LimeSurvey avant, parce que dans la doc ils expliquent qu'il faut le faire sur le serveur, donc je sais pas trop comment tu as fait et ce que tu entends par "configurer LimeSurvey".

Perso, je suis aussi très nulle en Php, et j'y suis arrivée sans souci...

tartifume
07/12/2007, 13h16
Bonjour rianame et les autres,

Je suis dans la même problématique que toi.

J'ai pris un hébergement Demo 1G pour également y mettre un questionnaire avec limesurvey et je galère sérieusement. (Je précise que je n'ai aucune notion en php alors vous serez gentils d'être indulgents à mon égar!! )

Je pense avoir bien configuré limesurvey, par contre j'ai demandé l'hébergement aujourd'hui, j'ai bien répondu au coup de téléphone pour m'identifier afin de profiter de la démo, mais je n'arrive pas à accéder à mon site.

Ma question est donc de savoir s'il faut attendre un certain temps avant de pouvoir y accéder ou pas, parce que si je comprends bien, pour limesurvey, il faut que j'aille sur mon adresse de site pour finir de le configurer et je n'ai pas reçu de mail de la part d'OVH pour me confirmer que je pouvais bien accéder à mon site.

Merci de m'éclairer un peu plus!!

rianame
20/11/2007, 07h33
Après plusieurs bidouilles hier, j'ai fini par arriver à exécuter le script.

Ma première erreur, c'est d'avoir placé les fichiers que je voulais exécuter dans un dossier du ftp autre que "www". En les déplaçant dans ce dossier, le script s'est exécuté.

Ensuite j'avais du faire quelques mauvaises manips dans le fichier de config, mais je les ai résolues (comment ? Ca c'est un mystère, mais bon à la rigueur, seul le résultat m'intéresse ! )

Je suis en train de créer mon questionnaire, donc pour l'instant sur mon "site", il n'y a rien : http://sondage-carto.ovh.org

Là où je vais sûrement galérer, c'est pour que le questionnaire aille se metre à cette adresse pile ensuite. mais bon, je suis sûre que je trouverais une autre âme charitable pour me dépanner...

Merci !

Shadow aok
19/11/2007, 22h40
Donne-nous l'url d'e ton site que l'on teste.

rianame
19/11/2007, 15h06
Oups, le sujet est parti deux fois... C'est possible de l'effacer seul ?

rianame
19/11/2007, 15h03
Bonjour,

J'ai fait une demande d'hébergement démo 1G, pour mettre en ligne un questionnaire pendant 15 jours.

Pour créer le questionnaire, je veux utiliser LimeSurvey (anciennement Php Surveyor) que je connais déjà.

Par contre, je suis en train de galérer à installer LimeSurvey, parce qu'entre serveur ftp, serveur mysql, serveur web, et autres, je m'emmêle les pinceaux complet !

Bref, si quelqu'un avait un élément de réponse à mon problème ci-dessous, ce serait génial !

En suivant les explications du manuel de LimeSurvey (http://docs.limesurvey.org/tiki-inde...n+en+Francais), j'ai édité un fichier (config.php), que j'ai rempli avec les informations qui me semblaient bonnes.

A l'instruction "En utilisant votre client FTP favori, connectez-vous à votre serveur web et créez un dossier pour y stocker les fichiers de LimeSurvey. Envoyez dans ce dossier l'ensemble des fichiers de LimeSurvey en respectant la structure des dossiers.", j'ai copié tout mes fichiers d'install sur ftp://ftp.demo1g.ovh.org/limesurvey/
Déjà là je sais pas si j'ai bon... Votre avis ?

Supposons que ce soit ok. Ensuite on me dit "Un script est fourni avec LimeSurvey pour installer ce programme. Rendez-vous à l'adresse "http://your.domain.com/limesurvey/admin/install/index.php". Si vous avez tout configuré correctement, le script va vous demander de créer la base de données et/ou les différentes tables nécessaires. Laissez faire..."

Alors là ma question c'est : qu'est-ce que je fais ?
Quand je suis dnas le bon dossier, et que je clique sur le fichier index.php, il se télécharge pour s'éditer. Si je tape la commande dans le navigateur, il ne trouve rien.
En gros, je n'ai aucune idée de comment faire éxécuter ce script PhP...

Merci à ceux qui auront pris la peine de me lire, et un gros bisou à ceux qui sauront m'aider !