OVH Community, votre nouvel espace communautaire.

Probleme pour interroger base Mysql


serval_xp
11/02/2004, 22h51
Bonjour,

j'ai 2 serveurs dédié, sur le serveur pris il y a 1 mois j'ai voulu installer un site qui interogait une base de donné mysql, toutes à l'air de fonctionner pour que le site se connecte à la base. mais on dirait qu'il ne lit pas les donnés de la base alors quel si trouve.

Quand je test la connexion avec le fichier connexion.php :

//*********** fonction connexion qui permet de se connecter à une base de données

function connexion($base='immo1500', $serveur='localhost', $login='immo1500', $pass='motdepasse')

{
$id = @mysql_connect($serveur, $login, $pass);
if ($id==false)
{
echo "
erreur ...
";
exit;
}
@mysql_select_db('immo1500', $id) or die('
Erreur 2...');
}
?>


Aucune erreur trouvé mais si je rentre le mot de passe et le login pour entrer dans la partie admin de mon site, il me dit que le login et mot de passe sont incorecte. comme si la base été vide.

Et si je mets le meme site sur mon autre serveur aucun problème. J'ai meme essayé avec un site qui fonctionnait tres bien sur mon ancien serveur et le problème est le même.

J'ai bien regardé dans mysql et les informations si trouve bien.

Quel différence peut il y avoir avoir l'autre serveur ???

J'ai vu qu'il ya un user de plus dans mysql "pma" je suppose que c'est pour "phpmyadmin" qui est centralisé ?

Faut il que je mette autre chose à la place de localhost pour le serveur ???

Merci de votre aide