OVH Community, votre nouvel espace communautaire.

Problème compil php-4.3.4 suite maj MySQL4


pascal
15/08/2004, 15h39
Mon dedier est a la 1.50, j'ai repasser le patch 1.49 -> 1.50 qui recomplie apache et php, aucun pb ...

ftp://ftp.ovh.net/made-in-ovh/releas...h-1.49-1.50.sh

regarde les options de compilation

Pharmespace
21/06/2004, 18h02
Salut,

J'ai suivi le thread531 pour la migration vers MySQL 4.0.20.
Mais c'est en voulant faire bien (!) à la recompil de PHP que j'ai un problème.

Le ./configure fonctionne (à part un warning sur le module db), mais le make me retourne :

In file included from /home/ovh/src/apache_1.3.29/src/include/ap_config.h:77, from /home/ovh/src/apache_1.3.29/src/include/httpd.h:72,
from /home/ovh/src/php-4.3.4/sapi/apache/php_apache_http.h:22,
from /home/ovh/src/php-4.3.4/sapi/apache/sapi_apache.c:24:
/home/ovh/src/apache_1.3.29/src/include/ap_config_auto.h:6:1: unterminated #ifndef
make: *** [sapi/apache/sapi_apache.lo] Erreur 1

Idem pour make install et puis tout le reste (apache etc) me renvoie le même genre de message.

Qui a une idée, je suis noyé là...

Merci.