OVH Community, votre nouvel espace communautaire.

Glibc 2.3.2 - Maj


tamok
31/01/2005, 20h28
Ou encore :

Code:
cd /home/src/soft
wget http://ftp.gnome.org/pub/GNOME/sourc...-2.5.11.tar.gz
cd ..
tar xzf soft/libxml2-2.5.11.tar.gz
cd libxml2-2.5.11
./configure
make && make install

tamok
31/01/2005, 20h14
La solution que j'ai trouvée pour installer PHP5 est de recompiler le src.rpm de libxml2 par un

Code:
rpm --rebuild libxml2-2.5.4-1.src.rpm
ensuite

Code:
cd /usr/src/redhat/RPMS/i386/
et

Code:
rpm -Uvh libxml2-*
Ca marche pour moi, j'espère que ça pourra aider certains

tamok
31/01/2005, 15h46
Salut,

Pour ma part g 3 dédiés sur ovh, et 4 autres ailleurs. Je sais que j'y suis arrivé par le passé, donc je vais essayer de retrouver comment

Par contre pourquoi OVH s'obstine-t'il avec un redhat 7.2 si austère ? Mes prochains dédiés seront surement sous fedora ou une "bête" mandrake 10.1 community

Ernest
31/01/2005, 09h14
Encore un petit bump,

Personne n'a une idée ou pour installer 2 glibc en 'parallèle' ?

Merci

Ernest
20/01/2005, 11h52
Petit bump, je souhaiterais également mettre à jour glic

xion
23/05/2004, 12h14
bas, j'espère que vous pouvez m'aider, car j'en ai besoin pour le connecteur JK 2 apache-tomcat, alors, svp, répondez-moi... (que fait ovh ? il y a bien une solution ?)

xion
20/05/2004, 18h18
Voilà, j'ai envie d'utiliser le XSLT et ce qui va avec, avec PHP 4 / 5, cependant,

->il me faut la version 2 de libxml... et là, j'essaie d'installer... et hop, il me faut la version 2.3.2 de GLIBC et GCC que je mets à jour (assez long)

-> alors je m'attaque à ce dernier(GLIBC 2.3.2), et ça me donne des erreurs, à cause de variables... (lors de "make" sur les fichiers créés par
../configure --prefix=/usr --disable-profile --enable-add-ons --libexecdir=/usr/bin --with-headers=/usr/include
)
(dans un dossier externe à celui de GLIBC bien sûr )

-->les erreurs donnés :
sscanf.c:31: erreur: types conflictuels pour « sscanf »
sscanf.c:31: erreur: types conflictuels pour « sscanf »
sscanf.c:48: erreur: types conflictuels pour « _IO_sscanf »
../libio/iolibio.h:42: erreur: déclaration précédente de « _IO_sscanf » était ici
sscanf.c:48: erreur: types conflictuels pour « _IO_sscanf »
../libio/iolibio.h:42: erreur: déclaration précédente de « _IO_sscanf » était ici
sscanf.c: In function `sscanf':
sscanf.c:37: erreur: « va_start » utilisé dans une fonction ayant des arguments fixes
make[2]: *** [/home/ovh/src/glibc-build/stdio-common/sscanf.o] Erreur 1
make[2]: Quitte le répertoire `/home/ovh/src/glibc-2.3.2/stdio-common'
make[1]: *** [stdio-common/subdir_lib] Erreur 2
make[1]: Quitte le répertoire `/home/ovh/src/glibc-2.3.2'
make: *** [all] Erreur 2
j'ai donc décidé avant de vous poser la question, d'installer à partir d'un RPM, et hop, je l'ai trouvé ce RPM, mais ça bloque aussi, et c'est presque pire...

error: failed dependencies:
glibc-common = 2.3.2-11.9 is needed by glibc-2.3.2-11.9
glibc > 2.2.4 conflicts with glibc-common-2.2.4-31
glibc = 2.2.4 is needed by glibc-devel-2.2.4-31
et ces trois RPMs ne peuvent être supprimés, ils ont eux aussi des tas de dépendances avec le serveur... donc je vois pas quoi faire..

pitié, aidez-moi ...