OVH Community, votre nouvel espace communautaire.

[Serveur dédié ] Release pour mettre à jour sa version de PHP ?


xion
10/05/2004, 18h31
si tu n'as pas envie de compiler tout manuellement, tu as un truc assez simple :
-tu prends le patch pour apache 1.3.29/ php 4.3.4 / ssh
-tu vas dans les sources du .sh et tu modifie le nom du paquetage pour PHP, par celui que tu veux utiliser (et qu'il faudra avoir téléchargé auparavant, bien sûr...) comme ça, ça fait tout comme le patch, mais ça met LA version PHP à jour...

tu peux modifier le patch comme tu veux... tant que ça marche...

cub
10/05/2004, 10h43
lol... effectivement c'etait un copier/coller.

Ok warix merci beaucoup de ton aide je vais essayer à nouveau.

Warix
10/05/2004, 02h50
Code:
Bonjour !

Je me suis lancé j'ais d'abord voulus lance un patch all avec les release

je me suis connecté en root et j'ais tapé ca :

ftp://ftp.ovh.net/made-in-ovh/release/patch-all.sh[4] -O patch-all.sh; sh patch-all.sh

ca m'a répondus ca :
Je suis sur à 100% que tu as fait un copier-coller de l'adresse qui est dans le guide !

Pourquoi ? Parce que quand on fait sa, il y a une glitche qui s'ajoute dans l'url, ce qui fait que l'adresse n'est pas bonne. Regarde après «patch-all.sh» tu as un {4} (remplace les acolades par des crochets ).

La bonne commande :

ftp://ftp.ovh.net/made-in-ovh/release/patch-all.sh -O patch-all.sh; sh patch-all.sh

cub
09/05/2004, 23h27
Bonjour !

Je me suis lancé j'ais d'abord voulus lance un patch all avec les release

je me suis connecté en root et j'ais tapé ca :

ftp://ftp.ovh.net/made-in-ovh/release/patch-all.sh[4] -O patch-all.sh; sh patch-all.sh

ca m'a répondus ca :

--00:18:35-- ftp://ftp.ovh.net/made-in-ovh/releas...-all.sh%5B4%5D
=> `patch-all.sh'
Connexion vers ftp.ovh.net:21...Connecté!
Session débutant sous anonymous...Session établie!
==> SYST ... complété. ==> PWD ... complété.
==> TYPE I ... complété. ==> CWD /made-in-ovh/release ... complété.
==> PORT ... complété. ==> LIST ... complété.

0K ...... @ 1.18 MB/s

00:18:35 (1.18 MB/s) - `patch-all.sh' sauvegardé [6170]

`.listing' détruit.
Pas de pairage sur le patron `patch-all.sh[4]'.



bon.... ca veut dire quoi ca pas de pairage etc ? j'ais pourtant fait exactement comme dans le guide ovh :\
en plus c'est un superplan d'y a 2 mois alors.... :\

Pourquoi ca fonctionne pas ?

Warix
09/05/2004, 22h11
Un bon truc

1. Download les patchs des releases d'ovh
2. Fouille, depuis les releases les plus récentes, pour trouver une release qui met à jour php
3. Refait, à la main, les mêmes opérations avec les mêmes options (ou d'autres si tu veux) mais pour la version 4.3.6 de php.
4. Enjoy !

FLCT
09/05/2004, 20h37
bonjour,
je t'ai deja répondu. il n'y as vraiment rien de sorcier tu as juste à suivre le manuel php et apache pour compiler et installer

cub
09/05/2004, 12h31
Tout d'abord bonjour !

J'aimerais savoir si un jour ce sera possible de mettre à jour php avec les release ?

Je suis débutant en admin server et j'ais besoin de passer de php 4.3.4 à 4.3.6.
Apparement il n'y a pas de release pour faire ca simplement ca fait bientôt 2 semaines que je suis bloqué à cause de ca :\

Bon week end.