OVH Community, votre nouvel espace communautaire.

Mise à jour PHP


FLCT
29/04/2004, 11h40
bonjour,

je voudrais juste savoir si je fait :

wget ftp://ftp.ovh.net/made-in-ovh/release/patch-all.sh[4] -O patch-all.sh; sh patch-all.sh
sur le superplan est ce que ca va me mettre à jour la version de PHP tout seul comme un grand ?
non il va essayer d'appliquer les patch qui ont été forunis mais ca ne te mettra pas php 2.4.6.

tu peux changer ta version php mais tu ne sera pas en release. ca ne veut pas dire que tu ne pourras pas appliquer les patchs. il faudra juste que tu ailles voir ce qu'ils font avant de les executer et au besoin les adapter à ton systeme

exemple, je n'ai pas garder ncftpd comme serveur ftp mais ca ne m'empeche pas d'appliquer les patch.^

si tu veux changer ta version de php tu:

- sauvegarde les repertoires des sources apache et php
- sauvegarde le (ou les) binaires d' apache
- telecharge les sources ton php
- compile ton php, apache
- installe les nouveaux binaires
- au pire comme tu as sauvegardé les anciens en cas de probleme tu peux retomber sur tes pattes.

++

cub
29/04/2004, 11h29
personne saurais me répondre ?

cub
28/04/2004, 14h44
Je suis sous PHP 4.3.4

J'ais besoin de passé a PHP 4.3.6

( une fonction ne fonctionne pas sous 4.3.4 , c'est un besoin pas un coup de tête comme ca )

J'ais pris récemment un nouveau superplan ( 1 mois et demi ) il possede donc le systeme de release.

Vu que je n'y connais rien , mais alors RIEN en release , je voudrais juste savoir si je fait :

wget ftp://ftp.ovh.net/made-in-ovh/release/patch-all.sh[4] -O patch-all.sh; sh patch-all.sh

( http://guide.ovh.com/ReleasePatchSecurite/ )

sur le superplan est ce que ca va me mettre à jour la version de PHP tout seul comme un grand ?


Ce message vous parait peut etre ridicule mais j'aimerais juste une confirmation j'ais "peur" de mettre le superplan down et de voir tout les site 404 ca serais térrible :-O

Merci d'avance si quelqu'un s'y connais dans le coin ca serais sympa de répondre.