OVH Community, votre nouvel espace communautaire.

[Mise à jour de clamav par gentoo] L'erreur


Emprint
06/02/2009, 16h39
Super, j'ai galeré toute la journée à cause de ça :P
Merci.

pmadfm
08/01/2008, 22h51
Merci bien,

toutefois dans l'aide je ne vois pas d'aide.

Peut être cela veut il dire que je n'ai pas de fichier etc/make profile

Et effectivement il y a un lien mais en rouge clignotant :

-rw-r--r-- 1 root root 458 jun 14 2006 /etc/make.conf
-rw-r--r-- 1 root root 16174 mai 30 2006 /etc/make.conf.example
-rw-r--r-- 1 root root 2278 mai 30 2006 /etc/make.globals
lrwxrwxrwx 1 root root 48 nov 26 05:55 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2006.0

Je suppose que c'est une caguette de la part l"installation R2.

9à y est cela fontionne, en fait ma version pointait vers un répertoire inexistant, il y a 2006.1 ou 2007.0 j'ai pris le 2007.0, je suppose qu'en novembre quand j'ai réinstallé le serveur il n'avaient pas correctement bouclé le script R2.

Problème résolu.

Merci de votre aide.

ztip
07/01/2008, 21h30
la réponse est ici:
http://cefoututruc.net/index.php?men...icle&art_id=13
merci Angie

pmadfm
07/01/2008, 12h40
Bonjour,

Je suis sous release 2.

Lorsque je lance emerge clamav je récupère :
!!! ARCH is not set... Are you missing the /etc/make.profile symlink?
!!! Is the symlink correct? Is your portage tree complete?

Alors j'ai téléchargé la dernière version 0.92
- ./configure
- make
- make install

- /etc/ini.d/spamd restart
- /etc/ini.d/clamd restart

Et rien n'y fait, il m'annonce toujours que je suis en version 0.88.

Auriez-vous une information pour m'aider ?

Par ava,ce merci.

McPeter
11/06/2007, 01h22
ben idem ^^
0.88.2 -> 0.90 hihihi

The Destroyeur
10/06/2007, 16h41
Oui mais moi c'est pour quand on fait une mise à jour de clamav ^^

McPeter
10/06/2007, 16h39
cf : http://forum.ovh.com/showthread.php?t=14724

Mais c'est toujours bon de le rappeler

The Destroyeur
08/06/2007, 18h16
Bonjour à tous,

Voila, après des semaines de recherche, j'ai trouvé pourquoi Q-Mail-Scanner foirait !

Je vous explique tous ! (Gentoo uniquement)

Voici l'erreur :
Jun 7 01:30:26 www X-Qmail-Scanner-2.01st: [www.redline-prod.com118117262676720890] clamdscan: corrupt or unknown clamd scanner error or memory/resource/perms problem - exit status 512/2
Quand vous mettez à jour votre clamav par emerge clamav, il supprime le fichier de configuration d'origine. Celui-ci est configuré par ovh pour que tout fonctionne.

Donc, il vous suffit de modifié le fichier /etc/clamd.conf, et de changer
User clamav
par
User qscand
Après cela, vous relancez clamav. Si il met une erreur, (soit avec les logs, soit avec les runs) vous faites ceci:
chown qscand:qscand -R /var/log/clamav
chown qscand:qscand -R /var/run/clamav
Un petit de reload, et c'est bon !