OVH Community, votre nouvel espace communautaire.

Plus d'accès web sauf webmin


MarcP
26/04/2004, 15h55
Déja les failles grave si tu prends un minimum de précautions tu t'en proteges pas mal (filtrage des ip, etc)
Apres installer un autre système c'est faisable à distance.
j'ai pas dit facile, mais faisable oui
C'est linux, pas windows
Au pire tu fais héberger ton serveur chez eux, c'est faisable aussi

FLCT
26/04/2004, 14h40
et j'ajouterai que si tu avait jeter un oeil ce WE sur ton serveur tu aurais poster ce message et on t'aurais répondu.. en moins de 20 heures

FLCT
26/04/2004, 14h38
re,

je lavais donc dit ca va etre un thread chargé.

encore une fois je ne defends pas ovh mais je rejoins marcP sur plusieurs point. Administrateur systeme c'est un metier et tout le monde ne peut pas s'improviser administrateur.

ovh fait de la location de machine. elle fournit une machine, elle y installe un systeme en etat de marche ( ce qu'elle n'est pas obligée de faire), des modules d'administration( pas obligé non plus) des faq (idem). Aprés c'est un choix soit tu as les competences requises pour gerer un serveur et tu acceptes de prendre la charge de travail, soit tu embauche, soit tu fais appel à un pro de l'infogerance qui le fera pour toi !!

maintenant tu as le droit de te plaindre et tu as le droit de partir si le service ici ne te conviens pas aussi. va faire un tour chez d'autres tu compares le service ... et puis aprés le prix .... c'est un choix.

de plus, si on avait à te faire un point detaillé de tout ton systeme, les bogues, les trucs, les ... dans 1 semaines on y est encore et encore ca ca rentre dans le cadre d'un service d'infogerance.

en ce qui concerne l'offre, je pense qu'elle est largement acceptable. deux point que je regrette:
- ne pas pouvoir installer son propre systeme mais je comprends
- ne pas etre avertis sur le mail d'urgence quand une faille grave est detecter( style le noyau) mais bon aprés tout depends de ses sources d'infos...

à suivre .....

MarcP
26/04/2004, 13h53
Le gros problème est la : à cause des tarifs allechants d'ovh, beaucoup de personnes s'improvisent hébergeur, sans avoir la moindre idée de comment gérer un serveur.
En l'occurence ton probleme est arrivé parce que ton espace disque sur / est arrivé à 0%....

Alors au lieu de perdre du temps à critiquer les autres, va suivre 2-3 cours de formation, ou bien prends un hébergement mutualisé, et ne devie pas sur les autres problèmes.
Si t'en as marre des mrtg ou des stats, tu fais un topic la dessus.

D.L
26/04/2004, 13h41
ou la grosse colère

quand y'a besoin de gueuler, je suis pas le dernier pour du Mutu

pour du SD, c'est TON server, à toi de t'en occuper

si t'es pas content des services installés, tu le format, tu réinstal ton tit noyau linux, ton tit apache perso, et basta

entre webmin et ovhm, on est déjà bien aidé, mais si tu veux te la jouer "moi on me doit du service", va en Mutu

là le seul truc que te doit OVH et sur lequel tu pourrais à la rigueur gueuler c'est le server physique et la bande passante

le reste.... queud

atkati
26/04/2004, 13h34
J'ai déjà fait un script php externe au serveur qui monitor ça ce matin à la suite de cette désagréable surprise.

Impossible de mettre ça côté serveur puisque le serveur ne répond pas. Il ne pourra pas agir...

J'ai fait un script PHP qui essaye de charger la page d'accueil d'un des sites et qui me mail s'il n'arrive pas à la charger.

Et pour répondre à FLCT, OVH est bien gentil de fournir un serveur préinstallé, mais si c'est pour avoir des attaques qui te pourrissent le serveur à cause de trucs installés que t'as pas besoin, ça fout les boules. C'est pas la première fois.

S'ils avaient l'esprit de prévenir de tels problèmes en livrant le serveur, je ne me facherai pas.

Mais là, c'est vraiment trop.

Entre les services que tu paye qui ne marchent pas de suite et les défauts d'installation des serveurs, c'est naze.

Les MRTG, les sats... Autant ne pas en parler dans l'offre des serveurs. Ca s'appelle de la publicité mensongère ! ! ! Purement et simplement.

A bon entendeur !

D.L
26/04/2004, 12h00
Un message autre qu'un 400, 404, 403 ou autre serait un résultat positif à une indisponibilité !

rien ne t'empeche de créer un truc tout bete, un htacess qui redirige sur une page php quand u as ces erreurs, et la page php qui t'envoi un mail ou même un sms pour te dire "y'a un bleme 403 ou 500 ou etc"

comme ça tes visiteurs bossent pour toi, uand ils loadent une page et que ça foire, t'es prévenu automatiquement


edit :

------------------------
je suis admin débutant, j'ai jamais installé mod_gzip et je sais même pas à quoi il sert, mais je sens que je vais jamais l'installer vu les problemes , en tt cas pas avant d'être à l'aise avec ce que je fais
éviter de faire trop de modif à la fois sur un server quand on sait pas 100% ce qu'on fait, ça permet d'apprendre doucement sans problemes de ce genre aussi
------------------------

FLCT
26/04/2004, 11h44
bonjour,

ce genre de probleme est déjà arriver ici. c'est un bug connu de mod_gzip.
voir le post ici http://forums.ovh.net/showthread.php...=6618#post6618

va faire un tour du cote de tmp pour effacer les fichiers. tnt que tu y est tu peux passer partout dans le logs car tu dois avoir pas mal de chose à lire !!


Le service de monitoring n'a rien vu, il ne surveille pas ce genre de problème.

Si l'attaque avait eu lieu un vendredi soir, étant donné que je ne regarde pas mon serveur le week-end, la panne aurait donc duré près de 60 heures!!!!

Imaginez la catastrophe !

Pourquoi le service de monitoring ne peut pas surveiller des problèmes aussi basiques !
Un simple test d'accès à la page d'accueil du serveur ferait l'affaire.

Un message autre qu'un 400, 404, 403 ou autre serait un résultat positif à une indisponibilité !
Un simple test d'accès à la page d'accueil du serveur ferait l'affaire.

Un message autre qu'un 400, 404, 403 ou autre serait un résultat positif à une indisponibilité !
sans defendre ovh, ton serveur meme le we faut s'occuper de lui. de plus comment differencier une erreur apache du à un probleme comme celui la ou d'une erreur de code ?? je ne pense pas que le service de monitoring gere ce type de probleme. cependant la mise en place de quelques espions sur ton systeme ne prend pas plus de temps que ca ...

/edit/
poster en retard mais je sens que c'est un thread qui va faire couler de l'octet
//edit/

MarcP
26/04/2004, 11h37
Le systeme de monitoring PING ton serveur.
Si celui ci reponds au ping, le monitoring est OK.
Apres le monde ne te tourne pas autour : tu lis la doc, tu vois que ca ne concerne que le ping. Si ca te conviens pas, et si t'etais un admin serieux, tu aurais un vrai systeme de monitoring d'installé, nagios par exemple.
Et tu te serais inquiété de voir ton espace disque bouffé avant saturation...
Accessoirement tu regarderais aussi tes dédié le W-E, mais c'est un autre débat...

atkati
26/04/2004, 10h03
Je ne trouve toujours pas où ça me bouffe de la place...

Y'a quand même un truc qui me fout la rage, c'est que pendant 20 heures mon serveur a été innaccessible.

Le service de monitoring n'a rien vu, il ne surveille pas ce genre de problème.

Si l'attaque avait eu lieu un vendredi soir, étant donné que je ne regarde pas mon serveur le week-end, la panne aurait donc duré près de 60 heures!!!!

Imaginez la catastrophe !

Pourquoi le service de monitoring ne peut pas surveiller des problèmes aussi basiques !

Un simple test d'accès à la page d'accueil du serveur ferait l'affaire.

Un message autre qu'un 400, 404, 403 ou autre serait un résultat positif à une indisponibilité !

A messieurs d'OVH d'être professionnels et de faire en sorte que ce service soit fonctionnel.

A bon entendeur !

atkati
26/04/2004, 09h11
J'ai désactivé le mod_gzip d'apache. C'est pas très propre, mais ça remarche.

Par contre, du coup, j'ai MySQL qui déconne, mon espace disque du systeme a été complètement bouffé !

Ca durait depuis hier 15H00 environ...

Je cherche où est-ce que ça m'a bouffé de la place et je vais tenter nettoyer.

Peut-être que ça va me rectifier les soucis avec MySQL.

atkati
26/04/2004, 08h34
Salut,

j'ai un ENORME probleme.

Plus d'accès web sur mon serveur dédié.

Aucune manipulation spéciale dessus.

J'ai ça de bizarre dans mes logs :

[Mon Apr 26 09:30:26 2004] [error] mod_gzip: EMPTY FILE [/tmp/_14142_119_20.wrk] in sendfile2
[Mon Apr 26 09:30:26 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:30:26 2004] [error] mod_gzip: EMPTY FILE [/tmp/_32042_118_19.wrk] in sendfile2
[Mon Apr 26 09:30:26 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:30:51 2004] [error] mod_gzip: EMPTY FILE [/tmp/_29354_120_21.wrk] in sendfile2
[Mon Apr 26 09:30:51 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:31:34 2004] [error] mod_gzip: EMPTY FILE [/tmp/_11192_121_22.wrk] in sendfile2
[Mon Apr 26 09:31:34 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:31:35 2004] [error] mod_gzip: EMPTY FILE [/tmp/_28270_121_22.wrk] in sendfile2
[Mon Apr 26 09:31:35 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:31:35 2004] [error] mod_gzip: EMPTY FILE [/tmp/_15634_120_21.wrk] in sendfile2
[Mon Apr 26 09:31:35 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:31:59 2004] [error] mod_gzip: EMPTY FILE [/tmp/_16296_117_18.wrk] in sendfile2
[Mon Apr 26 09:31:59 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:32:00 2004] [error] mod_gzip: EMPTY FILE [/tmp/_6663_119_20.wrk] in sendfile2
[Mon Apr 26 09:32:00 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:32:00 2004] [error] mod_gzip: EMPTY FILE [/tmp/_6916_120_21.wrk] in sendfile2
[Mon Apr 26 09:32:00 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: EMPTY FILE [/tmp/_26512_120_21.wrk] in sendfile2
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: EMPTY FILE [/tmp/_31201_120_21.wrk] in sendfile2
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: EMPTY FILE [/tmp/_26902_119_20.wrk] in sendfile2
[Mon Apr 26 09:32:39 2004] [error] mod_gzip: Make sure all named directories exist and have the correct permissions.
Quelqu'un sait comment faire ?