OVH Community, votre nouvel espace communautaire.

aide script sh


trakiss
19/04/2004, 17h40
réglé lol

trakiss
19/04/2004, 17h38
heu en lexecutant en dehors du script jai lerreur suivante :

./sh.sh: line 5: syntax error near unexpected token `>'
./sh.sh: line 5: `sed s/"$org_name = 'SquirrelMail';"/"$org_name = '$domaine';"/g /home/$compte/webmail/config/config_default.php > '

read compte
read domaine

# configuration
sed s/"$org_name = 'SquirrelMail';"/"$org_name = '$domaine';"/g /home/$compte/webmail/config/config_default.php >
/home/$compte/webmail/config/config2.php
sed s/"$squirrelmail_default_language = 'en_US';"/"$squirrelmail_default_language = 'fr_FR';"/g
/home/$compte/webmail/config/config2.php > /home/$compte/webmail/config/config3.php
sed s/"$domain = 'mydomain.com';"/"$domain = '$compte';"/g /home/$compte/webmail/config/config3.php >
/home/$compte/webmail/config/config4.php
sed s/"$imap_server_type = 'cyrus';"/"$imap_server_type = 'courier';"/g /home/$compte/webmail/config/config4.php >
/home/$compte/webmail/config/config.php
rm /home/$compte/webmail/config/config1.php
rm /home/$compte/webmail/config/config2.php
rm /home/$compte/webmail/config/config3.php
rm /home/$compte/webmail/config/config4.php
une idée ?

trakiss
19/04/2004, 17h36
http://www.zepitt.ch/spip/article.php3?id_article=151

Voila le script sh que j'utilise enfin essaie

voila mon probleme, arrivé a :

# configuration
sed s/"$org_name = 'SquirrelMail';"/"$org_name = '$domaine';"/g /home/$compte/webmail/config/config_default.php > /home/$compte/webmail/config/config2.php
sed s/"$squirrelmail_default_language = 'en_US';"/"$squirrelmail_default_language = 'fr_FR';"/g /home/$compte/webmail/config/config2.php > /home/$compte/webmail/config/config3.php
sed s/"$domain = 'mydomain.com';"/"$domain = '$compte';"/g /home/$compte/webmail/config/config3.php > /home/$compte/webmail/config/config4.php
sed s/"$imap_server_type = 'cyrus';"/"$imap_server_type = 'courier';"/g /home/$compte/webmail/config/config4.php > /home/$compte/webmail/config/config.php
rm /home/$compte/webmail/config/config1.php
rm /home/$compte/webmail/config/config2.php
rm /home/$compte/webmail/config/config3.php
rm /home/$compte/webmail/config/config4.php
ca plante au debut

le probleme : je nes aucun emssage dereur, le truc tourne dans le vide ou je ne sais quoi

quelquu'n vois lerreur ?