OVH Community, votre nouvel espace communautaire.

serveur chargé


stouz
01/05/2004, 02h28
merci pour ta réponse, j'ai stopper gzip pour l'instant.

Pour ce qui est des pics ponctuel, ça se vérifi vraiment tout les jours, c'est très ponctuel. je comprends pas.
Et nan il n'y a pas de CRON a ces heures la. a par de rafraichissement de mrtg, mais ça c'est toute les 5 minutes toute la journée, donc je comprend pas.

TranSGeniK
01/05/2004, 02h05
C'est encore le mod_gzip qui merdouille, regarde dans le /tmp à coup sur c'est encore le bordel avec les .wrk.

En attendant de trouver le problème, désactive le mod_gzip sur ton serveur Apache, dans le fichier de configuration httpd.conf cherche la ligne:
puis commente celle-ci:
mod_gzip_on yes (tu rajoutes un # devant)
# mod_gzip_on yes

Tu sauvegardes et tu redemarre Apache

Pour la charge ponctuelle as tu regardé si il y avait des taches CRON qui pourraient correspondre à ces heures?

stouz
29/04/2004, 15h34
et bien non ! lol
je pensais que ça allais mieux, et la depuis 2,3 jours ,c'est de nouveau la folie.
C'est vraiment imcompréhensible.
C'est enorme quand meme la, nan ?! qu'en pensez vous ?
http://ns30613.ovh.net/mrtg/mrtg-sys/

Vous avez pas d'autres petites idée pour m'aider. Je fouille vraiment dans tous les logs et je vois rien du tout.

Merci d'avance.

TranSGeniK
27/04/2004, 05h48
Supprime les fichiers qui sont dans le répertoire /tmp ça devrait aller mieux.

stouz
22/04/2004, 16h26
Donc nan ?! personne n'a un avis sur mon probleme ?!
Je les supprime ces fichiers étranges ?

Personne que hier le serveur a grave planter entre 20h et 22h, c'était la folie !

stouz
20/04/2004, 19h29
hum... après analyse de /tmp, ce que j'avais fais il n'y a pas très longtemps je trouve certains trucs un peu étrange ...

Il y a 496 fichiers (mouais ...) : normal ça ?!

- Enormément de .wrk certain remontant au 10 avril, mais tous excepté 1 pèsent 0 octets : normal ça ?

- Ensuite je trouve quelques fichiers très étrangent ... Tentative de hack ? hack ? parano de ma part ?!!

srwxr-xr-x 1 root root 0 mar 11 02:42 file850Oje
drwxr-xr-x 2 root root 4096 avr 8 04:15 hsperfdata_root
-rw-r--r-- 1 root root 7 jan 26 19:28 LATEST-VERSION-IS
-rw------- 1 nobody nobody 5119 avr 16 16:35 php5QZeC3
-rw------- 1 nobody nobody 46071 avr 16 16:33 phpDlTSCB
-rw------- 1 nobody nobody 209879 avr 3 23:03 phpjkRjZz


- Ensuite il y a plusieurs centaine de fichier de session mais datant tous de aujourd'hui, donc ça ça devrait etre normal. enfin je pense.

stouz
20/04/2004, 19h19
ouais je suis en super plan (128Mo)

je viens de faire le changement :
MaxClients 47 (avant c'était bien 50)

On va bien voir ce qui va se passer. Mais j'avais deja mis 30 et ça planter quand meme. En tout cas je sais pas trop a quoi c'est du, mais aujourd'hui ça na pas trop planté. Enfin a par a 20h ou la charge est monté a plus de 2100 ....

TranSGeniK
20/04/2004, 19h17
Y a une embrouille avec ton espace /
Visiblement y a un ou plusieurs fichiers qui prennent de la place sur ton espace /
Regarde dans ton /tmp si c'est pas trop le bordel.

Fraser
20/04/2004, 17h53
Si t'es bien en superplan (128Mo)
Descend ton nombre de slot maxi apache à 47 (il est à 50 sur ta config), ca devrait se stabiliser.

stouz
20/04/2004, 14h33
Salut, merci de ta réponse Julien
ouais ça doit surement etre ça.
Mais j'ai beau cherché, grace a ovh-status notamment au moment ou ça plante, et je vois rien d'anormal.
Et puis je comprend pas pourquoi c'est généralement a des heures fixe : 14h, 16h, 18h

Julien2222
20/04/2004, 02h52
Si c'est le meme site depuis le debut le probleme vient de la et d'un de tes scripts qui doit faire une grossr boucle infinie ou une recherche mysql tres tres bourrin

stouz
19/04/2004, 15h15
Salut
J'ai un serveur dédié chez ovh depuis maintenant 3/4 mois. Tout se passe bien. Parcontre je suis embetté car depuis que je l'ai, mon serveur ram tout les jours ou presque et il est donc inaccéssible parfois pendant plusieurs heures. Je ne comprend pas d'ou cela peut venir, j'ai cherchais partout, suivit tous les tutoriels, howto, discutions ,... j'ai fais toute les manip a faire. Et rien ne change. Aujourd'hui ça va encore, mais bon, je ne comprends pas, car ce sont des pics soudain (montant la charge a 5k parfois et le load average vers 30), généralement a des heures précises (pas de cron pourtant). Regardez les courbes mrtg : http://ns30613.ovh.net/mrtg/mrtg-sys/ j'ai vraiment rien trouvé de semblable. De plus je n'ai qu'un seul site qui tourne sur le serveur actuellement. Les charges viennent depuis mysql et httpd apparemment , mais rien de sur. C'est surement juste la conséquence. Que faire ?! ça fait plusieurs fois que je vous contacte le support, mais sans succès.
Merci beaucoup d'avance a ceux qui peuvent un peu m'aider