OVH Community, votre nouvel espace communautaire.

Probllème d'envoi email


zopeur
19/04/2004, 12h40
j'ai regardé dans la pile de log de qmail et, pour un envoi par exemple dans ma bal tarek@ziade.org via python,

c'est extremement étrange on a l'impression qu'il essaye d'envoyer à tarek@ziade.org_ donc fatalement, il trouve pas le domaine....(le tiret en plus) (j'ai fait le meme envoi par mailto c'est ok il y a pas le tiret)

mais via python ca ne marche pas
voila le log

new msg 212630
info msg 212630: bytes 605 from < root@ns2641.ovh.net >
qp 31930 uid 503
starting delivery 127: msg 212630 to remote tarek@ziade.org_
status: local 0/10 remote 1/20
delivery 127: failure:
Sorry, I couldn't find any host named ziade.org?. (#5.1.2)/ (j'ai supprimé les _ entre les mots le parser epoz aime pas trop je crois
status: local 0/10 remote 0/20
bounce msg 212630 qp 28709
end msg 212630
new msg 212638
info msg 212638: bytes 1155 from <> qp 28709 uid 507
starting delivery 128: msg 212638 to local
ns2641.ovh.net-root@ns2641.ovh.net
status: local 1/10 remote 0/20
delivery 128: success: did_0+0+1/
status: local 0/10 remote 0/20
end msg 212638


remarque : vous avez remarqué le ? derrière ziade.org, apparement c'est le _ digeré...

reste à saisir pkoi via python, je me retrouve avec ca...


le code python d'envoi et son résultat
voila le bout de code python qui envoi le mail :

import smtplib
s = smtplib.SMTP("localhost")
s.set_debuglevel(1)
tolist = ["tarek@ziade.org"]
msg = '''
From: root@ns2641.ovh.net
Subject: test

test
test'''
s.sendmail("root@ns2641.ovh.net",tolist,msg)
s.quit()

et voila le retour :

send: 'ehlo ns2641.ovh.net\r\n'
reply: '250-ns2641.ovh.net\r\n'
reply: '250-PIPELINING\r\n'
reply: '250 8BITMIME\r\n'
reply: retcode (250); Msg: ns2641.ovh.net
PIPELINING
8BITMIME
send: 'mail FROM:\r\n'
reply: '250 ok\r\n'
reply: retcode (250); Msg: ok
send: 'rcpt TO:\r\n'
reply: '250 ok\r\n'
reply: retcode (250); Msg: ok
send: 'data\r\n'
reply: '354 go ahead\r\n'
reply: retcode (354); Msg: go ahead
data: (354, go ahead)
send: '\r\nFrom: root@ns2641.ovh.net\r\nSubject: test\r\n\r\ntest\r\ntest\r\n.\r\n'
reply: '250 ok 1082364958 qp 27858\r\n'
reply: retcode (250); Msg: ok 1082364958 qp 27858
data: (250, ok 1082364958 qp 27858)
send: 'quit\r\n'
reply: '221 ns2641.ovh.net\r\n'
reply: retcode (221); Msg: ns2641.ovh.net



c'est quand meme strange que derrière le mail soit jeté avec un _ ajouté sur l'email destinataire non ?

enfin bon si qqu'un à une idée :~(

zopeur
19/04/2004, 09h41
bon en fouillant dans les logs voici ce que j'ai trouvé pour un essai d'envoi su rma bal tarek@ziade.org :

new msg 212630
info msg 212630: bytes 605 from < root@ns2641.ovh.net >
qp 31930 uid 503
starting delivery 127: msg 212630 to remote tarek@ziade.org_
status: local 0/10 remote 1/20
delivery 127: failure:
Sorry, I couldn't find any host named ziade.org?. (#5.1.2)/ (j'ai supprimé les _ entre les mots le parser pas trop je crois )
status: local 0/10 remote 0/20
bounce msg 212630 qp 28709
end msg 212630
new msg 212638
info msg 212638: bytes 1155 from <> qp 28709 uid 507
starting delivery 128: msg 212638 to local
ns2641.ovh.net-root@ns2641.ovh.net
status: local 1/10 remote 0/20
delivery 128: success: did_0+0+1/
status: local 0/10 remote 0/20
end msg 212638


-> apparement il ajoute un _ derrière l'email donc il trouve pas le domaine

qqun a une idée ?

zopeur
18/04/2004, 20h38
Bonjour, j'ai un problème étrange :
avec un user donné j'arrive à envoyer des mails à l'exterieur via mon smtp sans soucis (en utilisant MailTo en ligne de commande)

Mais dès lors que j'utilise un envoi via un script python (librairie qui communique avec le smtp) cela ne marche plus.

Pour être précis, si je regarde la conversation qu'il se passe entre le script et le serveur (mode "verbeux") tout se passe bien, le serveur SMTP qmail répond correctement et annonce l'envoi de l'email sans souci (aucune erreur)....

mais l'email n'arrive jamais.
j'ai regardé le fichier de log dans qmail, et je n'y ai rien vu d'anormal. Pourtant c'est bien qmail qui répond au script, puisqu'il se présente....

alors là je marrache la tete, je ne sait pas trop quoi faire, il ya peut être un endroit particulier ou regarder ? MailTo se base peut etre sur autre chose que qmail et smail n'a jamais marché peut etre....

heeeeeeeeeeeeeelllppp !