OVH Community, votre nouvel espace communautaire.

[Apache 2] Fichiers .ZIP ou .GZ corrompus après téléchargement


acousticsamples
18/05/2009, 14h46
Bon, ben en effet, les fichiers rar ne marchent pas non plus chez moi, personne n'a une idée?
En revanche pour les mp3 et le reste, merci!!!

Emprint
28/04/2009, 15h54
Tu as relancé Apache ?

Daelin
17/08/2008, 10h12
De meme pour moi, ca m'a bien été utile
Merci a vous

Emprint
27/03/2008, 10h32
Les gars, vous venez de sauver ma semaine...
Ça fait des mois que je cherche pourquoi mes applications Flex (browser d'AMFPHP) ne se lancent pas correctement sur mon dédié gentoo alors qu'en local ça fonctionne.
Ça fait des mois que je cherche pourquoi mes vidéos en h264 ne se chargent pas dans Flash !!!


Et tout ça a cause du mod_gzip (deflate).


Merci, vraiment.

radio666
05/07/2007, 16h13
Merci énormément.
Je me prenais la t^te depuis plusieurs semaines car mon kimsuffy ne pouvait pas servir des mp3 à un lecteur flash.
J'ai failli jeter le serveur, mais je vais le garder un peu !!

michamaza
06/03/2007, 21h42
Excellent, merci beaucoup pour cet explication. J'ai essayé avec des formats de vidéo et musiques, ça marche impec ! C'est aussi pour ça qu'on arrive pas à voir les vidéos lorsqu'elles sont en plug-in...mais après cette config ça tourne !

sadkun
01/02/2007, 15h46
Il en est de même pour les .avi, .mp3 et cie, ça résoudra tous vos problèmes

Raven
01/02/2007, 12h32
Salut,

si aprés ces modifications les problèmes persistent du genre pour IE 7 il suffit enfait de retirer un seul caractère pour que cela fonctionne.
Car tout le problème vient à la base d'une option dans le deflate.
Dans le mod_deflate:
Code:

 BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html
il faut retirer le ! devant le no-gzip:
Code:

 BrowserMatch \bMSI[E] no-gzip !gzip-only-text/html

frederic1
30/01/2007, 21h37
Si vous êtes sous Apache 2 et que les fichiers .zip ou .gz deviennent corrompus après téléchargement, il vous faut éditer le fichier /httpd.conf et remplacer :
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png)$ no-gzip dont-vary
PAR :
SetEnvIfNoCase Request_URI \
\.(?:gif|jpe?g|png|zip|gz)$ no-gzip dont-vary
Merci à i-services pour l'astuce