OVH Community, votre nouvel espace communautaire.

PHP-GD chez OVH -> FreeType Linkage pas à jour.


lol
16/04/2004, 15h07
Je viens de passer mon hébergement du 20gp au 60gp pour pouvoir faire du php, et utiliser la librairie GD pour ecrire sur des images en php, et quel dégout quand j'ai vu que mon texte s'ecrivais en jaune au lieu de noir

Je suis donc venu sur se forum pour la premiere fois et m'appercois que je ne suis pas le seul a demander la version deux de la librairie.

Qu'est ce qui vous empeche de la mettre a jour cette librairie

Expliquez nous pourquoi des hebergeurs moins professionnel (free.fr ou mon ancien hebergeur mm100) possedent cette version

Je part de chez mm100 car mon site ne fonctionne pas comme il faut chez eux, et que chez eux, et je m'apercois que chez vous le probleme disparait mais un autre apparait

ikkiphenix
05/04/2004, 17h52
Bonjour,
OVH vient de proposer mysql4, va passer dans quelques temps à PHP5, ce sont de très bonnes choses, attractives certes pour les clients (je l'avoue) et les futurs clients, mais certains thèmes plus spécifiques, moins connus mais qui donnent à PHP toute sa puissance et sa souplesse, semblent malheureusement mis à l'écart et moins suivis. Dans mon cas, je pense précisemment au phpinfo() où l'extension GD est compilée avec TTF Library (Freetype 1) qui donne lieu à de nombreux bugs. La plus récente est "With Freetype" (Freetype 2) qui arrange le tout. Sur http://bugs.php.net/bug.php?id=27693 , je suis le lanceur du thread.
J'avais dans un premier temps écrit au support en espérant pouvoir profiter rapidement des possibilités graphiques de php grâce à la mise à jour d'une librarie vieille et buguée, mais à mon grand regret on m'a répondu que ce n'était pas à l'ordre du jour. Dommage... De ce fait, php4 ou php5 (j'ai essayé la beta) ne changera pas la donne puisque une extension existante est buguée...

Cordialement.

--
Xavier