OVH Community, votre nouvel espace communautaire.

PB utilisation ATOS


copper
07/01/2008, 09h13
Il faudrait que tu m'envoies le code de ton fichier php pour voir si toutes les variables sont bien initialisées.

Fais le par le forum ou en MP, c'est toi qui voit.

A+

Copper

lelectronique
06/01/2008, 21h18
Bonjour,

Tout d'abord merci pour ta réponse. Donc pour résumer si j'appelle le cgi directement via un formulaire en passant les champs cela fonctionne correctement la preuve via la page de test de la banque http://www.jlt7.com/boutique/test/test_paiement.html

par contre quand je passe le cgi via cette ligne
Code:
  echo shell_exec( "/cgi-bin/modulev2.cgi $PBX" );
dans le fichier php il ne se passe rien http://www.jlt7.com/boutique/test/test_paiement.php

je ne comprends pas trop pourquoi même pas d'erreur c'est la première fois que je met en place ce genre de système en plus...

je suis preneur de tout idée

a noter que j'ai récupéré le script "Module v2.20 : DEBIAN noyau 2.4.25 - libc 2.2.5" parmi cette liste :
Code:
Module v2.00 : AIX version 4 release 3
Module v2.00 : AIX version 5 release 2
Module v2.00 : FREE BSD 4.7
Module v2.00 : FREE BSD 4.9
Module v2.00 : FREE BSD 5.3
Module v2.00 : MAC OS X architecture RISC
Module v2.00 : SUN SOLARIS 5.9 Solaris v9.0 sparc RISC
Module v2.00 : SuSE 9.2 noyau 2.6.8 libc 2.3.3
Module v2.10 : AIX BULL Escala version 4 release 3 Architecture RISC
Module v2.10 : LINUX 64 bits noyau 2.4.22 libc 2.3.2
Module v2.10 : Linux COBALT noyau 2.4.19 - libc 2.2.3
Module v2.10 : REDHAT 7.3 noyau 2.4.20 libc 2.2.5
Module v2.10 : SUN SOLARIS 5.8 sparc RISC
Module v2.10 : UNIX HP version 11i ou 11.11 architecture RISC
Module v2.11 : LINUX 64 bits noyau 2.6.9 libc 2.3.4
Module v2.11 : Linux CentOS 4.2 noyau 2.4.20 libc 2.3.4
Module v2.11 : REDHAT 7.2 noyau 2.4.29 libc 2.2.4
Module v2.11 : SUN Solaris v10.0 Intel
Module v2.11 : UNIX SCO system V release 4
Module v2.20 : DEBIAN noyau 2.4.25 - libc 2.2.5
Module v2.20 : REDHAT 8.0 noyau 2.4.18 libc 2.3.2
Module v3.02 : FEDORA 64 bits noyau 2.6.16 libc 2.3.6
Module v3.02: module EXE pour WINDOWS 98, NT 4.x, XP, 2000, 2003
merci d'avance
bonne soirée
A+
ludo

copper
06/01/2008, 20h54
Alors dans un premier temps fais tes essais sur ton serveur local (easyphp par exemple si tu es sous windows).
Essayes.
Si ca fonctionne chez toi, tu peux essayer chez ovh mais telecharge le bon cgi (il y en plein, ca depend de l'OS qui heberge ton site).

Ensuite essayes de chez OVH.

Si ca ne marche pas tu peux appeller le support technique de Atos, pour ma part ils ont été top.
Le probleme venait de chez OVH, mais quand je les appellait ils disaient que tout etait ok chez eux.
A la fin de l'histoire c'est le support de Atos qui a appellé OVH et le PB s'est réglé.
Atos m'a dit que celà arrivait souvent chez OVH.
Si tu veux + d'explication, pas de PB. Dis moi comment tu appelles ton script, ce que tu as à l'écran...etc

Bon courage

Copper

lelectronique
05/01/2008, 20h55
Bonjour,

as tu trouvé une solution au problème car je suis confronté au même soucis

merci d'avance pour ton aide

bonne soirée
A+
Ludo

copper
15/11/2006, 09h15
Salut à tous,

j'ai dev un site de ecommerce et integre le module de paiement Atos (module cgi).

Quad je fais appel au script via un formulaire tout fonctionne, mais au niveau secu c'est pas top.
Donc je veux faire comme il est conseille de faire, appeller le module via un shell_exec. Et la ca ne marche pas, je n'ai aucun message et je ne suis pas redirige vers la banque pour le paiement.
La hotline me ballade un peu donc je faix appel à vous si vous avez une idée.
Sinon j'ai bien fait un chmod 755 sur le module cgi.

Merci d'avance

Copper