OVH Community, votre nouvel espace communautaire.

Mails envoyé par la fonction mail()


vieuxbrice
05/11/2006, 19h43
Je viens d'essayer et cela fonctionne nickel !!

MErci bcp pour le coup de pouce.

vieuxbrice
05/11/2006, 19h38
Merci pour le script.

Je vais essayer...

visualight
05/11/2006, 12h14
Essaye avec le script php ci-dessous.

Si l'erreur réapparaît, c'est que le problème est autre part.

Code PHP:
// Récupération des valeurs des champs du formulaire
$nom $_POST['nom'];
$email $_POST['email'];
$demande $_POST['message'];

// Création de l'email et de son entête
$to "$email;
$from "TON ADRESSE MAIL" ;

$subject "TITRE DE L'EMAIL" ;
$message =  "$demande";
$header 'From: '.$from."\n"
 
.'MIME-Version: 1.0'."\n"
 
.'Content-Type: text/html; charset= ISO-8859-1'."\n"
 
.'Content-Transfer-Encoding: 7bit'."\n\n";

// Envoi de l'email
mail($to,$subject,$message,$header); 
@+

osgadou
03/11/2006, 15h06
oui c'est un probleme de script et de header

trouve un autre script pour envoyer le mail avec mail()

vieuxbrice
03/11/2006, 12h45
Bonjour,

je suis depuis peu client chez OVH et j'utilise sur mon site la fonction mail() afin de m'envoyer des emails dans certains cas. (pour faire du suivi sur certaines fonctions du site).

Les mail sont bien envoyé, avec le bon message, le bon sujet et tout et tout... mais ils commencent tous par :

Message-Id: <20061103124002.F3D7E361DF@90plan.ovh.net> Date: Fri, 3 Nov 2006 13:40:02 +0100 (CET) X-Ovh-Remote: 213.186.36.178 (8.mail-out.ovh.net) X-Ovh-Local: 213.186.33.29 (mx1.ovh.net) X-Spam-Check: DONE|H 0.5/N

y'a t'il un moyen pour enlever cela des mails envoyés ??

Merci d'avance.