OVH Community, votre nouvel espace communautaire.

[Apache2] Augmenter Maxclients


brouk
24/08/2007, 17h00
donc si je change par :

StartServers 5
MinSpareServers 5
MaxSpareServers 10
ServerLimit 512
MaxClients 200
MaxRequestsPerChild 0

C'est Ok normalement ?
et j'ai changer le 150 maxslients par le 200 c'est Ok aussi ?
Merci pour ta réponse

Blade1o6
24/08/2007, 16h45
Ben de toute façon il n'y en a qu'un des 2 qui est exécuté. Sous Linux, c'est le prefork qui sera utilisé vraisemblablement, vu que le Worker est sujet à des petites fuites de mémoire ou n'est pas recommandé par le PHP Group.

Donc le premier. Enfin à moins que t'aies choisi l'autre par erreur :-)

brouk
24/08/2007, 16h41
Merci beaucoup pour votre aide, j'ai encore une petite question!
dans le fichier apache2.conf j'ai 2 endroit ou il a MaxClients.
Actuelement c'est comme se ci:

StartServers 5
MinSpareServers 5
MaxSpareServers 10
MaxClients 150
MaxRequestsPerChild 0

je dois changer comme cela ??


StartServers 5
MinSpareServers 5
MaxSpareServers 10
ServerLimit 512
MaxClients 200
MaxRequestsPerChild 0


et le 2 endroit :

StartServers 2
MaxClients 150
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0

je dois changer comme ca ??

StartServers 2
ServerLimit 512
MaxClients 200
MinSpareThreads 25
MaxSpareThreads 75
ThreadsPerChild 25
MaxRequestsPerChild 0

pour pas faire de connerie pouvez vous me confirmer ?

Nissart
25/05/2007, 21h55
WARNING: MaxClients of 300 exceeds ServerLimit value of 256 servers,
lowering MaxClients to 256. To increase, please see the ServerLimit


Nissart
19/05/2007, 11h06
merci Fred

Mon souci c'est que j'ai paramétré depuis un moment la valeur à son max (256) et après une hausse de fréquentation de mes sites, je vois via mes courbes MRTG que ça bouchonne à plusieurs moments de la journée, sans que ma RAM ou mon %age CPU soit en danger.

Le souci c'est que pour tester j'ai voulu le passer à 300 en modifiant comme ci dessous, mais même après avoir redémarré Apache, ça bloque à 256. Est-ce que j'ai merdé ailleurs ?


StartServers 5
MinSpareServers 5
MaxSpareServers 10
ServerLimit 512
MaxClients 300
MaxRequestsPerChild 0

frederic1
19/05/2007, 01h54
Hello Nissart

Personnellement je tape de temps en temps cette commande :
Code:
cat /var/log/httpd/error_log |grep MaxClients
S'il me répond un truc du genre :
Code:
[Fri Aug 04 02:30:02 2006] [error] server reached MaxClients setting, 
consider raising the MaxClients setting
... alors je sais qu'il faut augmenter la valeur MaxClients. Je te conseille d'augmenter intelligemment cette valeur car comme l'a dit Blade1o6, plus c'est élevé plus ça utilisera de RAM.

Voilà j'espère que ça t'a aidé

Nissart
17/05/2007, 17h13
Citation Envoyé par sadkun
Mais grâce à la magie de apache 2 tout se simplifit :

  • Ouvrez votre httpd.conf
  • Selon votre module rajoutez au-dessus de MaxClients la ligne suivante :
  • ServerLimit : 512 (ou 1024 tout dépend de votre config)
  • Ensuite vous n'avez plus qu'à augmenter votre MaxClients, et ohhh miracle, apache ne râle plus
Merci sadkun.
Dans server limit tu mets 512 ou 1024 suivant la config. Mais justement qu'est ce qui va faire que l'on met l'un ou l'autre ? Mon maxclients est actuellement à 256 sur un dédié MG+ et c'est souvent insuffisant en raisons de sites qui utilisent des galeries d'images et prennent donc bcp de slots

Tibre44
27/12/2006, 15h55
C'est un tuto Apache 2 et dans les how-to des tutos. Il faut mieux que tu poses ta question dans une rubrique avec un titre explicite. Tu auras plus de change d'avoir une réponse

frederic1
27/12/2006, 14h37
Merci pour l'aide !

Sauriez-vous s'il faut augmenter MaxClients dans "prefork MPM" ou "worker MPM" ?

Mon serveur ovh est l'opteron dual sur os linux.

Merci pour vos réponses !

Blade1o6
22/11/2006, 12h54
Attention à être bien sûr que si on atteint le Maxclients on est pas déjà en rade sur le serveur. Car si le serveur rame déjà énormément, il vaut mieux baisser le MaxClients que de l'augmenter, c'est notamment le cas avec des fichiers PHP. Pour des images, normalement on peut l'augementer sans souci ou presque, mais bien prévoir la consommation de ram qui va avec : 2 à 8Mo/client (avec PHP), 1 à 2 Mo/client (sans PHP). Donc 512 clients avec PHP => 512 * 8 = 4Go de RAM + le CPU qui va bien ^^.

sadkun
24/10/2006, 14h12
Plop,

Bon c'est bien beau de demander du support à gauche et à droite mais il faut aussi aider les autres, c'est le principe d'une communautée.

Donc souvent beaucoup sont confrontés au problème suivant :

Le MaxClients est trop faible par rapport à vos besoins, problème au-dela de 256 apache râle en vous priant de changer la valeur.

Sous apache 1 c'était la galère : modification de fichiers + recompilation d'apache, pour les débutants ça fait peur (et je suis toujours un débutant même pire )

Mais grâce à la magie de apache 2 tout se simplifit :

  • Ouvrez votre httpd.conf
  • Selon votre module rajoutez au-dessus de MaxClients la ligne suivante :
  • ServerLimit : 512 (ou 1024 tout dépend de votre config)
  • Ensuite vous n'avez plus qu'à augmenter votre MaxClients, et ohhh miracle, apache ne râle plus


En ésperant que ce mini tuto qui n'a rien de compliqué en aidera certains