OVH Community, votre nouvel espace communautaire.

Sous-domaine enregistré, quelles configurations ftp?


vdhnat
02/10/2016, 14h33
Nouvelle découverte intéressante.

J'ai créé un nouveau fichier nginx:

Code:
server {
	listen 443 ssl;

	ssl_certificate /etc/letsencrypt/live/monsite.com/fullchain.pem;
	ssl_certificate_key /etc/letsencrypt/live/monsite.com/privkey.pem;
	ssl_dhparam /var/www/monsite/ssl/dhparam.pem;

	root /var/www/sousdomaine/www;
	index index.html;

	server_name sousdomaine.monsite.com;

	include global/restrictions.conf;
	include global/wordpress.conf;
	include ssl.conf;
}

server {
	listen 80;
	listen [::]:80;

	root /var/www/sousdomaine/www;
	index index.html;

	server_name sousdomaine.monsite.com;
}
Et là, quand je me suis connecté sur mon site en http://, tout est normal. En https:// par contre je tombe sur mon "Hello world!" de l'index.html que j'avais créé pour le sous-domaine

J'ai bien vite supprimé cette config puisque je souhaite qd même que les gens accèdent à mon site principal avec https://. Mais si ça peut aider...

vdhnat
02/10/2016, 14h31
Nouvelle découverte intéressante.

J'ai créé un nouveau fichier nginx:

Code:
server {
	listen 443 ssl;

	ssl_certificate /etc/letsencrypt/live/monsite.com/fullchain.pem;
	ssl_certificate_key /etc/letsencrypt/live/monsite.com/privkey.pem;
	ssl_dhparam /var/www/monsite/ssl/dhparam.pem;

	root /var/www/sousdomaine/www;
	index index.html;

	server_name sousdomaine.monsite.com;

	include global/restrictions.conf;
	include global/wordpress.conf;
	include ssl.conf;
}

server {
	listen 80;
	listen [::]:80;

	root /var/www/sousdomaine/www;
	index index.html;

	server_name sousdomaine.monsite.com;
}
Et là, quand je me suis connecté sur mon site en http://, tout est normal. En https:// par contre je tombe sur mon "Hello world!" de l'index.html que j'avais créé pour le sous-domaine

J'ai bien vite supprimé cette config puisque je souhaite qd même que les gens accèdent à mon site principal avec https://. Mais si ça peut aider...

vdhnat
02/10/2016, 11h32
Ok, je comprends. Merci beaucoup pour le lien vers le tuto, ça a aidé.

En fait, je me suis rendu compte que mon serveur utilisait nginx, pas apache. Voici ce que j'ai fait:

J'ai créé un nouveau fichier dans etc/nginx/sites-available/ avec en partie les infos suivantes:

Code:
server {
	listen 80 default_server;
	listen [::]:80 default_server ipv6only=on;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Ensuite, j'ai créé un symlink dans etc/nginx/sites-enabled/ pour le fichier sousdomaine que je venais de créer.

Lors du service restart nginx, j'ai eu l'erreur de duplicate, j'ai donc modifié la config des deux premières lignes selon ce que j'ai trouvé sur le net:

Code:
server {
	listen 80;
	listen [::]:80;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Nginx a redémarré sans problème, mais quand je me connecte à sousdomaine.monsite.com, cela ne fonctionne toujours pas (j'ai la page index of / sans aucun fichier). Je pense que je me rapproche de la bonne solution par contre ! Merci beaucoup pour tout ce que j'apprends.

As-tu une idée de ce que pourrait être le problème maintenant ?

vdhnat
02/10/2016, 09h30
Citation Envoyé par _skip
Essaie de faire ça en local, sur une installation virtualbox en créant des entrées dans le fichier /etc/hosts. Et en suivant des tutos comme celui-ci:
https://wiki.gandi.net/fr/hosting/us...u/virtualhosts

Tu peux aussi louer un VPS de l'heure le temps de faire des essais.
Le tuto a été très utile, merci ! Maintenant je comprends que mon serveur utilise nginx et pas apache... ceci dit la manip a l'air très similaire.

J'ai donc créé un nouveau fichier dans sites-available et créé un symlink dans sites-enabled. La configuration était la suivante:

Code:
server {
	listen 80 default_server;
	listen [::]:80 default_server ipv6only=on;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Puis nginx m'a sorti l'erreur de duplicate:
Code:
nginx: [emerg] duplicate listen options for 0.0.0.0:80 in /etc/nginx/sites-enabled/
D'après mes recherches, c'est parce que /sites-enabled/monsite utilise déjà "listen 80 default_server". J'ai donc modifié la config:

Code:
server {
	listen 80;
	listen [::]:80;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Maintenant nginx restart sans problème, mais toujours rien n'apparaît sur mon sous-domaine (mon site principal est OK). As-tu une idée d'où le problème pourrait se trouver ?

En tout cas j'apprends beaucoup -- donc merci !

vdhnat
02/10/2016, 09h25
Citation Envoyé par _skip
Essaie de faire ça en local, sur une installation virtualbox en créant des entrées dans le fichier /etc/hosts. Et en suivant des tutos comme celui-ci:
https://wiki.gandi.net/fr/hosting/us...u/virtualhosts

Tu peux aussi louer un VPS de l'heure le temps de faire des essais.
Merci, le tuto a aidé ! Je comprends maintenant que mon serveur utilise nginx, pas apache... ;-)

Du coup c'était beaucoup plus clair. J'ai créé un nouveau fichier dans sites-available avec les infos suivantes:

Code:
server {
	listen 80 default_server;
	listen [::]:80 default_server ipv6only=on;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Et j'ai créé un symlink dans sites-enabled. Puis nginx m'a sorti l'erreur de duplicate nginx:
Code:
[emerg] duplicate listen options for 0.0.0.0:80 in /etc/nginx/sites-enabled/
Après quelques recherches, j'ai cru comprendre que /sites-available/monsite utilisait déjà listen 80 default_server et j'ai donc apporté les changements suivants:

Code:
server {
	listen 80;
	listen [::]:80;

	root /var/www/sousdomaine/www;
	index index.html index.htm;

	server_name sousdomaine.monsite.com;
Nginx se lance sans problème... mais toujours rien n'apparaît sur mon sous-domaine :-)

Je pense que je me rapproche, et j'apprends beaucoup ! As-tu une idée d'où se trouverait la mauvaise manip ?

_skip
02/10/2016, 08h03
Essaie de faire ça en local, sur une installation virtualbox en créant des entrées dans le fichier /etc/hosts. Et en suivant des tutos comme celui-ci:
https://wiki.gandi.net/fr/hosting/us...u/virtualhosts

Tu peux aussi louer un VPS de l'heure le temps de faire des essais.

vdhnat
01/10/2016, 18h06
Citation Envoyé par janus57
Bonjour,

cela se configure sur votre serveur (les VHost), et OVH n'a rien à voir avec l'administration de votre serveur (sauf contrat d'infogérance).

Vous êtes sûr d'être en dédié et pas mutualisé ? (car avoir 0 connaissance et prendre un dédié c'est un peu du suicide même si y a des panel pour faciliter le boulot)

Cordialement, janus57
Oui, je suis en dédié. Compris; rien à voir avec OVH alors. J'ai un peu regardé sur le web et je pense devoir configurer ça (voir ci-dessous) dans /etc/apache2/sites-available/. Par contre, je n'ai que /etc/apache2/conf-available qui contient un javascript-common.conf . Du coup je suis un peu déconcerté ...

Code:

        ServerName test.my.address.com
        ServerAdmin webmaster@my.address.com

        DocumentRoot /var/www/test.my.address.com/
        
                Options FollowSymLinks
                AllowOverride None
        
        
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        

        ErrorLog ${APACHE_LOG_DIR}/test.my.address.com.error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/test.my.address.com.access.log combined

janus57
01/10/2016, 17h36
Citation Envoyé par vdhnat
Oui, ça me semble logique. Où puis-je configurer ça chez OVH ? Il y a un guide ?

Merci
Bonjour,

cela se configure sur votre serveur (les VHost), et OVH n'a rien à vopir avec l'administration de votre serveur (sauf contrat d'infogérance).

Vous êtes sûr d'être en dédié et pas mutualisé ? (car avoir 0 connaissance et prendre un dédié c'est un peu du suicide même si y a des panel pour faciliter le boulot)

Cordialement, janus57

vdhnat
01/10/2016, 16h06
Citation Envoyé par _skip
Si tu as deux adresses différentes qui pointent toutes les deux sur ton VPS, tu dois utiliser des Virtual Host dans la configuration de ton serveur web (apache) afin de décider quel site va s'afficher en fonction de l'URL (ou plus précisément du HOST http) qui est envoyé.

Est-ce que déjà ça, ça te parle ou pas du tout?
Oui, ça me semble logique. Où puis-je configurer ça chez OVH ? Il y a un guide ?

Merci

vdhnat
01/10/2016, 15h42
Citation Envoyé par _skip
Si tu as deux adresses différentes qui pointent toutes les deux sur ton VPS, tu dois utiliser des Virtual Host dans la configuration de ton serveur web (apache) afin de décider quel site va s'afficher en fonction de l'URL (ou plus précisément du HOST http) qui est envoyé.

Est-ce que déjà ça, ça te parle ou pas du tout?
Oui ça me semble logique, en gros je dois modifier une config pour que, quand j'entre sousdomaine.monsite.com, j'arrive au bon endroit. Tu as un guide quelque part ?

_skip
01/10/2016, 15h19
Si tu as deux adresses différentes qui pointent toutes les deux sur ton VPS, tu dois utiliser des Virtual Host dans la configuration de ton serveur web (apache) afin de décider quel site va s'afficher en fonction de l'URL (ou plus précisément du HOST http) qui est envoyé.

Est-ce que déjà ça, ça te parle ou pas du tout?

vdhnat
01/10/2016, 15h12
J'ai hier commandé un sous-domaine pour mon hébergement, il semble actif (quand je m'y connecte je vois "index of /"...).

Je voudrais savoir comment y mettre quelques fichiers (nouvel index.html etc) ? J'ai essayé de me connecter sur mon vps, dans /var/www/ mon site principal est bien là mais pas le sous-domaine. J'ai essayé de créer un folder avec le nom du sous-domaine, ajouté quelques fichiers dummy, ça n'a pas réglé le problème.

Je pense que je suis complètement à côté de la plaque (au cas ou ça n'était pas clair, je ne m'y connais pas du tout).

Merci d'avance pour vos réponses.

vdhnat