OVH Community, votre nouvel espace communautaire.

Site web affiche Index Of, config me semble correcte :D


Gaston_Phone
20/09/2016, 12h00
Citation Envoyé par MisterJay
Mysql_connect et PHP7 ne font pas bon ménage. Je ne savais pas ^^
Je change de plateforme, indexhibit n'est plus vraiment mis à jour...
Tu te voiles la face.
Tous les hébergements passent ou passeront un jour ou l'autre à PHP7.
Le problème "Mysql_connect Deprecated: Method" se posera un jour ou l'autre.

Il vaut mieux prendre le problème à bras le corps et passer de suite à MySQL en mode PDO --> OVH - Test de Base de Données via un script en langage PDO.

- - - Mise à jour - - -

Citation Envoyé par MisterJay
Merci bien, résolu.
Citation Envoyé par MisterJay
Toujours "Internal Server Error".

MisterJay
20/09/2016, 09h30
Hello !

Merci bien, résolu.

Mysql_connect et PHP7 ne font pas bon ménage. Je ne savais pas ^^

Je change de plateforme, indexhibit n'est plus vraiment mis à jour...

Merci à vous,

Ludo.H
19/09/2016, 10h45
Bonjour,

Des erreurs dans vos scripts.
Je me suis permis de changer votre .ovhconfig pour passer l'environment de "production" vers "development" et voici les messages :

Code:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Cache has a deprecated constructor in /home/julienst/www/ndxzstudio/lib/cache.php on line 3

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Core has a deprecated constructor in /home/julienst/www/ndxzstudio/lib/core.php on line 11

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/julienst/www/ndxzstudio/db/db.mysql.php:41 Stack trace: #0 /home/julienst/www/ndxzstudio/db/db.mysql.php(24): Db->initialize() #1 /home/julienst/www/ndxzstudio/common.php(169): Db->__construct() #2 /home/julienst/www/ndxzstudio/lib/core.php(113): load_class('db', true, 'db') #3 /home/julienst/www/ndxzstudio/lib/core.php(36): Core->load_db() #4 /home/julienst/www/ndxzstudio/common.php(169): Core->Core() #5 /home/julienst/www/index.php(41): load_class('core', true, 'lib') #6 {main} thrown in /home/julienst/www/ndxzstudio/db/db.mysql.php on line 41
Il vous est possible de corriger et de remettre votre environment en "production".

Cdt,

MisterJay
17/09/2016, 10h55
Bonjour à tous,

nic : sj43662-ovh
site web : www.juliensales.fr et www.reportages.juliensales.fr

J'ai du zapper quelque chose... mon site web était fonctionnel. H.S actuellement.

L'historique :
J'avais un problème avec la base de donnée partagée entre mon site et son sous-domaine :
/www -> www.juliensales.fr /reportages -> www.reportages.juliensales.fr
Deux sites web indexhibit. Une base de donnée commune.
Ca a toujours bien marché, puis l'interface du sous-domaine "reportages" est devenu accessible mais ne prenait plus en compte mes modifications

J'ai donc du modifier quelque chose... et comme ca ne marchait pas, j'ai remis les backup (base de donnée + fichiers html + confi initiale DNS et redirection).

Actuellement, plus rien ne s'affiche. Je souhaite au moins rétablir le site www.juliensales.fr

Voici la config actuelle :

.htaccess :
"SetEnv PHP_VER 7
SetEnv REGISTER_GLOBALS 0"

Permissions du site web : 705 sauf certaines fichiers qui sont en 777 pour indexhibit

C'est parti pour les screenshots :
Lien direct -> http://img110.xooimage.com/files/e/8/4/js-5068962.jpg





J'ai essayé de chercher, mais je patauge un peu pour tout vous avouer. Il me semble, avec le peu d'expériences que j'ai, que les DNS et les redirections sont ok.

J'ai attendu 48 heures après mes dernières modifs histoire que tout soit propagé pour vous contacter.
J'ai un autre site web sur ovh, avec indexhibit, configuré exactement pareil et ca marche impec. J'ai du mal a y voir clair.

En vous remerciant d'avance.

Julien,