OVH Community, votre nouvel espace communautaire.

Php 5.4 ?


chmod777
16/09/2016, 16h16
Citation Envoyé par Paul Sellis
suite à l'arrêt du support de PHP 5.2 par OVH
L'annonce de l'arrêt plutôt. Un an plus tard, ces versions obsolètes sont toujours là (peut-être que la mise en place des environnements d'exécution a fait changer d'avis ?). Mais l'idéal reste effectivement d'utiliser PHP7.

vcasse
16/09/2016, 15h59
Bonjour,

PHP 5.4 est déjà une version sans mises à jour.
PHP5.6 est actuellement la version dont le maintient est le plus long.
http://php.net/supported-versions.php

Mais je te conseille de passer en PHP7.0 : les gains en rapidité sont énorme dans cette version. Et joomla est compatible depuis la version 3.5
Sans compte que passer de PHP5.6 à PHP7.0 demande un peu de travail, ce qui sera beaucoup moins le cas en 7.1.

(D'ailleurs 7.1 va bientot sortir)

Cordialement,
Vincent

kingkurt
16/09/2016, 15h48
Citation Envoyé par saxgard

Sur le site de joomla ils ne donnent pas les infos concernant la compatibilité de la dernière version ?
Le problème vient souvent des extensions tierces
https://www.joomla.org/about-joomla/...uirements.html

saxgard
16/09/2016, 15h27
Salut

La 5.4 est déjà considérée comme obsolète depuis un bon moment et mieux vaut que dès maintenant le site soit compatible 5.6 voir même 7.0 pour se donner une bonne longueur d'avance.

Pourquoi ne pas tester en local avec un Wampserver ? De cette façon tu sera vite fixé sur la compatibilité avec les nouvelles versions php.

Sur le site de joomla ils ne donnent pas les infos concernant la compatibilité de la dernière version ?
Le problème vient souvent des extensions tierces

kingkurt
16/09/2016, 15h26
Citation Envoyé par Paul Sellis

- A votre avis elle sera supportée jusqu'à quand ?...
- Sinon, 5.6 ou directement la 7 ?

Merci
Paul
1) pas très longtemps
2) php7

Paul Sellis
16/09/2016, 14h58
Bonjour,


suite à l'arrêt du support de PHP 5.2 par OVH, et leur demande de migration vers une version plus récente de PHP, j'ai pris mes cliques et mes claques sur suis allé me faire héberger ailleurs...
;-)

En fait on n'avait pas le temps à faire toutes les mises à jour nécessaires entre celle liées à la nouvelle version de PHP et celles liées aux mises à jour de Joomla, etc.
Maintenant qu'on va prendre le temps, j'envisage de revenir chez OVH.
(je passerai dans la dernière version de Joomla)

Actuellement la version par défaut est la 5.4
Chat échaudé craint l'eau chaude…

- A votre avis elle sera supportée jusqu'à quand ?...
- Sinon, 5.6 ou directement la 7 ?

Merci
Paul