OVH Community, votre nouvel espace communautaire.

VPS OVH: bloqués sur PHP 5.3? Sérieusement?


LouisSeb
11/09/2016, 16h41
et bien, merci à tous pour vos retours.

En fait, je n'avais pas vraiment besoin d'aide hein.... J'ai réinstallé le serveur avec une distrib un peu plus à jour, puis installé Plesk dessus. Rien de très sorcier: mais quelle perte de temps.

Je voulais donc juste pousser un ptit coup de gueule: Plesk fonctionne désormais sur Cent OS7, ce serait pas mal que les équipes d'OVH mettent à jour l'installation par défaut d'un VPS plesk.

sich
11/09/2016, 13h10
Comme dis plus haut, une install en Debian 8 et il n'y aura pas ce problème.... Au lieu de chercher à avoir un truc avec panel il faut juste prendre une distrib convenable et à jour.

lxwfr
11/09/2016, 12h08
vous êtes partie faire un tour dans outils et paramètre -> mise à jours et mise à niveaux puis coché je sais il y a 5.4 mais 5.3 pas sur.

- - - Mise à jour - - -

mrc comme même, lol, j'uilise pas cette version

buddy
11/09/2016, 12h02
La 5.5 est end of life depuis 1,5 mois aussi

lxwfr
11/09/2016, 12h00
php.net ne support plus cette version 5.3 et 5.4 actuellement seul les v.5.5, 5.6 et 7

buddy
11/09/2016, 11h17
Ovh propose également plesk pour centos 7 en autre l'on ?, https://www.ovh.com/fr/serveurs_dedies/plesk.xml

Sinon la release 3 ovh est toujours sous php 5.3....

buddy
11/09/2016, 11h11
C'est parce que c'est plesk non ? Plesk ne propose pas de mise à jour via son interface ?

Tu peux très bien partir sur un Vps avec debian 8 en 2015 et virtualmin https://www.how-to.ovh/viewtopic.php?f=2&t=12#p29 c'est gratuit en plus virtualmin

LouisSeb
11/09/2016, 10h28
Bonjour,

je viens de commander un VPS OVH avec une licence Plesk.
Ce serveur est livré de base avec CentOS6 : centOS 6 est sortie en 2011. Centos7 est sortie depuis 2014.

Or, la version maximale de PHP pour CentOS6 est PHP 5.3.3, qui date de 2010.
Cela veut dire qu'il n'est pas possible d'updater PHP sur un serveur VPS OVH au delà de la version 5.3.

Pour information: cette version de PHP est la plus bugguée de toute l'histoire de PHP.
Elle n'est plus supportée par PHP depuis janvier 2013: http://php.net/supported-versions.php

Utiliser cette version de PHP représente un risque de sécurité MAJEUR.
Pire: la majorité des applications web ne fonctionnent pas sur cette version de PHP. C'est le cas par exemple de Joomla 3.

Ainsi, un serveur VPS OVH est IN-CA-PABLE de faire tourner out-of-the-box Joomla 3.


C'est un très gros problème. Personnellement, plutôt que de passer par des dépôts non officiels pour chercher à faire tourner PHP 5.6 sur mon VPS tout neuf, en risquant de faire sauter les modules PHP de Plesk: je réfléchis sérieusement à tout simplement commander un VPS chez un concurrent
.

J'ai beaucoup de respect pour le travail de haute qualité des équipes de OVH, et c'est pour cela que je prends la peine de venir vous prévenir. J'imagine qu'un grand nombre de professionnels confrontés à ce type problèmes se contente de rigoler et de faire une croix définitive sur OVH.

Car oui: offrir PHP 5.3 en 2016, c'est RI-DI-CULE.