OVH Community, votre nouvel espace communautaire.

Cluster010 vs version PHP 7.0.x : ça se balade entre 7.0.8 et 7.0.6 suivant les jours


doume
06/09/2016, 20h25
Merci pour l'explication.

Clt,
D.

adudouit
06/09/2016, 09h39
Pas si surprenant en fait, avec quelques éléments en plus : il est tout simplement en train d'être mis à jour.
Un cluster peut se modéliser sous la forme d'une (grande) ferme de machines, qui assurent une redondance et une disponibilité. Et plusieurs problèmes se présentent lorsqu'une mise à jour doit être déployée : volumétrie, suivi, etc..
La volumétrie engendrée par le déploiement des nouveaux paquets depuis les dépôts vers les machines pourrait avoir un impact en termes de charge réseau. Hors, depuis la mise en place des environnements d'exécution, c'est pire ! L'environnement étant séparé et indépendant du système fonctionnant sur la machine, le nœud de la ferme, il ne s'agit plus d'un simple "apt-get install", "emerge", etc. directement sur le nœud. Ce système a montré ses limites, en empêchant de le faire évoluer pour le maintenir. Par mesures de cohérence, de traçabilité et de stabilité, les mises à jour s'apparentent à une mise à jour de ce qui serait "l'image système" pour Docker ; un système d'exploitation entier, c'est dire ! , à installer sur chaque nœud de la ferme.

Cette façon de déployer en une "vague" une mise à jour a ses partisans et ses détraqueurs. Considérant qu'il ne s'agit que de mises à jour mineures en termes d'impact, des mises à jour de sécurité, calquées sur le modèles des mises à jour de la distribution Debian, l'hétérogénité - temporaire - de la ferme n'est pas un problème, et il en a été ainsi depuis longtemps (en apparté, les mises à jour plus impactantes seront réservées à l'environnement "testing").

doume
05/09/2016, 20h32
Bonjour,

Depuis le déploiement par OVH de PHP7.0.8 sur le cluster010, je constate que suivant les jours mon site (PHP7 + container.image=stable), mais aussi http://fpm7.0-check.cluster010.ovh.net/phpinfo.php , "se baladent" entre PHP7.0.8 et PHP7.0.6.
Non problématique pour moi fonctionnellement, mais étonnant.

Clt,
D.