OVH Community, votre nouvel espace communautaire.

Modem ZyXEL AMG1001 - redéfinition de SNR Cible


ndi76
23/09/2016, 20h25
Bonjour

Merci pour la réponse
Je vois bien le paramétrage IP sous Windows, pas de soucis

Ce que je ne vois pas c'est avec quelle IP j'attaque la configuration du modem s'il est en mode bridge ?
Son IP non routable de classe LAN ? Est elle encore active ?
L'IP'publique attribuée par OVH ?

Au pire n'est ce pas plus simple de faire un reset pour l'attaquer en mode classique puis restaurer la config ensuite ?
J'imagine qu'il y a une fonction backup ?

Merci

sergio_ovh
23/09/2016, 04h06
Il faut vérifier, la présence de la fonctionnalité NAT LOOPBACK , si je ne raconte pas d'idiotie ...

Un peu de lecture ici :
http://opensimulator.org/wiki/NAT_Loopback_Routers
https://www.google.fr/search?q=NAT+L...oopback+tomato

Tomato est un firmware, que tu peux installer sur une multitude de routeurs du marché qui ne coûtent pas cher, ça marche d'enfer, sur mes équipements. Le petit suisse, humour vache, est quand même destiné, à faire très bien la fonction modem, il vaut bien mieux acheter ensuite un petit routeur Linksys ou autre, sur lequel tu changes le firmware d'origine, par quelque chose de bien plus sérieux, et bien écrit. Tomato qui implémente le NAT LOOPBACK et des tas d'autres choses qui sont opérationnelles et bien testées , DD-WRT n'est pas génial, mais possède le mérite d'avoir à sa disposition une communauté d'utilisateurs disséminés dans le monde entier, et donc une base de questions et de réponses très fournie.

Sergio

sergio_ovh
23/09/2016, 03h41
Salut, ndi76

Avec simplement, deux cartes réseau dans un PC, 1 simple Windows sait gérer normalement l'accès , sur 2 pattes du LAN.
Ne pas trop jouer avec le feu, et l'adresse IP publique, ça peut permettre à un hacker boutonneux de perpétrer une attaque en règle
de ton réseau local.

Si tu veux faire des tests basiques, un PC sous Windows ( depuis des versions anciennes, XP, de mémoire ) est capable de communiquer avec une seule carte physique, sur 2 plages IP différentes du LAN.

Il ne s'agit pas d'une carte virtuelle, mais simplement d'un double adressage IP, sur une seule carte physique, il suffit d'ajouter sur la carte physique, plusieurs adresses.

Cela te permettra de faire tes tests, sans achat de matériel :

Aller dans Centre Réseau et Partage, choisir la connexion à configurer en cliquant dans le champ Connexions, sur la zone surlignée, une nouvelle fenêtre apparaît, clique ensuite sur le bouton Propriétés, sélectionner dans la liste le protocole, TCP/IPV4, appuyez sur le bouton Propriétés, une nouvelle fenêtre apparaît, choisir 'Utiliser l'adresse IP suivante' et renseigner les 3 champs, ensuite appuyer sur le bouton 'Avancé', une nouvelle fenêtre apparaît, là il suffit de finir et cliquer sur le bouton 'Ajouter' dans la zone Adresses IP. Validez autant de fois que nécessaire.
Ne rien faire d'exotique, ensuite, càd, vouloir jongler avec l'adresse de la passerelle par défaut.

Ce qu'il faut retenir, adressage multiple, mais routage unique, sinon, ça va 'se chier dessus' une carte physique <=> une passerelle, c'est la limite du test. Ceci dit, en câblant correctement, tu auras accès même si tu passes ton équipement en bridge, aux deux pattes de celui ci. CQFE <=> Ce qu'il fallait expliquer.

En espérant t'avoir éclairé, fais de bons tests.
Le mode bridge comporte des limitations, et le petit Zyxel aussi, je l'utilise de temps en temps ...

Sergio

ndi76
22/09/2016, 11h46
Citation Envoyé par teamasphalte
Cela dépend du routeur que tu utilise. Certains le permettes
Synology RT1900AC

Je suis très curieux de votre solution car j'avoue ne pas voir par quelle IP attaquer l'interface de configuration du modem...
l'IP publique ?

Merci

teamasphalte
22/09/2016, 11h26
Citation Envoyé par ndi76
..., car ensuite plus moyen d'accéder à l'interface de configuration ?
Cela dépend du routeur que tu utilise. Certains le permettes

ndi76
21/09/2016, 07h18
Merci pour ce partage d'information, je me suis du coup commandé ce modem

J'en profite au passage : avez vous passé le modem en mode bridge ?
Si oui c'est la dernière opération je suppose, car ensuite plus moyen d'accéder à l'interface de configuration ?

jrobin
06/09/2016, 16h06
Bon, en ben on y arrive ! Histoire de résoudre tout éventuel problème si quelqu'un galère aussi, et veut s'acheter le même modem, voilà tout ce que j'ai fait.

- Après avoir reflashé le Firmware original par dessus au cas où (AMG1001-T10A_100AAJL0C0.zip) - peut être pas nécéssaire
- Après avoir reflashé le RomFile original par dessus au cas où (AMG1001-T10A_100AAJL0C0.zip) - peut être pas nécéssaire

- Après m'être rendu compte que la touche d'effacement était un piège (elle fausse les commandes qu'on entre même si elles ont l'air bien corrigées)
- Après m'être rendu compte que la documentation originale constructeur du firmware était fausse (c'est bien la peine de faire une doc)
- Que certaines commandes étaient planquées même dans le telnet quand on fait help pour avoir la liste

J'ai enfin réussi a configurer le Zyxel AMG1001 à 6,0 dB de marge SNR en Download Et obtenu un débit de ~5700 kbps au lieu de ~4600 kbps avec ce modem, en mode G.DMT. C'est le même débit que j'obtiens sur la ligne Orange ADSL2+ quand je force le G.DMT aussi avec le même modem, donc c'est enfin correct.

En résumé :
Identifiants par défaut : admin / 1234
http://192.168.1.1

Telnet

Code:
Password: 1234
Copyright (c) 1994 - 2010 ZyXEL Communications Corp.
La commande est, pour une ligne qui prend 10dB par défaut, en G.DMT :

Code:
AMG1001-T10A> wan dmt set snrmoffset
usage: wan dmt set snrmoffset 

AMG1001-T10A> wan dmt set snrmoffset -2048
Set SNRM OFFSET = -4.0 db
(pour retenter la synchro sans avoir à retourner au cul du modem : wan adsl close)

Ca permet visiblement de fausser les valeurs reportées et auto-négociées de -4.0 dB, permettant d'avoir une synchronisation réelle à 6dB de SNR malgré toujours 10dB affichés. C'est un peu bidouille, m'enfin, ça serait évidemment plus facile avec des DSLAM réglés normalement

Sur les lignes qui ne sont pas en G.DMT mais en ADSL2+ (entre les deux je sais pas) la commande serait

Code:
AMG1001-T10A> wan dmt2 set snrmoffset
usage: wan dmt2 set snrmoffset [Intl*512] [Fast*512]
Et la détermination des deux valeurs serait un poil plus complexe. Néanmoins si on en croit le commentaire Amazon d'un abonné OVH ayant déjà joué avec ce modem sur une ligne d'environ 15 Mbit/s ça devra marcher aussi.

Pour info, j'ai trouvé les infos là dedans :
Code:
Problem: How to change noise margin on P660HW-T1v2.		
	
Solution: Here is an example to show the steps to change the noise margin.

Step1: Show the current noise margin;
 P-660HW-T> wan adsl linedata near
 noise margin downstream: 12 db
 output power upstream: 8 db
 attenuation downstream: 0 db
 tone   0- 31: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 tone  ..........

Step2: Delete CI command "wan dmt2 db tlb 10" in autoexec.net;
PS: Please reference other KB to edit the autoexec.net file.

Step3: Show current default offset value of noise margin;
 P-660HW-T> wan dmt2 show dmt
 ============= DMT SW setting =============
 %  txfltr_gain      = 0x8f9f4
 %  txfltr_type     = 0x1
 %  AGC reverb vref1, vref2, vref3 = 470  470  372
 %  rxfltr_type     = 0x2
 %  Loop length     = 0
 %  pilot tone      = 467
 %  watch tone      = 468
 %  TCM             = 1
 %  One Bit flag    = 1
 %  TargetNoiseMarg = 6144
 %  Sync flag       = 0
 %  echocancel flag = 0
 %  MOS             = 1280
 %  Budget MOS      = 0
 %  shapefilterflag = 1
 %  AGC clip counter= 255
 %  Rate4Sel= 0
 %  Rs= 1
 %  CG= 3738
 %  OlrCom= 1
 %  ModCG = 1
 %  ROS = 1536
 %  IntlSNRM= 1280 , FastSNRM= 1280
 %  force zero bit = 0
 %  ST SyncSym update = 0
 %  ST SyncSym Update Pattern = SEGUE

PS: This is in ADSL2/2+ mode. The default value is 1280.
If it's in ADSL mode, the CI command is "wan dmt show dmt".

Step4: Set new offset value of noise margin;
 P-660HW-T> wan dmt2 set snrmoffset 1792 1792
 offset = 1792/512    1792/512

PS:
If you want to increase 1 db, the new value should be 1280-(1*512)=768.
If you want to decrease 1 db, the new value should be 1280+(1*512)=1792.
If it's in ADSL mode, the command should be "wan dmt set xx xx".

Step5: Reset ADSL and check the result.
 P-660HW-T> wan adsl reset
 P-660HW-T> wan adsl linedata near
 noise margin downstream: 11 db
 output power upstream: 8 db
 attenuation downstream: 0 db
 tone   0- 31: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 tone  32- ...............

http://forum.kitz.co.uk/index.php?topic=11742.15
Afin que les modifications soient gardées au redémarrage du modem, il faut éditer un fichier appelé autoexec.net. On peut le restaurer en restaurant le RomFile.

sys view autoexec.net
sys edit autoexec.net

Les touches :
"n" permet de passer à la ligne suivante (elle s'affiche alors)
"r" permet de remplacer la dernière ligne qu'on a vu passer
"x" permet de sauver les modifs
"q" permet de quitter sans écrire les modifs
... attention, le retour comme quoi on a tapé "r" par exemple, ne s'affiche pas tant qu'on a pas commencé à écrire

J'ai été sur la dernière ligne et j'ai fait "i" pour Insert After; et j'y ai placé la commande, entrée, puis x

J'espère que ça aidera quelqu'un un jour !

Bon après mon débit upload est toujours dégradé de 30% mais bon, là je peux vraiment rien faire tant que l'opérateur de collecte sera pas un poil moins bête et borné a surlimiter pour rien des lignes déjà suffisamment limitées comme ça.

Bonne journée à tous

jrobin
04/09/2016, 16h16
Salut à tous,

Je relance un sujet avec un titre différent vu qu'il s'agit d'une question différente.
https://forum.ovh.com/showthread.php...sez-vous/page2
Il s'agit cette fois-ci d'utiliser des fonctionnalités embarqués dans des modems compatibles pour restaurer les 6dB de marge de bruit standard en ADSL, à la place de 10dB de marge fixés sur les collectes SFR (occasionnant une baisse de 30% de débit sur ma nouvelle ligne, en UP comme en Down)

Car en collecte SFR, OVH n'a pas totalement la main la dessus :
Le support OVH avait pu, autour du 8 Aout, mettre ma ligne sur un profil un peu meilleur - en download - 5376 kbps en Download forcé (le SNR résultant était alors d'environ 8dB). Mais... de 384 kbps fixes en envoi ! (Avec un SNR résultant de 21dB de marge UP, pour ceux qui aiment les chiffres)

J'ai donc fait marche arrière et demandé la réactivation du mode par défaut cette semaine (auto adaptatif "max", avec les limitations SFR quant à la modulation et à l’élévation de marge de bruit)
Et me suis procuré un ZyXEL AMG1001 pour rattraper moi même ce frustrant 10dB de marge au lieu de 6dB standard comme sur mon autre ligne.

-----------------------------------------------------------------

Ma question : quelle commande pour faire marcher le SNR tweaking sur le ZyXEL AMG1001 ?

ZyXEL AMG1001 : si j'ai bien cru comprendre, c'est le descendant d'un modem connu qui s'appelait P660 et qui proposait déjà à l'époque un levier sur le SNR cible. A en croire un commentaire Amazon d'une personne qui utilise OVH, ce modèle le fait aussi.

Problème : la commande ne fait rien !

"wan adsl targetnoise xxx"

Je suis parmi ces personnes qui ont tapé toutes les valeurs possibles et imaginables en vain au lieu de XX (y compris des gros mots)
Le modem indique que c'est (SNR Margin (dB) * 512) qu'il faut y mettre
La doc indique que c'est de -32 à +31
Un site indique que c'est de 0xfa à 0x06 par paliers de 0,5 dB (je suppose que c'est du "Moins N = N barre +1" pour les nombres négatifs, ce qui transforme bien 0xFA en -6 - )
J'ai également essayé des valeurs en hexadecimal 32 bits comme en décimal (en essayant avec 2048, -2048 etc...) car visiblement pour certaines commandes il faut mettre ça.

Tout, tout tout en vain. Il y a également une commande "wan adsl snroffset" qui ne fait rien de plus. J'ai essayé de déconnecter/reconnecter la ligne ADSL manuellement à chaque modification en vain, le débit résultant est toujours le même et le SNR aussi, en Up comme en Down.
Et le firmware est le même pour tout le monde, il s'agit actuellement du V100AAJL0C0, donc s'il y en a qui ont réussi c'est forcément que celui-ci peut le faire aussi.
La documentation officielle qui accompagne le firmware n'en indique pas plus.

-----------------------------------------------------------------

J'ai fini par tomber sur un Forum indiquant que si l'opération ne fonctionne pas, c'est que le DSLAM empêche le réglage... foutaise, ça marche avec un AH4222 (vieux modem Club-Internet plein de bugs) et avec la commande "adsl configure --snr 60".

D'où une seconde question : adsl configure --snr XX (chipsets Broadcom)
Sur le Technicolor, serait-il possible de demander au fabricant s'il pourrait faire marcher cette fonctionnalité ? Cette commande est connue pour fonctionner sur les chipsets Broadcom mais Technicolor semble ne pas l'avoir rendu disponible, c'est super dommage ! Sur les prochaines mises à jour ce serait vraiment cool de l'avoir.

Merci d'avance !